Crash happened during the install of oem mode

Bug #1537858 reported by Dave Morley on 2016-01-25
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
Adam Conrad

Bug Description

1. Setup kvm secure boot
2. Download the latest daily 14.04 iso
3. Install in OEM Mode
4. Check the boxes for 3rd party drivers and download updates from the internet
5. At some point the installer just crashes out

Installer to complete successfully and reboot into OEM Setup Mode

Installer threw up a window saying the installer had crashed

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: ubiquity
ProcVersionSignature: Ubuntu 4.2.0-26.31~14.04.1-generic 4.2.8-ckt1
Uname: Linux 4.2.0-26-generic x86_64
ApportVersion: 2.14.1-0ubuntu3.19
Architecture: amd64
CasperVersion: 1.340.2
Date: Mon Jan 25 18:13:30 2016
InstallCmdLine: BOOT_IMAGE=/casper/vmlinuz.efi file=/cdrom/preseed/ubuntu.seed boot=casper only-ubiquity quiet splash oem-config/enable=true --
LiveMediaBuild: Ubuntu 14.04.4 LTS "Trusty Tahr" - Beta amd64 (20160124)
 PATH=(custom, no user)
SourcePackage: ubiquity
UpgradeStatus: No upgrade log present (probably fresh install)

Dave Morley (davmor2) wrote :
Dave Morley (davmor2) wrote :

Just tried a normal install over an oem install and that worked fine so this is an issue specific to OEM mode.

description: updated
tags: added: qa-manual-testing regression-proposed

Exception during installation:
Jan 25 18:13:03 ubuntu / Traceback (most recent call last):
Jan 25 18:13:03 ubuntu / File "/usr/share/ubiquity/", line 1770, in <module>
Jan 25 18:13:03 ubuntu /
Jan 25 18:13:03 ubuntu / File "/usr/share/ubiquity/", line 78, in wrapper
Jan 25 18:13:03 ubuntu / func(self)
Jan 25 18:13:03 ubuntu / File "/usr/share/ubiquity/", line 221, in run
Jan 25 18:13:03 ubuntu / self.remove_unusable_kernels()
Jan 25 18:13:03 ubuntu / File "/usr/share/ubiquity/", line 801, in remove_unusable_kernels
Jan 25 18:13:03 ubuntu / self.do_install(install_kernels)
Jan 25 18:13:03 ubuntu / File "/usr/lib/ubiquity/ubiquity/", line 912, in do_install
Jan 25 18:13:03 ubuntu / mark_install(cache, pkg)
Jan 25 18:13:03 ubuntu / File "/usr/lib/ubiquity/ubiquity/", line 527, in mark_install
Jan 25 18:13:03 ubuntu / "Unable to install '%s' due to conflicts." % pkg)
Jan 25 18:13:03 ubuntu / ubiquity.install_misc.InstallStepError: Unable to install 'linux-signed-generic-lts-wily' due to conflicts.
Jan 25 18:13:03 ubuntu /

tags: added: installer-crash
Changed in ubiquity (Ubuntu):
importance: Undecided → High
Steve Langasek (vorlon) on 2016-01-25
Changed in ubiquity (Ubuntu):
assignee: nobody → Adam Conrad (adconrad)
Adam Conrad (adconrad) wrote :

I'm going to assume this is resolved in more recent trusty daily builds, but it would be lovely if someone could check for sure.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers