live install routine ubuntu 7.10BETA freezing

Bug #145836 reported by Raul on 2007-09-27
4
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: ubuntu-live

the live installer freezes (at 53%) when the live install routine tries to scan the disks (starting partitioner)

configuration in the setup:

video resolution, language, timezone, kbdtype
then installer freezes ...

Brian Murray (brian-murray) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Does the installer freeze or is it just the Live environment? Thanks in advance.

Changed in ubuntu-meta:
status: New → Incomplete

Hello.
Its a good question. I think the live environment freezes, because nothing
happens when I cancel the operation.
I can push "cancel" but, nothing happens when I want to reboot or when I
want to do something with the live library.

generally, live environment is always buggy with the "new" ATI cards (my:
x1950 pro agp 512MB).
My live environment freezes many times.
The hilariously thing is that the system will install only with a specific
configuration.
If i do not choose a THE specific config, it freezes.
If you need more help or you have specific questions, mail me.

good luck :)
Raul

2007/9/28, Brian Murray <email address hidden>:
>
> Thank you for taking the time to report this bug and helping to make
> Ubuntu better. Does the installer freeze or is it just the Live
> environment? Thanks in advance.
>
> ** Changed in: ubiquity (Ubuntu)
> Sourcepackagename: ubuntu-meta => ubiquity
> Status: New => Incomplete
>
> --
> live install routine ubuntu 7.10BETA freezing
> https://bugs.launchpad.net/bugs/145836
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Alex Mendez (martin-amendez) wrote :

Hi.

My live CD is doing the same thing except that the GUI has not stopped. I am using an Nvidia card though (Nvidia Geforce 6600 w/ 512 MB).

I can close the window that hangs at 53%, and I can also stop the installation. Running ubiquity in the terminal has no different effect. Starting the installer a second time, the installer hangs just before the "Scanning the Partitions" window is suppose to appear.

Since it stops at 53% on the partition detection, I should reveal that I have two hard drives, one 400GB SATA and one 240GB SATA. Windows XP Pro is installed on the 400GB (1 NTFS), Ubuntu 7.04 on the 240GB (2 partitions including the EXT3 and Swap).

I hope this helps,
Martin

RRamalho (rramalho-gmail) wrote :

Hi all,

I have *exactly* the same problem, on my machine.

It's a Pentium 4 2.8 on a Asus P4P800, with a GeForce 7600 GS, 2Gb of RAM, one SATA Drive and one PATA drive.
It has two more OSes installed, i do the manual configuration, configure it to format one partition, and then it hangs on the "Starting Partitioner" window.

It hangs in a way that i can't reboot. Only the reset button works! The GUI works (i can open apps and all), but when i try to reboot it hangs completely.

I hope this helps,
--
Ricardo

RRamalho (rramalho-gmail) wrote :

Oh... and i forgot... this happens on kubuntu 7.10 beta as well...

--
Ricardo

Brian Murray (brian-murray) wrote :

The full output of 'dmesg' after experiencing the freeze in the installation might be helpful. Additionally the log files asked for at https://wiki.ubuntu.com/DebuggingUbiquity/AttachingLogs would be quite useful. Thanks in advance.

Marvin (ubuntu-martinsen) wrote :

The same thing happens to me.

The installer stops at 53%, but I can close the installer and use the Live enviroment. I can also start gparted manually and partition my hard drives.

I have a ATI Raedon 9800, 2 harddrives 250GB and 500GB. On the 250GB there is installed windows XP and Ubuntu 7.04.

Marvin

RRamalho (rramalho-gmail) wrote :

Well... I've tried to install both ubuntu and kubuntu 7.10 beta on a vmware (fusion, OS X 10.4), and it worked flawlessly!

I will post the output of dmesg later in the day...

I do hope this ain't one ignored bug...

--
Ricardo

RRamalho (rramalho-gmail) wrote :

Well,

Here are the logs, as i promised!

Ricardo

RRamalho (rramalho-gmail) wrote :

And the /var/log/syslog

RRamalho (rramalho-gmail) wrote :

And the /var/log/installer/debug

Hope these help... :S

Changed in ubiquity:
importance: Undecided → Medium
status: Incomplete → Triaged
Gary (ygary2) wrote :

I have exactly a same problem. I believe the frozen process is from /lib/partman/init.d35/dump. The following line is frozen:

rm /var/log/partition_dump

The problem is for some reasons directory /var/log is locked (I can't even list files in the directory) when the installer is running.

My workaround is just comment the line before run the installer. It works.

Raul (raulr) wrote :

Hi
I've tested your workaround. It works fine.
/var/log is locked and you cannot list the files, like Gary said it.
BUT you have to comment out TWO lines (line 10 and 11). Both lines with the directory /var/log.

/lib/partman/35dump

...
# cat /var/log/partition_dump >>/var/log/partman
# rm /var/log/partition_dump
...

With this workaround MY installer isn't freezing anymore.

Raul (raulr) wrote :

sorry. wrong path.

file: /lib/partman/init.d/35dump

Colin Watson (cjwatson) wrote :

Please try a current daily build; unionfs was broken in the beta which could have had this sort of effect.

Colin Watson (cjwatson) wrote :

The workaround, by the way, cannot have any effect unless the filesystem is very badly broken, so I'd rather have the filesystem fixed than apply random workarounds (somebody else might easily have a different random workaround).

jehon (jeanhonlet) wrote :

I also get the problem under 9.04 installer 8.10 installer. Seems that my harddrive is not a common one.

For 8.10, I manipulated /lib/partman/init.d/35dump (removing the 2 lines of output in /tmp) and it worked fine. For 9.04, it was a bit more tricky!

By the way, here is the steps I used to get ubuntu installed anyway. I thought it could help anybody getting out of problems... This solution is a tricky one, "use at your own risk blablabla"

1/ trap the partman:
edit (as sudo) /bin/partman and /bin/partman-commit -> erase all content and remplace by "exit 0"

2/ make your partitions using gparted
you need at least one ext2/3/4 fs

3/ simulate the job of partman
One of the job of partman is mounting your target filesystem in /target
So, let's do it:
mkdir /target
mount /dev/sda2 /target

4/ run ubiquity as normal
It will complain after the keyboard selection layout, saying that you could destroy everything and disappear in a black hole if you continue, but continue anyway...

5/ generate your own fstab file in /target/etc/fstab

6/ Grub_update will fail (~97% of installation process)
Grub will not find the necessary data, update it manually...
cd /target
chroot /target update-grub /dev/sda
grub-install --root-directory=/target /dev/sda

7/ reboot

8/ when started:
- use "janitor" to clean up install...
- change keyboard option
- add other os's into /boot/grub/menu.lst

Well, now, if your followed all those instructions, and that you are lucky enough, you should get an up and running ubuntu! Otherwise...

Raul (raulr) on 2010-08-15
description: updated
Changed in ubiquity (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers