[Gutsy] LiveCD Install Hung on Partitioner 53%

Bug #145086 reported by nullack on 2007-09-26
8
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
Undecided
Colin Watson

Bug Description

Im using the LiveCD 25.2/9/7 for 32bit x86 on Ubuntu. The bug replicates on each attempt for my system. To replicate:

1. Boot live CD
2. Select install
3. Answer prompts as necessary and observe the commencement of a new window for setting up the partitioner
4. The partitioner gets to 53% and then hangs.

I'm on an i875 chipset board with a mix of pata and sata drives. There is three drives, one running EXT3 in three partitions and the other two discs on NTFS.

nullack (nullack) wrote :

Just remember the second drive with NTFS is a dynamic disk, not a basic disc if that helps.

Colin Watson (cjwatson) wrote :

Dynamic disks aren't supported yet; that could well be the problem.

Please attach /var/log/syslog and /var/log/partman from the installation session to this bug.

Changed in ubiquity:
status: New → Incomplete

Thank you Colin. I am on holidays currently so I will need to defer the logs
for a week when I return home. Please indicate if you would prefer me to try
the beta. I can say however that last night when my Gutsy daily did not
work, I installed Feisty 7.04 no problems on exactly the same hardware.
Perhaps Dynamic disc support was taken out in the release from then till
now?

Kev (nvous23) wrote :

I too am running into this problem, and theres only one drive. I had installed Kubuntu 7.10 Beta Last night just fine, and didn't really like KDE much, so Now im going back to regular ubuntu. I had Tribe5 ubuntu installed previously before Kubuntu 7.10 which also installed fine.

Chad D (tuxstorm) wrote :

I too have experienced the exact same issue.

My system only has one SATA drive and an Intel chipset.

I installed only days before using a daily build and that went without issue.

I was able to install the beta using the alternative image.

Colin Watson (cjwatson) wrote :

nullack: We've never had dynamic disk support, to my knowledge. I would be likely to know if it had been removed.

nullack (nullack) wrote :

 Sorry Colin I should be more specific. The dynamic disk is NTFS, on sata,
and I am not using that to install Ubuntu or fiddle with the partitions or
doing anything beyond mounting it for reading ntfs. I have an older pata
drive which is a basic disk that I have previously installed Feisty on,
which I have changed partitions with and so forth. On Feisty it worked no
problem installing to the pata basic disc and creating 3 primari partitions
for / home and swap.

On Gutsy I attempted to do the same thing within ubuquity install on the
same basic pata drive with the same 3 partitions and it hangs on 53%.

I am holidays currently but as soon as I return to my home I will post the
logs.

PS: Really do admire what Canonical is doing. Thanks so much for all the
work.

Tracker1 (tracker1) wrote :

I have just experienced the same issue... this is on an nVidia AMD chipset motherboard (ASUS M2NPV-VM) .. it was with a new Seagate Barracuda 80GB SATA drive. I wound up booting from an XP cd, and going as far as to let the installer partition the drive, reset on copying files.. then the partitioner seems to load properly... I'd say this is an important bug considering that one can't do an OEM install on a fresh/blank hard drive.

Colin Watson (cjwatson) wrote :

nullack: I'll need the logs I asked for above in order to get any further. If possible, I'd prefer to get this from a current daily build.

Tracker1: Please file a separate bug, and attach the logs I asked for in this one.

Kev (nvous23) wrote :

I've even re-installed windows xp, deleting any partition and formatting to NTFS in the process, 1 HDD, 1 Partition, then putting in the Live CD and trying to install, and Select English, Next, Select City, Next, Select U.S. English, Next, the Partitioner hangs at 53% of Scanning Disk.

nullack (nullack) wrote :

Colin as promised I gave this another test. However, due to another bug in the current ubiquity (https://bugs.launchpad.net/bugs/149810) I am unable to progress installation to get to the gparted point. I have had to do an alternative install to get gutsy happening on my system to do some testing beyond the installer. Once the other bug is fixed I will be able to retest this particular problem.

Colin Watson (cjwatson) wrote :

Kev: what CD build were you using?

showcaser (showcaser) wrote :

Same problem here, using the original beta CD.

I have two SATA drives on a RAID with windows and one PATA drive which i'm installing ubuntu on. The PATA has Feisty on the first half of the drive. I should note that 1 out of 3 it passes the 53% fine but then after step 8 (the summary) it hangs at 'Scanning disks' at 8%.

I attached the syslog file, the partman file seems inaccessible. Trying to browse /var/log or copy partman out of /var/log hangs the terminal.

I'll download the latest build today and see what happens tonight.

Colin Watson (cjwatson) wrote :

showcaser: Any luck with something current? At this point I'm not too interested in debugging the beta, since we've put out the release candidate :-)

Changed in ubiquity:
milestone: ubuntu-7.10-rc → ubuntu-7.10
showcaser (showcaser) wrote :

Good news, downloaded the RC DVD last night (i386) and it installed first try with no problems at all. It appears the issue is resolved although I could repeat the installation tonight to be sure.

Previously, it would always hang at one of the two 'scanning disks' stages mentioned above (first partitioning stage and at the start of the actual installation), and so I imagine the fact that it went through both first time round is most likely not by chance.

showcaser (showcaser) wrote :

Installed again with no problems.

Colin Watson (cjwatson) wrote :

Glad to hear it; thanks for re-testing!

Changed in ubiquity:
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments