"Force UEFI" dialog displayed if user selects custom partitioning

Bug #1447256 reported by Jean-Baptiste Lallement on 2015-04-22
36
This bug affects 8 people
Affects Status Importance Assigned to Milestone
One Hundred Papercuts
Low
Unassigned
Release Notes for Ubuntu
Undecided
Unassigned
ubiquity (Ubuntu)
Low
Unassigned

Bug Description

vivid desktop amd64 20150422

During installation on a blank disk on a UEFI system, if the user creates a custom partition, the installer displays the 'Force UEFI' dialog (screenshot) while there is no pre-installed system. This dialog is not displayed if the custom partitioner is not used.

ProblemType: Bug
DistroRelease: Ubuntu 15.04
Package: ubiquity 2.21.25
ProcVersionSignature: Ubuntu 3.19.0-15.15-generic 3.19.3
Uname: Linux 3.19.0-15-generic x86_64
ApportVersion: 2.17.2-0ubuntu1
Architecture: amd64
CasperVersion: 1.360
Date: Wed Apr 22 13:00:04 2015
InstallCmdLine: BOOT_IMAGE=/casper/vmlinuz.efi file=/cdrom/preseed/ubuntu.seed boot=casper only-ubiquity quiet splash ---
LiveMediaBuild: Ubuntu 15.04 "Vivid Vervet" - Release amd64 (20150422)
ProcEnviron:
 SHELL=/bin/bash
 TERM=linux
 PATH=(custom, no user)
 LANG=en_US.UTF-8
SourcePackage: ubiquity
UpgradeStatus: No upgrade log present (probably fresh install)

Jean-Baptiste Lallement (jibel) wrote :
Changed in ubuntu-release-notes:
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubiquity (Ubuntu):
status: New → Confirmed
Changed in ubiquity (Ubuntu):
importance: Undecided → Low
Changed in hundredpapercuts:
importance: Undecided → Low
status: New → Confirmed
Rod Smith (rodsmith) wrote :

I encountered the same bug when I performed an installation that used LVM (I selected the "Use LVM with the new Ubuntu installation" option). When I opened a shell and examined the partition table, it appears that it had already been created. (The disk was empty when I began.) The partition table resembled the one that resulted after I completed the installation, except that the to-be-ESP partition was set up as a Microsoft Basic Data partition, not as an ESP. (Screen shot attached.)

It should also be noted that the error message refers to installing Debian, not Ubuntu.

Overall, new users could be confused by this message. It deserves more than a documentation fix.

Simos Xenitellis  (simosx) wrote :

I am installing Ubuntu 15.10 (final) and I encountered this issue (exactly as described by the original poster).
This issue is mentioned in https://wiki.ubuntu.com/WilyWerewolf/ReleaseNotes as well, in the Known Issues section.

However, in my case the Force UEFI dialog cannot be closed, thus, it is not possible to continue the installation.

Simos Xenitellis  (simosx) wrote :

The installer is stuck at this dialog box. Neither button (Go Back or Continue) work.
The user is unable to complete the installation (and has to either reboot or kill ubiquity before trying again).

Simos Xenitellis  (simosx) wrote :

Workaround #1:
Create partition table using "gparted".
Create one 200MB partition with filesystem FAT32. Then click Appy so that "gparted" applies the change.
Then, change the flag of the partition (right-click on partition, then Manage Flags) in order to add the "efi" flag.
Save and exit.
It should be possible to using the installer (ubiquity) and complete the installation.

Workaround #2:
Do not use the "Something else" option in the installer.

Rod Smith (rodsmith) wrote :

I've confirmed Simos's observation. I've identified two variants of the problem, doing a test installation under VirtualBox:

1) The disk is unpartitioned (either with no partition table or with a GPT in which no partitions are defined) when ubiquity is launched. In this case, the error message appears AFTER the manual partitioning screen. Importantly, it does not appear to be possible to continue past this error in this case; both the "Continue" and "Go back" buttons are unresponsive. Thus, the claim in the release notes that this bug "is harmless since... you can proceed with the installation" is flat-out wrong.
2) The disk contains at least one partition when ubiquity is launched. (I tested with a single partition flagged as an ESP, but holding no filesystem.) In this case, the error appears BEFORE the manual partitioning screen, and the "Continue" button works. (I didn't test the "Go back" button.) In this case, the error is confusing but is not nearly so important.

Because there seems to be no way out in the first case except to terminate ubiquity (by rebooting or using command-line tools to kill the process), and because the only fix is the (non-obvious) workaround of creating a partition table and at least one partition, I consider this bug to be serious.

Marc Pignat (swid) wrote :

IMHO, a bug preventing installation should be "critical" or "release-critical"

Jesse (jesse-crayston) wrote :

So I'm able to get around this, but is there anything I can add to my preseed to answer this in advance?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers