The installation window was not shown completely with vivid-desktop-amd64-20150408 on hidpi laptop

Bug #1443767 reported by Bruce.Ma on 2015-04-14
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
OEM Priority Project
Undecided
Unassigned
Trusty
Undecided
Unassigned
Unity Settings Daemon
New
Undecided
Unassigned
ubiquity (Ubuntu)
Undecided
Unassigned
unity-settings-daemon (Ubuntu)
Undecided
Unassigned

Bug Description

1. Burn vivid-desktop-amd64-20150408.iso to USB stick.
2. Boot from USB stick to install the ubuntu.
3. The window "Keyboard layout" wasn't shown complete on hidpi laptop.

Related branches

Bruce.Ma (bruce.ma) wrote :

The screenshot.

Sebastien Bacher (seb128) wrote :

Thanks Bruce, that seems a bit overscaled. What's the resolution of the screen?

Bruce.Ma (bruce.ma) wrote :

The resolution is "2560x1440".

Sebastien Bacher (seb128) wrote :

hum, I wonder if that really should be considered as hidpi, 1440 is a bit small for doubling vertically, it means the UI needs to fit on 720 pixels (also your screen makes widgets look bigger than they should). What is the screen size in mm?

Bruce.Ma (bruce.ma) wrote :

The screen size is 310mm x 174mm.

Sebastien Bacher (seb128) wrote :

The first installer screenshot was from the install only mode, do you get the same issue if you run ubiquity from the live session? The text is quite big on that screenshot it looks like more than double size on a "2560x1440" resolution

Bruce.Ma (bruce.ma) wrote :

If I run the ubiquity from the live session , then the windows was not scaled like #4.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubiquity (Ubuntu):
status: New → Confirmed
Colin Watson (cjwatson) on 2015-05-14
no longer affects: ubiquity
Lars Karlitski (larsu) wrote :

> The screen size is 310mm x 174mm.

That gives a DPI of 209. I don't think we should enable hidpi for this resolution. 1280×720 is very small for today's apps.

Unity-settings-daemon enables hidpi starting from 192 dpi. I suggest raising that to at least 220 or so. Wikipedia says HIDPI is around 213-240 dpi.

Bin Li (binli) wrote :

Lars,

 Yes, I agree with your idea, we should adjust the hidpi from a higher value, is it ok that we change DPI_FALLBACK to 110, or change HIDPI_LIMIT directly? Thanks!

Phillip Susi (psusi) wrote :

@Lars: Seeing as how *normal* is only 96 dpi, 192 seems a pretty darn good spot to call high. If anything it should be lower than that.

@Bin: He was saying the opposite of that: that the limit is too low and should be higher.

Bin Li (binli) wrote :

@PHillip,

 Here is Lars' comment, https://code.launchpad.net/~binli/unity-settings-daemon/dont-scale-out-of-screen/+merge/268881/comments/679173

@Lars,

 What is the best way to fix it? Thanks!

Ara Pulido (ara) wrote :

I have confirmed with the original reporters that these issues are fixed in Xenial

Changed in ubiquity (Ubuntu):
status: Confirmed → Fix Released
Changed in unity-settings-daemon (Ubuntu):
status: New → Fix Released
Changed in oem-priority:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers