[Kubuntu 15.04 beta] Failed to format ext4 partition in the installation

Bug #1443692 reported by YAFU on 2015-04-13
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
Undecided
Unassigned

Bug Description

Kubuntu 15.04 64 bits (Vivid Vervet) from daily build 08/04/2015.

$ lsb_release -rd
Description: Ubuntu Vivid Vervet (development branch)
Release: 15.04

$ apt-cache policy ubiquity
ubiquity:
  Instalados: (ninguno)
  Candidato: 2.21.18
  Tabla de versión:
     2.21.18 0
        500 http://ar.archive.ubuntu.com/ubuntu/ vivid/main amd64 Packages
==========
Disk /dev/sda: 149,1 GiB, 160041885696 bytes, 312581808 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0xf069f069

Device Boot Start End Sectors Size Id Type
/dev/sda1 * 63 20547134 20547072 9,8G 7 HPFS/NTFS/exFAT
/dev/sda2 20547584 61431807 40884224 19,5G 83 Linux
/dev/sda3 61432684 312576704 251144021 119,8G f W95 Ext'd (LBA)
/dev/sda5 61432686 110983167 49550482 23,6G 83 Linux
/dev/sda6 110985216 125386751 14401536 6,9G 83 Linux
/dev/sda7 125387388 188313929 62926542 30G 83 Linux
/dev/sda8 188313993 284784254 96470262 46G b W95 FAT32
/dev/sda9 284784318 302295104 17510787 8,4G 7 HPFS/NTFS/exFAT
/dev/sda10 302295168 306388991 4093824 2G 7 HPFS/NTFS/exFAT
/dev/sda11 306391743 312576704 6184962 3G 82 Linux swap / Solaris
=========
=====
=

The partition in question is "sda2".

"sda2" previously existed and had data on it. I had selected Kubuntu manual disk installation as usual, and I chose formatted "sda2" as ext4 and mount as "/". When it began installing it remained static at 33% without progress. Then I tried from KDE "partitionmanager" from the LiveDVD and trying to delete and format "sda2" as ext4 and it also failed with the following message:
==
KDE Partition Manager: SMART Status Report
Date: 4/12/15 7:41 PM
Program version: 1.2.1
Backend: pmlibpartedbackendplugin (1)
KDE Frameworks version: 5.7.0
Machine: Linux kubuntu 3.19.0-12-generic #12-Ubuntu SMP Fri Apr 3 04:03:26 UTC 2015 x86_64

Delete partition ‘/dev/sda2’ (19.50 GiB, unknown)
Job: Delete file system on ‘/dev/sda2’
Delete file system on ‘/dev/sda2’: Success
Job: Delete the partition ‘/dev/sda2’
Delete the partition ‘/dev/sda2’: Success
Delete partition ‘/dev/sda2’ (19.50 GiB, unknown): Success
Create a new partition (19.50 GiB, ext4) on ‘/dev/sda’
Job: Create new partition on device ‘/dev/sda’
Create new partition ‘/dev/sda2’: Success
Job: Create file system ‘ext4’ on partition ‘/dev/sda2’
Command: mkfs.ext4 -q /dev/sda2

Proceed anyway? (y,n)

Create file system ‘ext4’ on partition ‘/dev/sda2’: Error
Create a new partition (19.50 GiB, ext4) on ‘/dev/sda’: Error
==
So I entered to my 14.04 installation, and I could delete and format "sda2" as ext4 from GParted. After this the Kubuntu 15.04 installation was successful only selecting "sda2" as "/" without format the partition.

YAFU (yafu) wrote :

I do not know how to add to the report also to KDE "partitionmanager" as affected.

YAFU (yafu) wrote :

The problem seems to be solved according to comments on this related thread:
https://www.kubuntuforums.net/showthread.php?67845-Installer-stops-at-33

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubiquity (Ubuntu):
status: New → Confirmed
Waz (paviluf) wrote :

Same problem here. If I select Kubuntu manual disk installation and try to format "sdaX" for "/" the installation is stuck at 33%

The Kubuntu 15.04 installation was successful only when selecting "sdaX" as "/" without format the partition.

Kirsch (6-ubuntu-com) wrote :

I have exactly the same problem on Kubuntu 15.10.

Installer stopped, when format the root-partition.
Installer run "mkfs.ext4 /dev/sdaX". When i run this command manually, it ask my to press 'j' ("Ja", German for yes).
I send this Key to the process. After that Installer continue.

kubuntu@kubuntu:~$ ps -Alf
[...]
0 S root 31995 31975 0 80 0 - 1614 poll_s 11:37 ? 00:00:00 log-output -t partman --pass-stdout mkfs.ext4 /dev/sda7
0 S root 31996 31995 0 80 0 - 5492 pipe_w 11:37 ? 00:00:00 mkfs.ext4 /dev/sda7
[...]

kubuntu@kubuntu:~$ sudo mkfs.ext4 /dev/sda7
mke2fs 1.42.12 (29-Aug-2014)
/dev/sda7 hat ein ext4-Dateisystem
        zuletzt auf / auf Sat Oct 3 13:47:59 2015
 eingehängtTrotzdem fortfahren? (j,n)
[CTRL+C]

kubuntu@kubuntu:~$ sudo bash
root@kubuntu:~# echo "j" > /proc/31996/fd/0

Bruno Loff (bloff-sites) wrote :

Had the same problem. The problem seems to happen when installing ubuntu on an already existing filesystem. In that situation, mkfs.ext4 will prompt the user with:

/dev/sdc1 contains a ext4 file system
        last mounted on /boot on Sat Nov 14 06:38:38 2015
Proceed anyway? (y,n)

And ubiquity will not answer this. Kirsch's solution works great.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers