Desktop Icons show on the install only desktop

Bug #1437180 reported by Elfy on 2015-03-27
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
One Hundred Papercuts
Low
Unassigned
ubiquity (Ubuntu)
Medium
Sean Davis

Bug Description

Desktop Icons show on the install only desktop

Should be an empty desktop behind the installer.

ProblemType: Bug
DistroRelease: Ubuntu 15.04
Package: xubuntu-default-settings 15.04.4
ProcVersionSignature: Ubuntu 3.19.0-10.10-generic 3.19.2
Uname: Linux 3.19.0-10-generic x86_64
ApportVersion: 2.16.2-0ubuntu4
Architecture: amd64
CasperVersion: 1.356
Date: Fri Mar 27 07:39:23 2015
LiveMediaBuild: Xubuntu 15.04 "Vivid Vervet" - Beta amd64 (20150326)
PackageArchitecture: all
ProcEnviron:
 SHELL=/bin/bash
 TERM=linux
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 XDG_RUNTIME_DIR=<set>
SourcePackage: xubuntu-default-settings
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Elfy (elfy) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xubuntu-default-settings (Ubuntu):
status: New → Confirmed
Simon Steinbeiß (ochosi) wrote :

I can confirm the regression, which seems to have been introduced by an update of xfdesktop, so maybe there is something we can do to work around the icons being displayed.

Other than that I guess the only way to fix this for 15.10 would be to use something else to draw the background, e.h. feh.

Simon Steinbeiß (ochosi) wrote :

Actually, one quick way to work around this problem would be to patch ubiquity-dm to execute this line after (or even before) launching xfdesktop:
"xfconf-query -c xfce4-desktop -p /desktop-icons/style -s 0"

http://bazaar.launchpad.net/~ubuntu-installer/ubiquity/trunk/view/head:/bin/ubiquity-dm#L530

Simon Steinbeiß (ochosi) wrote :

The attached diff is the workaround I mentioned in my previous comment.

The attachment "Diff of the workaround" seems to be a patch. If it isn't, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are a member of the ~ubuntu-reviewers, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issues please contact him.]

tags: added: patch
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1437180

tags: added: iso-testing
Changed in hundredpapercuts:
status: New → Confirmed
Changed in xubuntu-default-settings (Ubuntu):
importance: Undecided → Low
Changed in hundredpapercuts:
importance: Undecided → Low
affects: xubuntu-default-settings → ubiquity
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

affects: ubiquity → ubiquity (Ubuntu)
Changed in ubiquity (Ubuntu):
status: New → Confirmed
tags: added: xubuntu

Would it not be simpler to not run xfdesktop, assuming that's what makes the icons show up? Unless it's also what draws the wallpaper?

Changed in ubiquity (Ubuntu):
status: New → Triaged
importance: Undecided → Medium

Since the problem is probably not -default-settings related, and directly something to do in ubiquity-dm, I'm making the xubuntu-default-settings task Invalid.

Changed in xubuntu-default-settings (Ubuntu):
status: Confirmed → Invalid

I've tried to use the patch in ubiquity-dm, but icons are still appearing. Seems like it might not be running at the right point in time?

Sean Davis (bluesabre) wrote :

Linked a new branch. With this, feh is to be used to draw the ubiquity-dm wallpaper with Xfce.

xubuntu-meta has already been updated to include feh on the live seed. Any other Xfce flavors or derivatives will need to follow suit.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 2.21.28

---------------
ubiquity (2.21.28) wily; urgency=medium

  [ Sean Davis ]
  * bin/ubiquity-dm: Draw the ubiquity desktop with feh under
    Xfce environments (LP: #1437180)

  [ Mathieu Trudel-Lapierre ]
  * Automatic update of included source packages: apt-setup
    1:0.80ubuntu8, base-installer 1.144ubuntu2, flash-kernel
    3.0~rc.4ubuntu55, hw-detect 1.95ubuntu7, partconf 1.48, partman-base
    187ubuntu1, partman-basicmethods 60, partman-jfs 46, partman-lvm
    110, partman-newworld 33, partman-xfs 56, user-setup 1.48ubuntu6.
  * Update timezone map to add North Korea (Pyongyang time). (LP: #1462688)
  * Fix instances of PEP8 warning: W503 line break before binary operator.
  * Ignore the PEP8 error E402 (imports at beginning of file). There are a few
    instances where we need to set sys.path to where ubiquity files are.
  * Fix some more style errors from PEP8.
  * autogen.sh: Use any available version of automake/aclocal.

  [ Luke Yelavich ]
  * ubiquity/frontend/gtk_ui.py: We do not want to be able to focus labels
    with Orca at all. It negatively affects the install experience and
    tab/shift tab flow through the installer pages, and prevents Orca
    presenting label relationships with other widgets

  [ Max Brustkern ]
  * Update the automated autopilot installation in the vm: get the updated
    sources.list picked up by hooks by being in the right location.

 -- Mathieu Trudel-Lapierre <email address hidden> Tue, 08 Sep 2015 10:58:17 -0400

Changed in ubiquity (Ubuntu):
status: Triaged → Fix Released
Pasi Lallinaho (knome) on 2015-09-08
Changed in ubiquity (Ubuntu):
assignee: nobody → Sean Davis (bluesabre)
no longer affects: xubuntu-default-settings (Ubuntu)
Changed in hundredpapercuts:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers