partman crashes when trying to make a EFI partition

Bug #1428877 reported by Aaron Honeycutt on 2015-03-05
30
This bug affects 5 people
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
Medium
Mathieu Trudel-Lapierre
Vivid
Medium
Mathieu Trudel-Lapierre

Bug Description

Trying to install Beta 1 of Kubuntu 15.04 into a UEFI active system (safe boot is off and has Ubuntu 14.10 working fine)

ProblemType: Bug
DistroRelease: Ubuntu 15.04
Package: ubiquity 2.21.13
ProcVersionSignature: Ubuntu 3.18.0-13.14-generic 3.18.5
Uname: Linux 3.18.0-13-generic x86_64
ApportVersion: 2.16.1-0ubuntu2
Architecture: amd64
CasperVersion: 1.351
CurrentDesktop: KDE
Date: Thu Mar 5 20:28:42 2015
InstallCmdLine: BOOT_IMAGE=/casper/vmlinuz.efi file=/cdrom/preseed/kubuntu.seed boot=casper maybe-ubiquity quiet splash --
LiveMediaBuild: Kubuntu 15.04 "Vivid Vervet" - Alpha amd64 (20150224.1)
SourcePackage: ubiquity
UpgradeStatus: No upgrade log present (probably fresh install)

I got past this bug as it seems the partitioner has a problem making a efi partition and/or formatting a partition into a efi partition. I moved though it by using fdisk to format the fat32 into efi and then going though the installer normally.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubiquity (Ubuntu):
status: New → Confirmed
Changed in ubiquity (Ubuntu):
importance: Undecided → Critical
status: Confirmed → Triaged
tags: added: rls-v-incoming
Changed in ubiquity (Ubuntu):
assignee: nobody → Parth Panchal (parthpanchl)
Phillip Susi (psusi) wrote :

Please don't assign bugs to yourself unless you are a developer who is going to fix it.

Changed in ubiquity (Ubuntu):
assignee: Parth Panchal (parthpanchl) → nobody
Brian Murray (brian-murray) wrote :

Setting to high due to lack of duplicate reports.

Changed in ubiquity (Ubuntu):
importance: Critical → High
Brian Murray (brian-murray) wrote :

The traceback is in UbiquityDebug.txt:

Traceback (most recent call last):
  File "/usr/lib/ubiquity/ubiquity/filteredcommand.py", line 145, in process_line
    return self.dbfilter.process_line()
  File "/usr/lib/ubiquity/ubiquity/debconffilter.py", line 287, in process_line
    if not input_widgets[0].run(priority, question):
  File "/usr/lib/ubiquity/plugins/ubi-partman.py", line 3088, in run
    None, request['method'])
  File "/usr/lib/ubiquity/plugins/ubi-partman.py", line 1738, in preseed_script
    question, menu_options, want_script, want_arg)
  File "/usr/lib/ubiquity/plugins/ubi-partman.py", line 1733, in must_find_one_script
    (question, want_script, want_arg))
ubi-partman.PartmanOptionError: partman-target/choose_method should have None (efi) option

Ryuichi UENO (ryu-the-first) wrote :

I encountered a same bug when trying to install Ubuntu 15.04 into HP Stream Mini 200-020( storage: Transcend TS64GMTS400 M.2. SSD) using daily build ISO image(Apr 4) .

Changed in ubiquity (Ubuntu Vivid):
milestone: none → ubuntu-15.04
tags: removed: rls-v-incoming
Changed in ubiquity (Ubuntu Vivid):
assignee: nobody → Mathieu Trudel-Lapierre (mathieu-tl)
status: Triaged → In Progress
Ryuichi UENO (ryu-the-first) wrote :

I tried install again with Ubuntu 15.04 daily build ISO image(Apr 17).

System is HP Stream Mini 200-020(32 GB M.2. SSD, same as comment #9). OS is not installed in disk. Secure boot and Fast boot are enabled.

- select "something else" at Installation type.
- After that, make EFI system partition(ESP), ext4(rootfs), and swap manually.
- install appears to complete, and prompts for reboot.
- remove USB drive and press Enter, reboot normaly.
- I do not get "ubi-partman crashed" message such as [1] during installation.

I seem issue may be 'fixed'.

(But I still get the "Force UEFI installation" message[2][3] yet.)

[1] https://bugs.launchpad.net/ubuntu/+source/ubiquity/+bug/1428877/+attachment/4335681/+files/partmancrase.png
[2] https://launchpadlibrarian.net/196734906/Screenshot%20from%202015-02-05%2012%3A13%3A29.png
[3] https://launchpadlibrarian.net/199485341/forceuefi.png

Martin Pitt (pitti) wrote :

We have a big warning when you try to do an EFI install on top of an already existing non-EFI install (see the screen shot). So this isn't a serious release blocker, and nothing new.

Changed in ubiquity (Ubuntu Vivid):
milestone: ubuntu-15.04 → none
importance: High → Medium
milestone: none → ubuntu-15.04
milestone: ubuntu-15.04 → none

Aaron, could you please confirm whether this was indeed fixed? I made changes to better handle installing in EFI mode; and hopefully your use case is fixed so we can close this bug report, but I know some very specific uses cases (especially when it comes to purely manual partitioning) might not be fully covered.

Thanks.

Changed in ubiquity (Ubuntu):
status: In Progress → Triaged
Changed in ubiquity (Ubuntu Vivid):
status: In Progress → Incomplete

I'm not at a point where I can reinstall to test. I'll test this weekend.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers