Crash after selecting timezone with non-US locale

Bug #1403914 reported by Mikhail Ivchenko on 2014-12-18
56
This bug affects 11 people
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
High
Unassigned
Vivid
High
Unassigned

Bug Description

Latest Kubuntu Vivid alpha.
Ubiquity 2.21.1

Steps to reproduce:
1) Set locale to "Russian" (reproducible also with French, Ukrainian at least)
2) Click next
3) Use default settings and click next.
4) Timezone selection. Use suggested timezone and click next
5) Crash.

Reproducible: always.

At least, Belarusian language is not affected.

ProblemType: Bug
DistroRelease: Ubuntu 15.04
Package: ubiquity 2.21.1
ProcVersionSignature: Ubuntu 3.16.0-28.38-generic 3.16.7-ckt1
Uname: Linux 3.16.0-28-generic x86_64
ApportVersion: 2.15-0ubuntu3
Architecture: amd64
CasperVersion: 1.347
Date: Thu Dec 18 19:48:03 2014
ExecutablePath: /usr/lib/ubiquity/bin/ubiquity
InstallCmdLine: file=/cdrom/preseed/kubuntu.seed boot=casper maybe-ubiquity initrd=/casper/initrd.lz quiet splash -- maybe-ubiquity
InterpreterPath: /usr/bin/python3.4
LiveMediaBuild: Kubuntu 15.04 "Vivid Vervet" - Alpha amd64 (20141218)
ProcEnviron:
 LANGUAGE=
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: ubiquity
UpgradeStatus: No upgrade log present (probably fresh install)

Mikhail Ivchenko (egormatirov) wrote :
Jonathan Riddell (jr) on 2014-12-18
Changed in ubiquity (Ubuntu):
milestone: none → ubuntu-15.04
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1403914

tags: added: iso-testing
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubiquity (Ubuntu):
status: New → Confirmed
Changed in ubiquity (Ubuntu):
importance: Undecided → High
importance: High → Critical
Changed in ubiquity (Ubuntu Vivid):
status: Confirmed → Triaged

I can't reproduce this, and it certainly doesn't sound like a Critical bug if it "only" affects users of specific languages. Setting to Incomplete, and reducing importance to "High".

Can anyone still reproduce this issue?

FWIW, I tried with both French and Russian, using the automatic timezone (Toronto here), but also a randomly-picked timezone in Asia.

Changed in ubiquity (Ubuntu Vivid):
importance: Critical → High
status: Triaged → Incomplete
Turbo (axelhc) wrote :

Hi. Can confirm that Latin American countries are also affected. The only way to install Kubuntu 15.04 with no crash is changing the zone to US.

Paul Konecny (paul-konecny) wrote :

Same here. Please fix.

Jonathan Riddell (jr) wrote :

I installed 20150326 ISO in russian and used the default timezone and it installed fine

Jonathan Riddell (jr) wrote :

Tried installing in Russian with and without network access. It changes the default timezone from Russian to Spain (where I'm based) with internet but still no crash.

Paul Konecny (paul-konecny) wrote :

Reproducible on Beta2
I booted with F2 --> language --> German
Ubiquity used the German/Austrian locale to install and crashed at "configuring Hardware 66%"
See attachment.

Jonathan Riddell (jr) wrote :

On today's vivid daily I set at the isolinux boot screen F2 → Language → Russian (russian is written in a different alphabet of course).

I boot and click to Try Kubuntu (written in russian), run ubiquity, it successfully runs through to the end including selecting timezone
This still works if I select Toronto timezone

I have also successfully installed in German using Austrian timezone and keyboard. I suspect Paul's bug from comment #10 is unrealated (if you can recreate please use ubuntu-bug ubiquity to report after the crash).

Paul Konecny (paul-konecny) wrote :

I tried to install it in vbox earlier. On actual hardware it works. Seems to me that plasma 5 doesn't like vbox. My bad, sorry.

Jonathan Riddell (jr) on 2015-04-22
Changed in ubiquity (Ubuntu Vivid):
status: Incomplete → Invalid
Martin Pitt (pitti) on 2015-04-22
Changed in ubiquity (Ubuntu Vivid):
milestone: ubuntu-15.04 → none
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers