Ubiquity crashes during installation

Bug #1401328 reported by Ian Nicholson on 2014-12-11
14
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
High
Unassigned
Vivid
High
Unassigned

Bug Description

This occurs for me with both the 14.10 and 15.04 installers. The crash happens around the time that the installer is downloading updates.

ProblemType: Bug
DistroRelease: Ubuntu 15.04
Package: ubiquity 2.21.1
ProcVersionSignature: Ubuntu 3.16.0-25.33-generic 3.16.7
Uname: Linux 3.16.0-25-generic x86_64
ApportVersion: 2.14.7-0ubuntu10
Architecture: amd64
CasperVersion: 1.346
Date: Wed Dec 10 18:32:15 2014
InstallCmdLine: BOOT_IMAGE=/casper/vmlinuz.efi file=/cdrom/preseed/ubuntu.seed boot=casper quiet splash --
LiveMediaBuild: Ubuntu 15.04 "Vivid Vervet" - Alpha amd64 (20141210)
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: ubiquity
UpgradeStatus: No upgrade log present (probably fresh install)

Ian Nicholson (imnichol) wrote :
Ian Nicholson (imnichol) wrote :
Ian Nicholson (imnichol) wrote :
Ian Nicholson (imnichol) wrote :

I was able to work around this by disabling home folder encryption, but that's far from an optimal fix.

Exception during installation:
Dec 11 00:32:08 ubuntu /plugininstall.py: Traceback (most recent call last):
Dec 11 00:32:08 ubuntu /plugininstall.py: File "/usr/share/ubiquity/plugininstall.py", line 1770, in <module>
Dec 11 00:32:08 ubuntu /plugininstall.py: install.run()
Dec 11 00:32:08 ubuntu /plugininstall.py: File "/usr/share/ubiquity/plugininstall.py", line 78, in wrapper
Dec 11 00:32:08 ubuntu /plugininstall.py: func(self)
Dec 11 00:32:08 ubuntu /plugininstall.py: File "/usr/share/ubiquity/plugininstall.py", line 204, in run
Dec 11 00:32:08 ubuntu /plugininstall.py: self.configure_plugins()
Dec 11 00:32:08 ubuntu /plugininstall.py: File "/usr/share/ubiquity/plugininstall.py", line 570, in configure_plugins
Dec 11 00:32:08 ubuntu /plugininstall.py: self.run_plugin(plugin)
Dec 11 00:32:08 ubuntu /plugininstall.py: File "/usr/share/ubiquity/plugininstall.py", line 547, in run_plugin
Dec 11 00:32:08 ubuntu /plugininstall.py: "Plugin %s failed with code %s" % (plugin.NAME, ret))
Dec 11 00:32:08 ubuntu /plugininstall.py: ubiquity.install_misc.InstallStepError: Plugin usersetup failed with code 1
Dec 11 00:32:08 ubuntu /plugininstall.py:

tags: added: installer-crash
Brian Murray (brian-murray) wrote :

This is likely relevant:

Dec 11 00:32:08 ubuntu user-setup: Copying files from `/etc/skel' ...
Dec 11 00:32:08 ubuntu ubiquity: chpasswd: (user ian) pam_chauthtok() failed, error:
Dec 11 00:32:08 ubuntu ubiquity: Permission denied
Dec 11 00:32:08 ubuntu ubiquity: chpasswd: (line 1, user ian) password not changed

Changed in ubiquity (Ubuntu):
importance: Undecided → High
Ian Nicholson (imnichol) wrote :

This also occurrs in 14.10, I didn't bother trying 14.04.

tags: added: utopic

Hello Ian,

Have you tried this recently? Is it still an issue?

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

On 04/16/2015 11:16 AM, Mathieu Trudel-Lapierre wrote:
> Hello Ian,
>
> Have you tried this recently? Is it still an issue?
>

No, I don't have any spare hardware to test it on. I'll try and see
if I can replicate it in a VM.

- --
Ian Nicholson
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1

iQIcBAEBAgAGBQJVMB/tAAoJEBwDRDHt9Q7mxJcQAICHvAlUiWAK988XsUSd8uz/
cQO9F9BouiAnkieB24g37eIduXUZPyHvn6LS6En6J+MChb2MbDkE8Sg1smjM19D6
du2BDRRNx0UR19P/y4oqtzBsS+aPF0qLuCUeG5beKuMy/BTVYn+e3sCXrW3sjbCT
Rb/ScsbwOCr6J/gQB9+H1YvV2FdT89HVUyFJB8LcnW4IK9I2UfIpVltAHtnSHr+1
KXjiy7W+6cxqYuTAtVHqmVcbpKxSJ85CjX9KpCa7uaHHVvmEtwjg/blh1A3RGAjq
DqHXZvgi8bbKXLKwk+3mhmG96bao5ajJoJkwzKmijCj/TaSU+nEghQkr9ZeNmo8E
A2uDxYatznHQk6joRWiIgo3QRXD2bRCA0PnVyNiEe1ktevpVzVLs1GqI3VXBvMce
6rACyQxGhHlwmLVfe4ofFjSVcpkudcsO9/OX1Oe52SQdQ+YUR3EpdZxmosc97TEN
ZevKL55LxGd+bMbRE/6YsUFg9XCTMJTFSXO75EC8/DASyjZwe2pply4Bwqgzi+Zv
0O1y9VNcgpeGN4ffW5gH3zxOGMmLYGl5HyZpfdG7AdXLY+HwCyA7kgDhpH7GyPcV
zMkj8a4AGOMbagVcVlHaAat04G0VvTol1Ka7KbKmbMQJZ0dJ1CcrKS6xyNH7gy9K
HfmaGpsaphzgV8KVbMex
=2owZ
-----END PGP SIGNATURE-----

Ihatewindows (ihatewindows522) wrote :

Having an issue with the Vivid installer doing the same thing, only there's no encryption involved, and the home folder is specified to be in the same Ubuntu partition.

Didn't have any issues with Utopic.

Marking as Incomplete until we can reproduce this in a VM.

Changed in ubiquity (Ubuntu):
status: New → Incomplete
Changed in ubiquity (Ubuntu Vivid):
status: New → Incomplete
Launchpad Janitor (janitor) wrote :

[Expired for ubiquity (Ubuntu Vivid) because there has been no activity for 60 days.]

Changed in ubiquity (Ubuntu Vivid):
status: Incomplete → Expired
Launchpad Janitor (janitor) wrote :

[Expired for ubiquity (Ubuntu) because there has been no activity for 60 days.]

Changed in ubiquity (Ubuntu):
status: Incomplete → Expired
Ian Nicholson (imnichol) wrote :

Slipped off my radar. I'll try to replicate it as soon as I get a chance.

Changed in ubiquity (Ubuntu):
status: Expired → Incomplete
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers