[gutsy tribe 5] installer doesn't work with XFS root filesystem

Bug #138470 reported by iGadget on 2007-09-09
2
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
Undecided
Unassigned

Bug Description

When installing Gutsy tribe 5 from the liveCD, reformatting an existing XFS partition and using that as the root filesystem results in the installer not continuing.

Steps to reproduce:
1) Boot from Gutsy tribe 5 liveCD, with harddisk already containing an XFS partition and and ext3 /boot partition (this is my situation, I expect the installer to behave the same when creating a new XFS partition or reformatting an existing partition which wasn't XFS before, but I don't know for sure)
2) Start the installation and select the 'manual' partitioning mode
3) Select the existing XFS partition as the root filesystem
4) Tag it to be reformatted
5) Select the ext3 partition as the /boot partition (GRUB can't be installed to an XFS partition directly because of some issue, at least this was the case with Dapper and Edgy - perhaps this is fixed by know)
6) Tag it to be reformatted (installer refuses to continue if you don't [is this a bug? Seems to me it is!], so backup any existing data just in case)
7) Continue the installer
Result: installer just 'hangs' for eternity and doesn't continue. It doesn't crash, though - it can be cancelled.

I've tried reformatting the root filesystem to ext3 after this during the (restarted) installation process - then the installer continues without a problem.
I really want XFS as my root filesystem though, so I consider this a bug. I selected Ubiquity as the package hint, but of course there could be something 'lower-level' causing this problem.

iGadget (igadget) on 2007-09-09
description: updated
iGadget (igadget) wrote :

Fixed in Gutsy final

Changed in ubiquity:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers