ubiquity install alongside points to wrong device letter

Bug #1382991 reported by sudodus
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
Opinion
Undecided
Unassigned

Bug Description

ISO-testing Lubuntu 32-bit desktop I found a bug that ris at best only confusing, at worst installing to the wrong drive.

Background: Installing from a USB pendrive to another USB drive. The live drive is /dev/sdb. The target drive has a system already installed (Trusty, which is found and reported).

Error: Ubiquity reports that it will format partitions 5 and 6 on sdb (the live drive) instead of the intended target drive sda (where it found Trusty). See the attached screendump.

--
I will continue this testcase and report what will happen when I continue ...

ProblemType: Bug
DistroRelease: Ubuntu 14.10
Package: ubiquity 2.20.0
ProcVersionSignature: Ubuntu 3.16.0-22.29-generic 3.16.4
Uname: Linux 3.16.0-22-generic i686
ApportVersion: 2.14.7-0ubuntu7
Architecture: i386
CasperVersion: 1.345
CurrentDesktop: LXDE
Date: Sun Oct 19 15:44:41 2014
InstallCmdLine: file=/cdrom/preseed/lubuntu.seed boot=casper initrd=/casper/initrd.lz quiet splash --
LiveMediaBuild: Lubuntu 14.10 "Utopic Unicorn" - Alpha i386 (20141016)
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: ubiquity
UpgradeStatus: No upgrade log present (probably fresh install)

Revision history for this message
sudodus (nio-wiklund) wrote :
Revision history for this message
sudodus (nio-wiklund) wrote :

Next symptom: "The creation swap space in partition #6 of SCSI9 (0,0,0) (sdb) failed."

And nothing happens, when I click on OK, so the installation could not continue.

Revision history for this message
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1382991

tags: added: iso-testing
Revision history for this message
sudodus (nio-wiklund) wrote :

Installing from a USB pendrive to another USB drive does not work. I remember doing such installations many times before, but maybe I have been using 'Something else'. I think this is another indication, that the option 'Install alongside' is buggy and risky.

Passed or failed? I think 14.10 passes, but 'Install alongside' should be removed, because it creates too much problems.

Phill Whiteside (phillw)
Changed in ubiquity (Ubuntu):
status: New → Opinion
Revision history for this message
sudodus (nio-wiklund) wrote :

Originally Posted by kansasnoob (at the Ubuntu Forums)
"I have a dumb question of sorts. Ever since the ubiquity redesign during the Maverick dev cycle there is no longer a separate option to "use the largest continuous free space". It's just sort of jammed into the "install alongside" option with the only difference being that the button in the lower right hand corner of the screen says "continue" if you're going to be offered the option of resizing an existing partition, but if adequate free space exists the button with say "install now".

So my dumb question is, did that button say Continue or Install Now?"

Indeed, it does say 'Install Now', so obviously it finds empty space on the live drive (behind the image of the iso file) and tries to install Lubuntu there (but fails). So it seems that the tests cannot see, which is the live drive, and exclude it from the possible targets.

Revision history for this message
sudodus (nio-wiklund) wrote :

I can't rely on "Install alongside", but it is obvious to me that this option is very popular, and most of us want to keep it to make things simple for newcomers.

In order to increase the chances to succeed, I think that at least

*There should be an option to select the target drive*

Revision history for this message
Erick Brunzell (lbsolost) wrote :

I'll mark this as affecting me but I'm fully aware that this was a design decision made during the Maverick dev cycle. For some history please see bug #652852 and bug #766265. The good thing is that Colin Watson's latest fix for bug #1265192 did let you know what was going to happen rather than just having the installation complete and then wondering what happened.

Revision history for this message
Erick Brunzell (lbsolost) wrote :

Should the bug report name be changed? Maybe we could "wishlist" the return of the Use largest continuous free space option? After all when we axed the d-i for all but Lubuntu we said that ubiquity would offer all options provided by d-i. Just thinking out loud and if it can't be done then it can't be done.

Totally off topic, but since I'm wishing, I also wish the option to install grub in a location other than /dev/sda was presented for all installation options as it was prior to the Maverick cycle redesign ;^)

Revision history for this message
sudodus (nio-wiklund) wrote :

Yes, please suggest a better title for this bug report :-)

Building a wish-list:

- a new option 'Select the target drive'
- return of the 'Use largest continuous free space' option

-o-

I would not bother with the install option 'Install alongside', if I were only to think about myself, because I can use 'Something else'. But I don't want to read about beginners, who get unpleasant surprises, when they misunderstand what will happen. Too many of these beginners do not realize that it is risky, so they have no backup ...

Revision history for this message
sudodus (nio-wiklund) wrote :

Trying with the next uploaded iso file, dated 20141020 and with the md5sum 42a489628386a2b7faacc67db1ab8649 there was an improvement. I don't know exactly why, because I haven't saved the old iso file to try again, and I cannot easily find if it was a temporary glitch the last time or some debugging action, that makes it work now. (Maybe there was a quick fix by someone who knows this part of Ubiquity well after the recent debug action of 'Install alongside'.)

Ubiquity still wants to install into the unallocated space behind the iso9660 file system on the live drive and complains that it cannot create the swap space, but now, when I click on OK, it does not get stuck, but returns to the partitioning page, and the next time I try 'Install alongside' it lets me share the space in the other drive (by dividing the ext4 partition into one part for the existing system and one part for the system to be installed now).

I could drag the boundary, as expected, and the installation succeeded :-)

Revision history for this message
sudodus (nio-wiklund) wrote :

Now I think it was a glitch due to flaky cooperation with a USB 3 hub, that I used at the first testing instance. That hub is rather new (bought this year) and has worked before except with one particular pendrive (which was not used in any of these tests). It has worked with many linux operating systems, also for booting. But it works only sometimes with Lubuntu 14.10 (otherwise boots to a text screen with some error output), and I suspect it was involved in the failure to continue from the window, which complained that swap could not be created in the live drive.

Tiny Core, ToriOS, Mageia work,

xubuntu-14.04.1-desktop-i386.iso and ubuntu-14.04.1-desktop-amd64.iso do not work (but worked until some week ago) ...

so I think the USB 3 hub is failing, or at least, it has changed somehow and lost the ability to cooperate with some operating systems and or pendrives during booting.

The modern Ubuntu based distros, versions, flavours work when booted directly from the USB port in the computer (but not via the hub and the same USB port).

-o-

So I don't think there was any quick fix. 'Install alongside' worked and works like this: When it cannot install into the unallocated space in the live drive, it returns to the partitioning page, and at the next attempt, it will let the user share the space in the other drive, and install Lubuntu 14.10 alongside the previous operating system(s).

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers