Black background to Try/Install Dialogue

Bug #1375893 reported by Elfy on 2014-09-30
36
This bug affects 7 people
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
Medium
Unassigned

Bug Description

Boot image.

Should have a Xubuntu bacground to the Try/Install dialogue. No background shown.

ProblemType: Bug
DistroRelease: Ubuntu 14.10
Package: ubiquity 2.19.8
ProcVersionSignature: Ubuntu 3.16.0-18.25-generic 3.16.3
Uname: Linux 3.16.0-18-generic x86_64
ApportVersion: 2.14.7-0ubuntu2
Architecture: amd64
CasperVersion: 1.344
CurrentDesktop: XFCE
Date: Tue Sep 30 17:20:02 2014
InstallCmdLine: noprompt cdrom-detect/try-usb=true file=/cdrom/preseed/xubuntu.seed boot=casper initrd=/casper/initrd.lz quiet splash -- maybe-ubiquity
LiveMediaBuild: Xubuntu 14.10 "Utopic Unicorn" - Alpha amd64 (20140930)
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: ubiquity
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Elfy (elfy) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubiquity (Ubuntu):
status: New → Confirmed
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1375893

tags: added: iso-testing
Sean Davis (bluesabre) wrote :

I've found a potential workaround to this issue...

1) Add "feh" package to the live installation.
2) Remove lines 400-403 from https://bazaar.launchpad.net/~ubuntu-branches/ubuntu/utopic/ubiquity/utopic/view/head:/bin/ubiquity-dm#L400

To test...
1) Boot live image.
2) Switch to TTY1
3) Comment out lines 400-403 in the above file.
4) Install the "feh" package.
5) Stop processes: sudo stop lightdm ; sudo stop ubiquity ; sudo pkill -9 X
6) Start ubiquity: sudo start ubiquity

Ubiquity now displays the background.

Elfy (elfy) wrote :

That didn't work for me.

Pasi Lallinaho (knome) on 2014-10-18
Changed in ubiquity (Ubuntu):
importance: Undecided → High
Elfy (elfy) wrote :

tried again - worked this time, pebkac possibly

Sean Davis (bluesabre) wrote :

Viewing the process list shows that xfdesktop4 is in a <defunct> state.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in xfdesktop4 (Ubuntu):
status: New → Confirmed

It's a usability issue that doesn't limit the functionality of a core package.

Changed in xfdesktop4 (Ubuntu):
importance: Undecided → High
Changed in ubiquity (Ubuntu):
importance: High → Medium
Changed in xfdesktop4 (Ubuntu):
importance: High → Medium
Dimitri John Ledkov (xnox) wrote :

The core problem is that xfce4settings daemon, whilst spawned by ubiquity-dm it end up defunct. it should be running properly and thus displaying background during ubiquity-dm session. this is a regression in the xfce4settings or it's looking for something that is missing in the environment.

Sean Davis (bluesabre) on 2015-01-22
no longer affects: xfdesktop4 (Ubuntu)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 2.21.6

---------------
ubiquity (2.21.6) vivid; urgency=medium

  [ Unit 193 ]
  * Start all Xfce components with --sm-client-disable.
  * Explicitly run `xfdesktop` to paint the background. (LP: #1375893)

  [ Ma Jun ]
  * lp:~maclin.jun/ubiquity/fix_1304410:
    - fix missing translation for "Change..." in the partition page
 -- Michael Vogt <email address hidden> Fri, 23 Jan 2015 13:18:51 +0100

Changed in ubiquity (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related blueprints