mac is not installing bcmwl even though 3rd party drivers is selected

Bug #1374126 reported by Dave Morley on 2014-09-25
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
Undecided
Unassigned
ubuntu-drivers-common (Ubuntu)
Critical
Alberto Milone

Bug Description

STEPS:
1. install amd64+mac
2. select 3rd party drivers
3. have no wifi or wired connection.

EXPECTED:
I expect the bcmwl driver to be install and wifi working on the installed system

ACTUAL:
Wired network works and you can manually add the wifi driver but it wasn't done by default.

ProblemType: Bug
DistroRelease: Ubuntu 14.10
Package: ubiquity (not installed)
ProcVersionSignature: Ubuntu 3.16.0-17.23-generic 3.16.3
Uname: Linux 3.16.0-17-generic x86_64
NonfreeKernelModules: wl
ApportVersion: 2.14.7-0ubuntu2
Architecture: amd64
CurrentDesktop: Unity
Date: Thu Sep 25 21:04:43 2014
InstallCmdLine: file=/cdrom/preseed/ubuntu.seed boot=casper initrd=/casper/initrd.lz quiet splash -- maybe-ubiquity
InstallationDate: Installed on 2014-09-25 (0 days ago)
InstallationMedia: Ubuntu 14.10 "Utopic Unicorn" - Alpha amd64+mac (20140923)
SourcePackage: ubiquity
UpgradeStatus: No upgrade log present (probably fresh install)

Dave Morley (davmor2) wrote :
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1374126

tags: added: iso-testing
Andy Whitcroft (apw) wrote :

Channelling the above png we see (all errors mine):

  $ ubuntu-drivers list
  bcmwl-kernel-source
  $ ubuntu-drivers autoinstall
  No drivers found for automatic installation.

From what I can see the bcmwl-kernel-source package (from another box):

  apt-cache show bcmwl-kernel-source | grep Mod
  Modaliases: wl(pci:v000014E4d*sv*sd*bc02sc80i*)

should be being matched for this one:

  ==> /sys/bus/pci/devices/0000:03:00.0/uevent <==
  DRIVER=bcma-pci-bridge
  PCI_CLASS=28000
  PCI_ID=14E4:4331
  PCI_SUBSYS_ID=14E4:4331
  PCI_SLOT_NAME=0000:03:00.0
  MODALIAS=pci:v000014E4d00004331sv000014E4sd00004331bc02sc80i00

Andy Whitcroft (apw) wrote :

As ubuntu-drivers autoinstall is failing this is almost cirtainly not a ubiquity bug.

Changed in ubiquity (Ubuntu):
status: New → Invalid
Andy Whitcroft (apw) wrote :

Ok, after playing with the machine it seems the issue is the driver is there and available, but not marked for autoinstall. Basically we have subbed in b43/brcmsmac for bcmwl by default. This generally means you need linux-firmware-nonfree installed. Unfortuantly the bcmwl driver is on the image, but l-f-nonfree is not; and you have no way to get it.

Changed in ubuntu-drivers-common (Ubuntu):
assignee: nobody → Alberto Milone (albertomilone)
status: New → Triaged
importance: Undecided → Critical
Martin Pitt (pitti) wrote :

So I suppose we should drop bcmwl from the images and instead put linux-firmware-nonfree on it? And mark that for auto-install instead?

On 06-10-14 16:32:22, Martin Pitt wrote:
> So I suppose we should drop bcmwl from the images and instead put linux-
> firmware-nonfree on it? And mark that for auto-install instead?
>

I wish it were that simple. Apparently there are licensing issues with
linux-firmware-nonfree. This means we'll probably have to switch back to
bcwml.

You can read the entire conversation that we had with infinity and apw
about it yesterday:

http://irclogs.ubuntu.com/2014/10/06/%23ubuntu-kernel.html

Changed in ubuntu-drivers-common (Ubuntu):
status: Triaged → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-drivers-common - 1:0.2.98.4

---------------
ubuntu-drivers-common (1:0.2.98.4) utopic; urgency=medium

  * debian/tests/system, tests/ubuntu_drivers.py,
    UbuntuDrivers/detect.py:
    - Revert the previous changes that made us switch from bcmwl to
      the open driver, as the latter (in order to be a full replacement)
      seems to require firmware that we cannot include in the Ubuntu
      image because of licensing issues (LP: #1374126).
 -- Alberto Milone <email address hidden> Thu, 09 Oct 2014 16:42:53 +0200

Changed in ubuntu-drivers-common (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers