OSError: [Errno 25] Inappropriate ioctl for device

Bug #1361595 reported by Jamin W. Collins on 2014-08-26
22
This bug affects 3 people
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
Undecided
Dimitri John Ledkov
Trusty
Undecided
Dimitri John Ledkov
Utopic
Undecided
Dimitri John Ledkov

Bug Description

With 14.04, I've found that oem-config no longer prompts end users for their final configuration details. In fact, the system reboots abruptly and no longer has the oem user account.

From the contents of /var/log/oem-config.log (below), it appears that oem-config is throwing an unhandled exception, exceeding its maximum retries (5), and then purging itself from the system. I've reproduced this with a fresh 14.04 OEM install.

This is definitely a regression from the 12.04 release.

Ubiquity 2.18.8 (oem-config)
Traceback (most recent call last):
  File "/usr/sbin/oem-config", line 636, in <module>
    main(oem_config)
  File "/usr/sbin/oem-config", line 622, in main
    install(query=options.query)
  File "/usr/sbin/oem-config", line 262, in install
    open_terminal()
  File "/usr/sbin/oem-config", line 100, in open_terminal
    ttyn = os.ttyname(0)
OSError: [Errno 25] Inappropriate ioctl for device
Ubiquity 2.18.8 (oem-config)
Traceback (most recent call last):
  File "/usr/sbin/oem-config", line 636, in <module>
    main(oem_config)
  File "/usr/sbin/oem-config", line 622, in main
    install(query=options.query)
  File "/usr/sbin/oem-config", line 262, in install
    open_terminal()
  File "/usr/sbin/oem-config", line 100, in open_terminal
    ttyn = os.ttyname(0)
OSError: [Errno 25] Inappropriate ioctl for device
Ubiquity 2.18.8 (oem-config)
Traceback (most recent call last):
  File "/usr/sbin/oem-config", line 636, in <module>
    main(oem_config)
  File "/usr/sbin/oem-config", line 622, in main
    install(query=options.query)
  File "/usr/sbin/oem-config", line 262, in install
    open_terminal()
  File "/usr/sbin/oem-config", line 100, in open_terminal
    ttyn = os.ttyname(0)
OSError: [Errno 25] Inappropriate ioctl for device
Ubiquity 2.18.8 (oem-config)
Traceback (most recent call last):
  File "/usr/sbin/oem-config", line 636, in <module>
    main(oem_config)
  File "/usr/sbin/oem-config", line 622, in main
    install(query=options.query)
  File "/usr/sbin/oem-config", line 262, in install
    open_terminal()
  File "/usr/sbin/oem-config", line 100, in open_terminal
    ttyn = os.ttyname(0)
OSError: [Errno 25] Inappropriate ioctl for device
Ubiquity 2.18.8 (oem-config)
Traceback (most recent call last):
  File "/usr/sbin/oem-config", line 636, in <module>
    main(oem_config)
  File "/usr/sbin/oem-config", line 622, in main
    install(query=options.query)
  File "/usr/sbin/oem-config", line 262, in install
    open_terminal()
  File "/usr/sbin/oem-config", line 100, in open_terminal
    ttyn = os.ttyname(0)
OSError: [Errno 25] Inappropriate ioctl for device
Reading package lists...
Building dependency tree...
Reading state information...
The following packages were automatically installed and are no longer required:
  alsa-base alsa-utils apt-clone archdetect-deb bogl-bterm btrfs-tools dmraid
  kpartx kpartx-boot libasound2 libasound2-data libdebian-installer4
  libdevmapper-event1.02.1 libdmraid1.0.0.rc16 libicu52 libiw30 liblzo2-2
  libparted0debian1 libpolkit-agent-1-0 libpolkit-backend-1-0 libreadline5
  libsamplerate0 linux-sound-base lvm2 ncurses-term ntfs-3g policykit-1
  python3-icu python3-pam python3-xkit rdate sbsigntool ubiquity-casper
  ubiquity-ubuntu-artwork ubuntu-drivers-common watershed
Use 'apt-get autoremove' to remove them.
The following packages will be REMOVED:
  oem-config* oem-config-debconf* ubiquity* ubiquity-frontend-debconf*
0 upgraded, 0 newly installed, 4 to remove and 0 not upgraded.
After this operation, 19.7 MB disk space will be freed.
(Reading database ... 50531 files and directories currently installed.)
Removing oem-config (2.18.8) ...
Purging configuration files for oem-config (2.18.8) ...
Removing oem-config-debconf (2.18.8) ...
Purging configuration files for oem-config-debconf (2.18.8) ...
Removing ubiquity-frontend-debconf (2.18.8) ...
Removing ubiquity (2.18.8) ...
Purging configuration files for ubiquity (2.18.8) ...

Jamin W. Collins (jcollins) wrote :

The root cause of this is a missing entry in the upstart init config: /etc/init/oem-config.conf

Specifically, the upstart config is not attaching STDIN to the job.

The attached patch fixes this.

The attachment "instruct upstart to attach STDIN to job" seems to be a patch. If it isn't, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are a member of the ~ubuntu-reviewers, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issues please contact him.]

tags: added: patch
Changed in oem-config (Ubuntu):
assignee: nobody → Dimitri John Ledkov (xnox)
affects: oem-config (Ubuntu Utopic) → ubiquity (Ubuntu Utopic)
Changed in ubiquity (Ubuntu Trusty):
assignee: nobody → Dimitri John Ledkov (xnox)
status: New → Triaged
Changed in ubiquity (Ubuntu Utopic):
status: New → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 2.19.5

---------------
ubiquity (2.19.5) utopic; urgency=medium

  * Re-add "console output" stanza to the oem-config upstart job to
    re-instate stdin/stdout. (LP: #1361595)
  * Automatic update of included source packages: netcfg 1.119ubuntu1.
 -- Dimitri John Ledkov <email address hidden> Sun, 31 Aug 2014 23:52:22 +0100

Changed in ubiquity (Ubuntu Utopic):
status: In Progress → Fix Released
Changed in ubiquity (Ubuntu Trusty):
status: Triaged → In Progress

Hello Jamin, or anyone else affected,

Accepted ubiquity into trusty-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/ubiquity/2.18.8.4 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in ubiquity (Ubuntu Trusty):
status: In Progress → Fix Committed
tags: added: verification-needed
tags: added: trusty
Jamin W. Collins (jcollins) wrote :

Chris,

I may be looking in the wrong area, but from the provided link I can only find three binaries built for amd64 (https://launchpad.net/ubuntu/+source/ubiquity/2.18.8.4/+build/6716449):

Binary packages
Binary packages produced by this build:

ubiquity 2.18.8.4
ubiquity-frontend-debconf 2.18.8.4
ubiquity-frontend-gtk 2.18.8.4
Built files
Files resulting from this build:

ubiquity-frontend-debconf_2.18.8.4_amd64.deb (437.8 KiB)
ubiquity-frontend-gtk_2.18.8.4_amd64.deb (84.5 KiB)
ubiquity_2.18.8.4_amd64.deb (4.9 MiB)

However the file in question (/etc/init/oem-config-debconf.conf) is owned by oem-config-debconf, which is not one of the built packages. Furthermore, this is only one of several issues preventing the oem-config package from working on server installations.

As a part of the Stable Release Updates quality process a search for Launchpad bug reports using the version of ubiquity from trusty-proposed was performed and bug 1417834 was found. Please investigate this bug report to ensure that a regression will not be created by this SRU. In the event that this is not a regression remove the "verification-failed" tag from this bug report and tag 1417834 "bot-stop-nagging". Thanks!

tags: added: verification-failed

Removing verification-failed; the fix appears to be good at first glance, but I'll run a more careful test now to be able to mark this verfiication-done if I can.

tags: removed: verification-failed
tags: added: verification-done
tags: removed: verification-done

The OEM installation appears to work properly using trusty-server-amd64.iso, so I'll go ahead and mark this verification-done.

One issue however, which is unrelated to oem-config itself is that I am unable to start an OEM installation straight from the gfxboot menu on the CD (using a VM), something which worked for 14.04.1. One needs to manually add oem-config/enable=true to the boot parameters to get into an OEM install.

tags: added: verification-done
tags: removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 2.18.8.4

---------------
ubiquity (2.18.8.4) trusty; urgency=medium

  * Re-add "console output" stanza to the oem-config upstart job to
    re-instate stdin/stdout. (LP: #1361595)
 -- Dimitri John Ledkov <email address hidden> Sun, 21 Dec 2014 07:05:55 +0000

Changed in ubiquity (Ubuntu Trusty):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for ubiquity has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers