[gutsy] failed to unmount migrationassistant

Bug #135149 reported by Stijn Gysemans on 2007-08-27
46
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: ubiquity

OS:Gutsy tribe 5
PC: core2duo, with vista in dual boot.

current situation on disk:
partition 1: vista
partition 2: feisty fawn (failed to boot, that's why i tried gutsy).

reproduce:
1. run live cd of gutsy
2. click on install
3. click on format the second partition
4. "no users or os's were found" is displayed (although vista is installed"
5. starts installing the system
6. pop's up a dialog:

migration-assistant needs to mount a partition, but cannot do so because the following mount point could not be unmounted:

/mnt/migrationassistant

Please close any applications using these mount points.

Would you like migration-assistant to try to unmount these partitions again?

7. standard option is "Go back": then it doesn't continue the installation and i'm forced to cancel the installation!
This UI glitch is VERY confusing!

Nanley Chery (nanoman) wrote :

Same bug happened to me, though i forget what happened when I clicked "Go back"

This is what happened when a user clicked continue:
https://bugs.launchpad.net/ubuntu/+source/ubiquity/+bug/134883

Nanley Chery (nanoman) on 2007-09-02
Changed in ubiquity:
status: New → Confirmed
Patrice Vetsel (vetsel-patrice) wrote :

screenshot

Changed in ubiquity:
importance: Undecided → Medium
Evan (ev) on 2007-09-26
Changed in ubiquity:
assignee: nobody → evand
Dennis Schmitz (deezid) wrote :

same here...
but install works ;)

Evan (ev) wrote :

Can someone who is experiencing this bug run the installer using the --debug option (`ubiquity --debug` in a console window), then attach /var/log/syslog and /var/log/installer/debug to this bug report?

Thanks!

Changed in ubiquity:
status: Confirmed → Incomplete
Serjudo (serjudo) wrote :

same problem here, if you push "continue", install works

Wenzhuo Zhang (wenzhuo) wrote :
Wenzhuo Zhang (wenzhuo) wrote :
Nanley Chery (nanoman) wrote :

I just tried the installation in Gutsy beta, and I haven't received any error dialogs.

Changed in ubiquity:
status: Incomplete → Confirmed
Wenzhuo Zhang (wenzhuo) wrote :

I am still getting the "failed to unmount migrationassistant" error prompt using Gutsy beta. The syslog and debug files I uploaded previously were generated by Gutsy beta Desktop CD.

Karlosak (koubekk) wrote :

I've got the same problem with Gutsy beta:
I'm running Windows XP with 3 NTFS partitions and remaining 60GB of unpartitioned space (single hard drive). During installation from the LiveCD I manually partition the free space - one partition for "/" (50GB) and 5GB for swap. The remainder unused. I'm not importing any configurations from my XP installation (the box is unchecked).

Now the problem: at 88% of installation (Importing documents and settings) the same window as described above pop ups. When I click the "go back" button the installation freezes. When I click "Continue" (another installation try) it seems to go on normally.

I'll try it once again with the --debug option.

Karlosak (koubekk) wrote :
Karlosak (koubekk) wrote :

Couldn't find the debug file, is it automatically discarded after PC restart?

Karlosak (koubekk) wrote :

Sorry for spaming, now I tried before PC restart and both files are there.

Karlosak (koubekk) wrote :
parren (peter-arrenbrecht) wrote :

Same here. Had me really stumped for a while. Don't know if my "sudo umount /mnt/migrationassistant" or the repeated clicking of "Continue" helped in the end.

Confirmed on Gutsy beta desktop 386.
Before clicking on "Continue",
"sudo umount -a" let me finish my installation process.

First time I tried without "sudo umount -a", a hard reboot was needed after clicking on "Continue".

Vivien Malerba (malerba) wrote :

With Gutsy beta, whatever I do nothing works and the installer finishes without any other word. I still haven't been able to install Gutsy... I've got other partitions, one with W2K and one with Ubuntu 07.04.

Vivien

With Gutsy Beta, when the message is displayed, I click Continue but the system hangs too. My only option to perform the installation is running the installer from the console:

ubiquity --no-migration-assistant

Please run the installer again using the --debug option, and attach
/var/log/syslog and /var/log/installer/debug to this bug report. Thanks!

I am attaching the logs. Perhaps there will appear something about language packs not downloaded, for I have done installed with no Internet connection.

And now the syslog... I hope this can help.

Colin Watson (cjwatson) wrote :

ubiquity (1.6.4) gutsy; urgency=low

  [ Evan Dandrea ]
  * Only set migration-assistant data in user-setup if updating an existing
    user (LP: #135149).
  * Properly filter out partitions marked for deletion in
    migrationassistant.py (LP: #146222).
  * Fixed a bug where the migration-assistant page would not be updated to
    reflect changes, such as if the user went back and partitioned
    differently, if the page had already been shown.

  [ Mario Limonciello ]
  * Copy over detected xserver-xorg changes to ensure BulletProofX
    is functional after installation. This behavior is temporary
    for gutsy and will be removed after the BulletProofX spec is
    reworked.

  [ Colin Watson ]
  * Automatic update of included source packages: migration-assistant 0.5.3.

 -- Colin Watson <email address hidden> Tue, 09 Oct 2007 17:11:38 +0100

Changed in ubiquity:
status: Confirmed → Fix Released
Evan (ev) wrote :

Can those of you who are experiencing this bug please test using the latest daily desktop CD (http://cdimage.ubuntu.com/daily-live/current/), running the installer from a terminal with the --debug option (`ubiquity --debug`)? Please report back if this is or is not still occurring, and if the former, attach /var/log/installer/debug and /var/log/syslog from the live CD environment following these instructions: https://wiki.ubuntu.com/DebuggingUbiquity/AttachingLogs. I'm especially keen on knowing of cases where you cannot possibly continue, that is, the installer hangs or crashes.

Thanks a lot!

Evan (ev) wrote :

I should note that I believe the meat of this bug is migration-assistant interacting with ntfs-3g, which seems to be unable to initially unmount partitions when it's only waiting on a write operation.

Nanley Chery (nanoman) on 2007-10-12
Changed in ubiquity:
status: Fix Released → Confirmed
Nanley Chery (nanoman) wrote :

I still have this problem in Gutsy 7.10-RC. I clicked "Continue" on the error dialog box. Also, after receiving this error, m-a successfully displayed (all?) options for my windows installation. I'll attach the logs you wanted.

Nanley Chery (nanoman) wrote :

I got the error at the partitioning area and 88% into the installation (Importing documents and settings...), I clicked "Continue" on both. Just in case this helps at all, I unchecked the install bootloader checkbox under the advanced menu.

Nanley Chery (nanoman) wrote :
Wenzhuo Zhang (wenzhuo) wrote :

I still have this problem with Gutsy RC Desktop CD as well. I saw the error prompt in the actual installation stage only. I suggest raising the bug importance.

If you need the debug info, just let me know, and I'll perform an installation again.

Evan (ev) wrote :

Nanely,

I'm having a hard time following those logs and how this could even be happening. Could you possibly add `set -x` to the second line of /usr/lib/ubiquity/migration-assistant/ma-ask and run the installer until you get the dialog, then attach syslog again. Don't worry about actually installing or waiting for the second dialog. I apologize for making you run through this so many times.

Wenzhuo,
If it would not be too much trouble, could you run through another install? This time please add `set -x` to the second line of /usr/lib/ubiquity/migration-assistant/ma-apply (/usr/lib/ubiquity/migration-assistant/ma-ask too if you're seeing the dialog in the first stage of the installer), then attach syslog to this bug report?

Thank you both.

Nanley Chery (nanoman) wrote :

By "second line", I assume you mean the line after 'set -e'. The resulting log is attached.

Karlosak (koubekk) wrote :

I've just downloaded and installed the 'release candidate'. This time the installation process went through smoothly, without any error window at 88%, thanks!

Wenzhuo Zhang (wenzhuo) wrote :

Added 'set -x' to the second line of /usr/lib/ubiquity/migration-assistant/ma-apply and tried another install, got the error dialog window at 88% only.

It installed flawlessly on the pc without interrupting!

On 10/13/07, Wenzhuo Zhang <email address hidden> wrote:
> Added 'set -x' to the second line of /usr/lib/ubiquity/migration-
> assistant/ma-apply and tried another install, got the error dialog
> window at 88% only.
>
> ** Attachment added: "syslog"
> http://launchpadlibrarian.net/9963788/syslog
>
> --
> [gutsy] failed to unmount migrationassistant
> https://bugs.launchpad.net/bugs/135149
> You received this bug notification because you are a direct subscriber
> of the bug.
>

parren (peter-arrenbrecht) wrote :

Problem still here in Gutsy RC.

Evan (ev) wrote :

I worked around this in Gutsy by sleeping once for 15 seconds and trying again. I'll work on a full fix for Hardy.

Uphaar Agrawalla (uphaar) wrote :

I faced similar problem with Gutsy RC installation - I selected Firefox in the list of applications to migrate, and got the same error message. Clicking "Go Back" unmounted the partition apparently, but did not continue with the installation. The installation progress dialog just disappears, without any success/error messages.

Since there were no errors, I thought maybe installation was successful. However, on rebooting I didn't see the Grub menu.

I ran the installation again and this time chose "Continue" on the error. The installation continued and I saw the progress bar completing after doing a lot of more things. Finally I got the completion message and reboot popup, so this time I knew that everything was fine. Rebooting got me to the Grub menu now.

Evan (ev) wrote :

Uphaar,

Were you using the RC the second time, or the 20071016 daily desktop CD?

Uphaar Agrawalla (uphaar) wrote :

Evan,

I was using the RC both the times.

fmaste (fmaste) wrote :

I have the same problem with the RC version, if I click on "Go back" Installation freezes at 88% and I have to reboot and start all the installation again. This second time I selected "Continue" and the installation finished correctly.

Here is a more detailed description:
https://bugs.launchpad.net/ubuntu/+source/ubiquity/+bug/152399

Evan (ev) on 2011-02-08
Changed in ubiquity (Ubuntu):
assignee: Evan Dandrea (ev) → nobody
tags: added: ubiquity-1.6.6
tags: added: gutsy

Exception during installation:
Oct 9 15:43:23 ubuntu python: Traceback (most recent call last):
Oct 9 15:43:23 ubuntu python: File "/usr/share/ubiquity/install.py", line 1787, in <module>
Oct 9 15:43:23 ubuntu python: install.run()
Oct 9 15:43:23 ubuntu python: File "/usr/share/ubiquity/install.py", line 392, in run
Oct 9 15:43:23 ubuntu python: self.configure_ma()
Oct 9 15:43:23 ubuntu python: File "/usr/share/ubiquity/install.py", line 1012, in configure_ma
Oct 9 15:43:23 ubuntu python: raise InstallStepError("MigrationAssistantApply failed with code %d" % ret)
Oct 9 15:43:23 ubuntu python: InstallStepError: MigrationAssistantApply failed with code 10
Oct 9 15:43:23 ubuntu python:

tags: added: installer-crash
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers