Ubuntu

compiz compositing locks up computer for rv350 chip

Reported by Wenzhuo Zhang on 2007-08-26
20
Affects Status Importance Assigned to Milestone
compiz (Ubuntu)
Undecided
Michael Vogt
compiz-fusion-plugins-main (Ubuntu)
Undecided
Unassigned
ubiquity (Ubuntu)
Undecided
Unassigned
xserver-xorg-video-ati (Ubuntu)
Medium
Tormod Volden

Bug Description

Binary package hint: ubiquity

Tribe-5 desktop CD boots successfully on my desktop computer with ATI9550 graphics card as always. However, X can easily lock up unless Desktop Effects is disabled as soon as the desktop CD finishes booting.

I am wondering if compiz compositing should be enabled on the desktop CD by default and if Ubiquity should offer users an option to disable Desktop Effects.

I consider it a major bug of Ubiquity, because it can lock up many computers during installation.

Wenzhuo Zhang (wenzhuo) wrote :

Is there a boot option to disable Desktop Effects of the Desktop CD?

Wenzhuo Zhang (wenzhuo) wrote :

Attaching Xorg.0.log. When X locks up, the kernel SysRq magic keys are still working. I can sync the file system and reboot the computer by pressing Alt-SysRq-S and Alt-SysRq-B.

Wenzhuo Zhang (wenzhuo) on 2007-09-14
description: updated
Timo Aaltonen (tjaalton) wrote :

How can you reproduce it, ie. is there something that will always make it hang?

Changed in xserver-xorg-video-ati:
importance: Undecided → Medium
status: New → Incomplete
Timo Aaltonen (tjaalton) wrote :

Closing for ubiquity. If it can't be made to work for you, compiz will eventually know your device pciid and refuse to start.

Changed in ubiquity:
status: New → Invalid
Michael Vogt (mvo) wrote :

Thanks for your bugreport.

If it always hangs your machine, we will have to blacklist the pciid:
 1002:4153
(RV350 AS [Radeon 9550])
in the compiz wraper.

Changed in compiz:
status: New → Triaged
Wenzhuo Zhang (wenzhuo) wrote :

Navigating in the Applications menu can reproduce the lockup in a matter of seconds.

Wenzhuo Zhang (wenzhuo) wrote :

I believe it's wise to enable compiz based a whilelist of well-tested graphics cards at the first stage. If you choose to enable compiz by default and to disable compiz for a blacklist of graphics card, it's cautious to provide a boot option to disable desktop effects, because you never know if compiz works with a particular untested graphics card.

Travis Watkins (amaranth) wrote :

That's what the failsafe GNOME session is for. Compiz doesn't run there.

Bryce Harrington (bryce) on 2007-09-19
Changed in compiz:
assignee: nobody → mvo
Changed in compiz:
status: Triaged → Fix Released
MaxNegro (maxnegro) wrote :

Just a quick followup: i have the very same chip (PCI ID 1002:4153) but here compiz runs quite stable, after disabling the blacklist in the wrapper script. Took a while to understand why it didn't start: only error message I got was "unable to activate graphic effects"...

Wenzhuo Zhang (wenzhuo) wrote :

Perhaps it is related to the graphics mode. I am using a 1280x1024 LCD. Please attach your Xorg.0.log.

smemorex (luca-consales) wrote :

it work for me too with the same chip when i disable my card from the blacklist

This is my output when i run compiz:

user@ubuntu:~$ compiz
Checking for Xgl: not present.
Detected PCI ID for VGA: 01:00.0 0300: 1002:4153 (prog-if 00 [VGA])
Checking for texture_from_pixmap: not present.
Trying again with indirect rendering:
Checking for texture_from_pixmap: present.
Checking for non power of two support: present.
Checking for Composite extension: present.
Comparing resolution (1152x864) to maximum 3D texture size (2048): Passed.
Checking for nVidia: not present.
Checking for FBConfig: present.
Checking for Xgl: not present.
Starting gtk-window-decorator
/usr/bin/compiz.real (video) - Warn: No 8 bit GLX pixmap format, disabling YV12 image format

The only one problem seems to be when i try to maximize firefox i see a black background in the firefox window for a moment and than it works normally

smemorex (luca-consales) wrote :

it work for me too with the same chip when i disable my card from the blacklist

This is my output when i run compiz:

user@ubuntu:~$ compiz
Checking for Xgl: not present.
Detected PCI ID for VGA: 01:00.0 0300: 1002:4153 (prog-if 00 [VGA])
Checking for texture_from_pixmap: not present.
Trying again with indirect rendering:
Checking for texture_from_pixmap: present.
Checking for non power of two support: present.
Checking for Composite extension: present.
Comparing resolution (1152x864) to maximum 3D texture size (2048): Passed.
Checking for nVidia: not present.
Checking for FBConfig: present.
Checking for Xgl: not present.
Starting gtk-window-decorator
/usr/bin/compiz.real (video) - Warn: No 8 bit GLX pixmap format, disabling YV12 image format

The only one problem seems to be when i try to maximize firefox at the beginnig shows me a black background in his winodow and than it works normally

MaxNegro (maxnegro) wrote :

Actually I'm using 1680x1050, and used to use 1280x1024 before switching to this new monitor I bougth recently. :)
I can confirm I'm still having no problems at all running with composite enabled and effects running (I use compiz-fusion, but I customized the list of plugins that gets loaded). More than 5 days of uptime at the moment.

Anyway, Xorg.0.log attached.

Gaspard Leon (gaspard.leon) wrote :

Someone with an RV350 should try it with the new driver (23 Oct 2007):
Read about it here: http://www.phoronix.com/scan.php?page=article&item=887

iDont (dennis-groenen) wrote :

Hello,
I have an ATi Radeon 9550SE (RV350)

I never had problems with:
* in the beginning Beryl (on Ubuntu 6.10, using the open source fglrx driver and XGL),
* later Compiz (on Ubuntu 7.04, using the open source fglrx and XGL driver)
* and now Compiz Fusion (on Ubuntu 7.10, using the official ATi driver 8.40.4 and later 8.41.7 on XGL)
since I use Ubuntu with an 3D Desktop with my Graphic Card.

I have installed the official ATi 8.42.3 driver today (for the first time using AIGLX :D) and I still haven't experienced any problems with Compiz Fusion.

I don't know why the RV350 is on the blacklist,
is the group people experiencing problems with it bigger than the group for who the card works flawless or not?
Otherwise I suggest to don't blacklist this card.

Feel free to ask any questions about my configuration and log files.

-Dennis

P.S. Sorry for my bad English, I am from the Netherlands

Leszek (bigl-aff) wrote :

Hi,

In previous versions of Ubuntu I could use Beryl/Compiz only with XGL with my Radeon 9550. Yesterday I installed official ATi 8.42.3 driver and now I can work with Compiz without XGL ( with AIGLX). Sadly performance is very poor - worst than with Ubuntu 7.04 with Ati restricted driver on XGL.

But at least I can confirm that with new ATi driver RV350 chip can be on whitelist.

Leszek

BastiBense (basti-bense) wrote :

I'm using a ATI 9550 (R300) card in Ubuntu 7.10 and can confirm that it works perfectly.

Justin Forest (umonkey) wrote :

I'm using ATI Technologies Inc RV350 AS [Radeon 9550] and it works well (with the ati driver, not fglrx). It always worked well, I'm surprised that (if) it got blacklisted without proper investigation.

Zoran Jolic (zjolic) wrote :

Hi, i had same problem, just that i installed ati proprietary driver (fglrx), and compiz didnt wont to work. Everything that I did after was quoting the blacklist for my chip (rv350), and now works perfect.

Nanley Chery (nanoman) on 2007-11-15
Changed in compiz-fusion-plugins-main:
status: New → Invalid
tuxo (beat-fasel) wrote :

I am using a ATI X1050 - RV350 AS [Radeon 9550] with the free ati drivers on Gutsy Gibbon. I don't know why this card has been blacklisted. Compiz works well for me and does not crash.

Sergio Zanchetta (primes2h) wrote :

Compiz works very well for me in Gutsy with rv350 chip.

I suspect that Wenzhuo Zhang problem is due to other reasons... (and it's not confirmed by any other people)

In addition to this, he experienced it on Tribe 5.

I think it's time to whitelist this chip.

Travis Watkins (amaranth) wrote :

We have already done so in hardy.

Timo Jyrinki (timo-jyrinki) wrote :

Marking xserver-xorg-video-ati as fix released, since the current driver seems to work with compiz.

Changed in xserver-xorg-video-ati:
status: Incomplete → Fix Released
Wenzhuo Zhang (wenzhuo) wrote :

I just tried un-blacklisting 1002:4153 again on up-to-date Gutsy. Compiz still locks up my computer. It seems that I am the only unlucky one with this graphics card. :( Perhaps I've got a faulty card, or it cannot draw enough current from the AGP socket. The desktop computer is very stable otherwise.

Unfortuately, I don't have enough hardware to isolate the problem.

Wenzhuo Zhang (wenzhuo) wrote :

Further findings regarding to this problem:

1. When X locks up, the system is still running. I can ssh into this machine from another machine. Everything is fine except that the screen stays frozen no matter what I do, including typing switching to console by typing "Ctrl-Alt-F1", and restarting gdm/X. The computer screen will not come back to life until system reboot.

2. The i845 motherboard has an AGP 4X socket. If I lower the AGPMode to 1 or 2, it seems that lockups no longer occur. At the time of writing, it has been running well in AGPMode 2 for one hour already.

Section "Device"
        Identifier "ATI Technologies Inc RV350 AS [Radeon 9550]"
        Driver "ati"
        BusID "PCI:1:0:0"
        Option "AGPMode" "2"
EndSection

Wenzhuo Zhang (wenzhuo) wrote :

Marking the bug as Incomplete for xserver-xorg-video-ati, because lockups no longer occur in AGP 1X and 2X mode. I haven't tried Hardy though.

Changed in xserver-xorg-video-ati:
status: Fix Released → Incomplete
Wenzhuo Zhang (wenzhuo) wrote :

Just for the record: I submitted a repair request to the graphics card vendor because of the noisy fan, but they shipped me a newer version of this card as a replacement instead. Now X no longer locks up with AGP in 4x mode when normal or extra desktop effects are enabled in Gutsy.

Sergio Zanchetta (primes2h) wrote :

So the problem was related to hardware, as I suspected.
Closing this bug.

Changed in xserver-xorg-video-ati:
status: Incomplete → Invalid
Tormod Volden (tormodvolden) wrote :

Wenzhuo, do you still have any problems running compiz with your RV350 card? If you need to specify a given AGPMode, we should fix this in xserver-xorg-video-ati.

Changed in xserver-xorg-video-ati (Ubuntu):
assignee: nobody → Tormod Volden (tormodvolden)
status: Invalid → Incomplete
Bryce Harrington (bryce) wrote :

No response in a couple months; assuming the issue is long since resolved.

Changed in xserver-xorg-video-ati (Ubuntu):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers