Tried to install Lubuntu on flash drive using VMware Player

Bug #1334816 reported by bill stewart at work on 2014-06-26
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)

Bug Description

I run VMware Player on my Windows 7-64 machine.
I downloaded the latest Lubuntu ISO.
I tried to create a new virtual machine, storing the disk on a removable flash drive, installing Lubuntu.
VMware Player suggested that ACE might be a better way to go (but I ignored it, because that doesn't seem to be supported on the free player.)
Lubuntu Install started up, asked me about languages and keyboards, but during the File Copy phase it choked a couple of times, with no clear indication of why.
At the end of the process, it handed me over to this bug reporting system. I hope there's enough useful info (Mozilla complained about losing something when I had to reset my Launchpad password.)

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: ubiquity 2.18.7
ProcVersionSignature: Ubuntu 3.13.0-24.46-generic 3.13.9
Uname: Linux 3.13.0-24-generic x86_64
ApportVersion: 2.14.1-0ubuntu3
Architecture: amd64
CasperVersion: 1.340
Date: Thu Jun 26 05:09:10 2014
InstallCmdLine: file=/cdrom/preseed/lubuntu.seed boot=casper only-ubiquity initrd=/casper/initrd.lz quiet splash --
LiveMediaBuild: Lubuntu 14.04 LTS "Trusty Tahr" - Release amd64 (20140416.2)
 PATH=(custom, no user)
SourcePackage: ubiquity
UpgradeStatus: No upgrade log present (probably fresh install)

Exception during installation:
Jun 26 12:08:46 lubuntu / Traceback (most recent call last):
Jun 26 12:08:46 lubuntu / File "/usr/share/ubiquity/", line 1770, in <module>
Jun 26 12:08:46 lubuntu /
Jun 26 12:08:46 lubuntu / File "/usr/share/ubiquity/", line 78, in wrapper
Jun 26 12:08:46 lubuntu / func(self)
Jun 26 12:08:46 lubuntu / File "/usr/share/ubiquity/", line 192, in run
Jun 26 12:08:46 lubuntu / self.configure_python()
Jun 26 12:08:46 lubuntu / File "/usr/share/ubiquity/", line 423, in configure_python
Jun 26 12:08:46 lubuntu / install_misc.chroot_cleanup(
Jun 26 12:08:46 lubuntu / File "/usr/lib/ubiquity/ubiquity/", line 196, in chroot_cleanup
Jun 26 12:08:46 lubuntu / os.rename('%s.REAL' % initctl, initctl)
Jun 26 12:08:46 lubuntu / OSError: [Errno 30] Read-only file system: '/target/sbin/initctl.REAL' -> '/target/sbin/initctl'
Jun 26 12:08:46 lubuntu /

tags: added: installer-crash
Changed in ubiquity (Ubuntu):
importance: Undecided → High
Phillip Susi (psusi) wrote :

From your logs it appears that you may have a severe hardware problem. Please choose the memtest option from the boot menu and let it run for at least 15 minutes and let us know the results.

Changed in ubiquity (Ubuntu):
status: New → Incomplete

Since this was a virtual machine (VMware Player running on a laptop), not real hardware, I'm skeptical that memtest would report anything useful (or at least, that it would realistically reproduce the previous events.) If there were actual hardware problems, most likely they'd be bad blocks on the SDHC memory card I was using as the disk space for the VMware. What I did instead was to shut down most of the other stuff running on the laptop so VMware Player could be sure of having all the memory it wants, and reinstalling from scratch. It seems to have worked ok this time, though it's only running a little faster from SDHC than from hard drive.

Launchpad Janitor (janitor) wrote :

[Expired for ubiquity (Ubuntu) because there has been no activity for 60 days.]

Changed in ubiquity (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers