/boot partition doesn't need to be formatted ( gutsy tribe 4 )

Bug #132840 reported by 9johnny on 2007-08-16
This bug report is a duplicate of:  Bug #72897: Unable to install without format. Edit Remove
2
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
Wishlist
Unassigned

Bug Description

Binary package hint: ubiquity

I tried to install gutsy from the tribe 4 liveCD (desktop), and I have a /boot partition. I tried setting up the /boot partition to be mounted and used by gutsy in the partitioner of the installer, but when I tried to hit continue it told me that it wouldn't go forward because I need to format /boot. This pretty mch beats the purpose of having a /boot partition, it would be nice to see this fixed.

Colin Watson (cjwatson) wrote :

It doesn't defeat the purpose at all; a common reason to have a /boot partition is to be within a range of the disk that the BIOS can boot. I acknowledge your point, though, and we may change this in future, though we need to make sure that we don't just go right back to the interminable crash reports that were the reason this check was introduced.

Changed in ubiquity:
importance: Undecided → Wishlist
status: New → Confirmed
Christian González (droetker) wrote :

Hm.
I think you have your boot partition because you have another linux, maybe as stable version, ant want to try out gutsy on a separate partition, but with the sme /boot partition.

On the first glance this seems to be a good idea, because you can select each of your operating systems within one menu.
But IHMO that is no good idea, because:

1. In debian/ubuntu there is an update-grub script which creates the automatic boot items. this script only chooses the kernels of it's own partition/system, all othere options you have to write per hand.
So in case you have your gutsy tribe 4 installed, and - as you wish - the installer adds your new gutsy kernel to the single /boot grub-menu, it has only the possibility to start it directly, like:

e.g.

title Ubuntu Gutsy Tribe 4
root (hd0,0)
kernel /boot/vmlinuz-blahblah root=/dev/sda3
initrd /boot/blahblah

And that as manual add, which means IT WILL NOT BE UPDATED IF YOU INSTALL A KERNEL UPDATE!

which is bad.

so you maybe see, "fixing" this would be an issue not only to this installer, but also to grub/debian scripts etc.

I think the much, much better way to do this is: keeping your boot partition, and install the gutsy GRUB into the partition, not the MBR.
Then you can manually add a "Testing" boot menu item which chainloads the partition bootloader.
Each system keeps separated.
You don't have to make another menu in gutsy, just don't prompt.

Hope that helps
Cheers,
Chris

Colin Watson (cjwatson) wrote :

This is also bug 72897.

9johnny (s.j.) wrote :

Well, I was almost fooled into formatting it, which would have left me with my main linux unbootable. is this really what we want?
Things be the way they be, this kept me pretty much from testing out gutsy the whole way, I got to this point of the install and then just gave up.
Oh well, I guess common mortals don't usually have /boot partitions, but do we really want an other windows? Ubuntu is starting to behave like it, what's with nuking a partition I never asked it to nuke?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers