Ubiquity does't start, hangs in "/usr/lib/ubiquity/bin/ubiquity", line 426, in acquire_lock, test_debconf.stdout.readline()

Bug #1326707 reported by Jean-Baptiste Lallement on 2014-06-05
44
This bug affects 7 people
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
Critical
Ubuntu Installer Team
Trusty
Critical
Mathieu Trudel-Lapierre

Bug Description

All flavors and archs of Utopic Desktop.
Last known good image is 20140527.

ubiquity-dm and ubiquity do not start.
Ubiquity started from the command line hangs forever, interrupting with CTRL-C shows that it's waiting on:

-----
ubuntu@ubuntu:~$ ubiquity -d
^CTraceback (most recent call last):
  File "/usr/lib/ubiquity/bin/ubiquity", line 636, in <module>
    main(oem_config)
  File "/usr/lib/ubiquity/bin/ubiquity", line 546, in main
    acquire_lock()
  File "/usr/lib/ubiquity/bin/ubiquity", line 426, in acquire_lock
    test_debconf.stdout.readline()
KeyboardInterrupt
umount: /var/lib/polkit-1/localauthority/90-mandatory.d: not mounted
----

The following command works fine from the command line
echo "VERSION 2.0"|sudo debconf-communitate -fnoninteractive ubiquity

ProblemType: Bug
DistroRelease: Ubuntu 14.10
Package: ubiquity 2.18.8
ProcVersionSignature: Ubuntu 3.15.0-5.10-generic 3.15.0-rc8
Uname: Linux 3.15.0-5-generic x86_64
ApportVersion: 2.14.3-0ubuntu1
Architecture: amd64
CasperVersion: 1.340
CurrentDesktop: Unity
Date: Thu Jun 5 08:54:35 2014
InstallCmdLine: file=/cdrom/preseed/ubuntu.seed boot=casper initrd=/casper/initrd.lz quiet splash --
LiveMediaBuild: Ubuntu 14.10 "Utopic Unicorn" - Alpha amd64 (20140604)
ProcEnviron:
 SHELL=/bin/bash
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 XDG_RUNTIME_DIR=<set>
SourcePackage: ubiquity
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Jean-Baptiste Lallement (jibel) wrote :
Changed in ubiquity (Ubuntu):
importance: Undecided → Critical
assignee: nobody → Ubuntu Installer Team (ubuntu-installer)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubiquity (Ubuntu):
status: New → Confirmed
Para Siva (psivaa) wrote :

This issue is seen in the daily smoke tests too, on both amd64 and i386 installs. The VM's in concern just hang with gray screens.

Jean-Baptiste Lallement (jibel) wrote :
description: updated
Jean-Baptiste Lallement (jibel) wrote :
Jean-Baptiste Lallement (jibel) wrote :
Jean-Baptiste Lallement (jibel) wrote :

I retried several images around the time of the failure and last known good image is 20140527.

On 20140528, the graphical environment starts, but there is no ubiquity-dm, ubiquity window is not displayed and the live session never starts.
On 20140529.1, ubiquity-dm is completely skipped and the live session starts directly.

I attached the manifest files for these 3 images, it corresponds with the upload of systemd.

Phil Pratt-Szeliga (pcpratts) wrote :

Here are the changes from 20140527.manifest to 20140528.manifest

Changed in ubiquity (Ubuntu):
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 2.18.9

---------------
ubiquity (2.18.9) utopic; urgency=medium

  * Flush print into debconf-communicate stdin PIPE, as print(...,file=)
    may not flush anymore. (LP: #1326707)
  * Switch sources to utopic.
  * Automatic update of included source packages: console-setup
    1.70ubuntu9, flash-kernel 3.0~rc.4ubuntu50, hw-detect 1.95ubuntu3,
    partman-basicfilesystems 95ubuntu1.
 -- Dimitri John Ledkov <email address hidden> Tue, 10 Jun 2014 01:07:43 +0100

Changed in ubiquity (Ubuntu):
status: Fix Committed → Fix Released
Changed in ubiquity (Ubuntu Trusty):
status: New → In Progress
importance: Undecided → Critical
assignee: nobody → Mathieu Trudel-Lapierre (mathieu-tl)

Hello Jean-Baptiste, or anyone else affected,

Accepted ubiquity into trusty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/ubiquity/2.18.8.9 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in ubiquity (Ubuntu Trusty):
status: In Progress → Fix Committed
tags: added: verification-needed
Adam Conrad (adconrad) wrote :

The SRU resolved this bug, according to my testing.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 2.18.8.9

---------------
ubiquity (2.18.8.9) trusty; urgency=medium

  * Automatic update of included source packages: debian-installer-utils
    1.105ubuntu1.14.04.1, flash-kernel 3.0~rc.4ubuntu49.5, hw-detect
    1.95ubuntu2.1, netcfg 1.116ubuntu2, partman-auto 118ubuntu3.14.04.2,
    partman-efi 25ubuntu6.14.04.1, grub-installer 1.78ubuntu20.2, partman-base
    172ubuntu1.1.
  * Add trusty-updates to sources.list for d-i components too; because we want
    things to be up to date...
  * Flush print into debconf-communicate stdin PIPE, as print(...,file=)
    may not flush anymore. (LP: #1326707)

 -- Mathieu Trudel-Lapierre <email address hidden> Mon, 27 Jul 2015 21:53:31 -0400

Changed in ubiquity (Ubuntu Trusty):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for ubiquity has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers