failed to use full system encryption with root, swap and home (with unencrypted boot)

Bug #1322188 reported by Schweineschwarte on 2014-05-22
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
Undecided
Unassigned

Bug Description

I want to encrypt the whole system without the boot-partition (boot is unencrypted). So I create a boot-partition and then a physical volume. Then, I delete the pre-formatted partition in it (with the reset-button). Now, I clicked on the button "new partitiontable". In the new free space of the phyical volume, I create some new partition in the physical volume (root, swap and home). I clicked now some next-buttons and then, the installation failed and the bugtracker was automaticly started.

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: ubiquity 2.18.7
ProcVersionSignature: Ubuntu 3.13.0-24.46-generic 3.13.9
Uname: Linux 3.13.0-24-generic i686
ApportVersion: 2.14.1-0ubuntu3
Architecture: i386
CasperVersion: 1.340
Date: Thu May 22 15:37:16 2014
InstallCmdLine: file=/cdrom/preseed/ubuntu.seed boot=casper initrd=/casper/initrd.lz quiet splash -- maybe-ubiquity
LiveMediaBuild: Ubuntu 14.04 LTS "Trusty Tahr" - Release i386 (20140417)
ProcEnviron:
 LANGUAGE=de_DE.UTF-8
 TERM=linux
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=de_DE.UTF-8
SourcePackage: ubiquity
UpgradeStatus: No upgrade log present (probably fresh install)

description: updated
summary: - full systemencryption with root, swap and home, but without boot
+ failed to use full system encryption with root, swap and home (without
+ boot)
summary: - failed to use full system encryption with root, swap and home (without
- boot)
+ failed to use full system encryption with root, swap and home (with
+ unencrypted boot)
description: updated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubiquity (Ubuntu):
status: New → Confirmed
mullah20144 (mullah20144) wrote :

In the form in which localization is presented in the present system, the system can not be represented and can not withstand any criticism of what! Need to completely change all the settings of localization. After this change all profiles and configuration for the installed system. Without encryption root system is not installed. Conclusion: completely non-working stuff!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers