impossible to create partition without a mouse

Bug #1302797 reported by Jb on 2014-04-04
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
High
Unassigned

Bug Description

I had previously installed Ubuntu. This time I deleted all the existing partitions and am trying to create a new partition.

Note: I am installing everything using only the keyboard.

Expected result: can add a new partition using only the keyboard, and tabbing between form fields works fine.

Steps to duplicate:
- delete all existing partitions
- tab to the "+" button and press space bar to bring up the partition list
- expected: partition screen shows up centered on the screen with first field having focus
- actual result: partition window shows up but is located in the top left of the screen (no title bar visible). This forum does not have focus so I can't tab between fields to do anything. Oddly hitting escape does close the window so it somehow does and does not have focus (?)

Even if I plug in a mouse I can't move the window anywhere because the title bar is not visible. Once I click on the create new partition window to give it focus I can now tab between fields.

I have a 1280x1024 resolution screen if that makes any difference.

Try tabbing across all the fields on the partition screen...can you tell just by looking what field has focus? It is not easy because the tab ordering on the partition screen is also out of sequence, and the field highlighting is inconsistent.

For example, shift-tab from the "Change" button incorrectly goes to the partition partition grid listing instead of the +/- buttons first. Worse, there is no indication at all that this field has focus.

On large buttons like "Install now" it's not too hard to tell it has focus because it has an extra 3 pixel border around the button. Not great, but okay visibility.

The "Device for boot loader installation" is just a one pixel border. Not consistent, a bit harder to see.

The "+" "-" buttons are worse. There is just a one pixel blue border when highlighted...and only on one side of the button! It is very difficult to see what has focus when you tab to these fields.

My test system:
Amd Athlon 6000+
3 gig ram
19" monitor (1280x1024 native resolution)
April 1, 2014 daily of trusty-desktop-amd64.iso

Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1302797

tags: added: iso-testing
Elfy (elfy) on 2014-04-05
affects: ubuntu-manual-tests → ubiquity
Colin Watson (cjwatson) on 2014-04-17
Changed in ubiquity:
importance: Undecided → High
status: New → Triaged
tags: added: a11y
affects: ubiquity → ubiquity (Ubuntu)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers