ubi-partman fails with error code 141 during install (14.04 beta 2)

Bug #1302694 reported by Julien Gabet on 2014-04-04
26
This bug affects 5 people
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
High
Unassigned

Bug Description

When running ubiquity from terminal, throws this error and never gets to the partitioning window.
When running it from the sidebar, doen't throw error but hangs before partitioning window (to never get there eventually)

It's very annoying, I seem to understand it searches for a RAID pool (I have a SSD), but I made sure to have s-ATA set to AHCI mode in the EFI/BIOS setup before booting the installer (and there's no Intel Fast Storage option there by the way)

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: ubiquity 2.17.10
ProcVersionSignature: Ubuntu 3.13.0-19.40-generic 3.13.6
Uname: Linux 3.13.0-19-generic x86_64
ApportVersion: 2.13.3-0ubuntu1
Architecture: amd64
CasperVersion: 1.339
CurrentDesktop: Unity
Date: Fri Apr 4 18:06:51 2014
InstallCmdLine: BOOT_IMAGE=/casper/vmlinuz.efi file=/cdrom/preseed/ubuntu.seed boot=casper quiet splash --
LiveMediaBuild: Ubuntu 14.04 LTS "Trusty Tahr" - Beta amd64 (20140326)
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: ubiquity
UpgradeStatus: No upgrade log present (probably fresh install)

Julien Gabet (jerome10-jg) wrote :
Julien Gabet (jerome10-jg) wrote :

Note: tried Latest daily (April 5th), same result...

Julien Gabet (jerome10-jg) wrote :

That issue is wierd, it seems my partition tables were somehow corrupted (on both disks at the same time, wtf?), but not completely (I could still boot windows, even install windows again, and I couls see all partitions in GParted and create new ones with no problem or error whatsoever).
Backing up my data on an other drive and re-creating new partition tables for both disks (gpt, same as before) did the trick.
I wonder though why GParted could see the contents of the disks and partman couldn't (or at least thought the disks were not eligible to install Ubuntu...)

Jean-Baptiste Lallement (jibel) wrote :

Thanks for your report.

There is a partition with non-ascii characters and in debug log there is is UnicodeDecodeError exception:
Exception caught in process_line:
Traceback (most recent call last):
  File "/usr/lib/ubiquity/ubiquity/filteredcommand.py", line 145, in process_line
    return self.dbfilter.process_line()
  File "/usr/lib/ubiquity/ubiquity/debconffilter.py", line 287, in process_line
    if not input_widgets[0].run(priority, question):
  File "/usr/lib/ubiquity/plugins/ubi-partman.py", line 2977, in run
    size = int(parted.partition_info(p_id)[2])
  File "/usr/lib/ubiquity/ubiquity/parted_server.py", line 220, in partition_info
    self.open_dialog('PARTITION_INFO', partition)
  File "/usr/lib/ubiquity/ubiquity/parted_server.py", line 141, in open_dialog
    self.error_handler()
  File "/usr/lib/ubiquity/ubiquity/parted_server.py", line 112, in error_handler
    exception_type = self.read_line()[0]
  File "/usr/lib/ubiquity/ubiquity/parted_server.py", line 74, in read_line
    line = self.outf.readline().rstrip('\n')
  File "/usr/lib/python3.4/codecs.py", line 313, in decode
    (result, consumed) = self._buffer_decode(data, self.errors, final)
UnicodeDecodeError: 'utf-8' codec can't decode byte 0xe9 in position 64: invalid continuation byte

Which could be due to the non-ascii label. Setting to incomplete and I'll will try to reproduce the case.

Changed in ubiquity (Ubuntu):
importance: Undecided → High
status: New → Incomplete
Jean-Baptiste Lallement (jibel) wrote :

I failed at reproducing this issue because I couldn't set a label on either an ntfs (with ntfslabel) or ext4 (with e2label) that parted_server would see. However there is enough information in the bug report to set it to triaged.

Changed in ubiquity (Ubuntu):
status: Incomplete → Triaged
tags: added: ubi-partman
Jacky Alciné (jackyalcine) wrote :

This bug is happening to me on a Dell laptop.

Alex Dueppen (adueppen) wrote :

This bug happened to me on VirtualBox on a daily build of Xenial

Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1302694

tags: added: iso-testing
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers