ubiquity-dm fails with: FileNotFoundError: [Errno 2] No such file or directory: '/usr/lib/x86_64-linux-gnu/indicator-application-service'

Bug #1297312 reported by Ove Risberg on 2014-03-25
28
This bug affects 4 people
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
Critical
Ubuntu Installer Team
Trusty
Critical
Ubuntu Installer Team

Bug Description

I created a new LiveCD install image for Ubuntu-14.04 today and automatic-ubiquity does not work anymore.

In /var/log/installer/dm I can see this message:
ubiquity-dm: Failed with an exception:
ubiquity-dm: Traceback (most recent call last):
  File "/usr/bin/ubiquity-dm", line 716, in main
    ret = run(vt, display, username)
  File "/usr/bin/ubiquity-dm", line 691, in run
    ret = dm.run(*sys.argv[4:])
  File "/usr/bin/ubiquity-dm", line 516, in run
    preexec_fn=self.drop_privileges))
  File "/usr/lib/python3.4/subprocess.py", line 848, in __init__
    restore_signals, start_new_session)
  File "/usr/lib/python3.4/subprocess.py", line 1446, in _execute_child
    raise child_exception_type(errno_num, err_msg)
FileNotFoundError: [Errno 2] No such file or directory: '/usr/lib/x86_64-linux-gnu/indicator-application-service'

The last LiveCD image I created have the /usr/lib/x86_64-linux-gnu/indicator-application-service file but not the one I created today.
The file belongs to the indicator-application package.
Version 12.10.1+14.04.20140117-0ubuntu1 have the file but 12.10.1+14.04.20140324-0ubuntu1 does not.

Ugly workaround:
ln -s /usr/lib/x86_64-linux-gnu/indicator-application/indicator-application-service /usr/lib/x86_64-linux-gnu/

Related branches

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubiquity (Ubuntu):
status: New → Confirmed
tags: added: trusty
Changed in ubiquity (Ubuntu):
importance: Undecided → Critical
Brian Murray (brian-murray) wrote :

Could you please add the log file (/var/log/syslog) from the Live CD where you experienced this error?

Changed in ubiquity (Ubuntu Trusty):
status: Confirmed → Incomplete
Jason Gerard DeRose (jderose) wrote :

I can confirm this. This will happen if when you boot from the live CD, you press shift to get the menu, pick your language, and then "Install Ubuntu".

This does not happen if you "Try Ubuntu without installing", because in this case you are passed into the normal desktop session, rather than the special ubiquity-dm session.

This also effects OEM config... the first customer boot will be broken and they'll end up autologging into the "oem" user account.

Changed in ubiquity (Ubuntu Trusty):
status: Incomplete → Triaged
assignee: nobody → Ubuntu Installer Team (ubuntu-installer)
milestone: none → ubuntu-14.04-beta-2
tags: added: rls-t-tracking
Jason Gerard DeRose (jderose) wrote :

Merge proposal for a fix here:
https://code.launchpad.net/~jderose/ubiquity/fix-1297312/+merge/212745

I confirmed this fixes the issue with regard to the customer first boot in OEM mode by manually editing /usr/bin/ubiquity-dm.

I haven't confirmed whether this fixes "Install Ubuntu" as that would require building a new ISO to properly test, something I don't have experience with with :)

Also, I haven't yet built ubiquity and and run its test, so there might be some unit test changes that are needed as well, dunno yet.

Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1297312

tags: added: iso-testing
Ove Risberg (ove-risberg) wrote :

I can confirm that applying the following patch solves the problem for automatic-ubiquity:
https://code.launchpad.net/~jderose/ubiquity/fix-1297312/+merge/212745

I am applying this change in my "preseed/early_command" until the ubiquity package is fixed.

summary: - automatic-ubiquity does no longer start in Ubuntu-14.04
+ ubiquity-dm fails with: FileNotFoundError: [Errno 2] No such file or
+ directory: '/usr/lib/x86_64-linux-gnu/indicator-application-service'
Dave Morley (davmor2) wrote :

Confirming this issue on i386/amd64/amd64+mac

Colin Watson (cjwatson) on 2014-03-26
Changed in ubiquity (Ubuntu Trusty):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 2.17.10

---------------
ubiquity (2.17.10) trusty; urgency=low

  [ Luke Yelavich ]
  * Set up atk label association for grub boot loader location combo box in
    advanced partition editor.
  * Add Super + Alt + S as an activation keystroke for the screen reader
    profile. This mirrors the same keystroke that can be used to activate the
    screen reader when in a Unity or GNOME desktop. The Control + S keystroke
    is still present for transitional purposes, so new users don't need to
    hunt for new information when they attempt to install trusty. It will be
    removed in trusty+1.

  [ Jason Gerard DeRose ]
  * ubiquity-dm: 'indicator-application-service' =>
    'indicator-application/indicator-application-service' (LP: #1297312).

  [ Colin Watson ]
  * Resolve LABEL= and UUID= entries in /etc/crypttab into real devices
    before trying to run swapoff and test -b on them (LP: #1296697).
  * Automatic update of included source packages: flash-kernel
    3.0~rc.4ubuntu48, grub-installer 1.78ubuntu18, partconf 1.45,
    partman-jfs 43, partman-lvm 90, partman-newworld 32.
 -- Colin Watson <email address hidden> Wed, 26 Mar 2014 15:11:43 +0000

Changed in ubiquity (Ubuntu Trusty):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers