Trusty Desktop installer crashed with "Encrypted Home" set

Bug #1296697 reported by Jean-Baptiste Lallement on 2014-03-24
16
This bug affects 4 people
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
Critical
Colin Watson
Trusty
Critical
Colin Watson

Bug Description

Trusty Desktop 20140323

Installation with the following settings:
- French
- Third Party
- Download updates during installation
- Encrypted home
- Other settings kept to defaults

Installation crash after the step 'User Info' with:
Mar 24 12:22:48 ubuntu ubiquity: /usr/share/ubiquity/user-setup-encrypted-swap: 84: /usr/share/ubiquity/user-setup-encrypted-swap: arithmetic expression: expecting primary: "/1048576"

According to [1] 1rst failure happened on build 20140316

[1] http://jenkins.qa.ubuntu.com/job/trusty-desktop-amd64-smoke-encrypted_home/

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: ubiquity 2.17.9 [modified: lib/partman/automatically_partition/question]
ProcVersionSignature: Ubuntu 3.13.0-19.39-generic 3.13.6
Uname: Linux 3.13.0-19-generic x86_64
ApportVersion: 2.13.3-0ubuntu1
Architecture: amd64
CasperVersion: 1.339
CurrentDesktop: Unity
Date: Mon Mar 24 13:31:32 2014
InstallCmdLine: file=/cdrom/preseed/ubuntu.seed boot=casper initrd=/casper/initrd.lz quiet splash -- maybe-ubiquity
LiveMediaBuild: Ubuntu 14.04 LTS "Trusty Tahr" - Alpha amd64 (20140323)
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=fr_FR.UTF-8
 SHELL=/bin/bash
SourcePackage: ubiquity
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Jean-Baptiste Lallement (jibel) wrote :
Jean-Baptiste Lallement (jibel) wrote :

Same error found during smoke testing:
https://jenkins.qa.ubuntu.com/view/Trusty/view/Smoke Testing/job/trusty-desktop-i386-smoke-encrypted_home

Mar 23 11:36:27 utah-21391-trusty-i386 ubiquity: INFO: Setting up swap: [/dev/vda5]
2014-03-23T11:36:27.139740+00:00 utah-21391-trusty-i386 ubiquity: INFO: Setting up swap: [/dev/vda5]
Mar 23 11:36:27 utah-21391-trusty-i386 ubiquity: WARNING: Commented out your unencrypted swap from /etc/fstab
Mar 23 11:36:27 utah-21391-trusty-i386 ubiquity: INFO: Successfully setup encrypted swap!
Mar 23 11:36:27 utah-21391-trusty-i386 ubiquity: stat:
Mar 23 11:36:27 utah-21391-trusty-i386 ubiquity: cannot stat ���UUID=f9979fe9-d619-4329-9a78-db272e07d326���
Mar 23 11:36:27 utah-21391-trusty-i386 ubiquity: : No such file or directory
Mar 23 11:36:27 utah-21391-trusty-i386 ubiquity:
Mar 23 11:36:27 utah-21391-trusty-i386 ubiquity: /usr/share/ubiquity/user-setup-encrypted-swap: 84: /usr/share/ubiquity/user-setup-encrypted-swap: arithmetic expression: expecting primary: "/1048576"
Mar 23 11:36:27 utah-21391-trusty-i386 ubiquity[2502]: debconffilter_done: ubi-usersetup (current: ubi-usersetup)
Mar 23 11:36:27 utah-21391-trusty-i386 ubiquity[2502]: dbfilter_handle_status: ('ubi-usersetup', 2)
2014-03-23T11:36:27.208170+00:00 utah-21391-trusty-i386 ubiquity: WARNING: Commented out your unencrypted swap from /etc/fstab
2014-03-23T11:36:27.215698+00:00 utah-21391-trusty-i386 ubiquity: INFO: Successfully setup encrypted swap!
2014-03-23T11:36:27.239588+00:00 utah-21391-trusty-i386 ubiquity: stat:
2014-03-23T11:36:27.239606+00:00 utah-21391-trusty-i386 ubiquity: cannot stat ���UUID=f9979fe9-d619-4329-9a78-db272e07d326���
2014-03-23T11:36:27.239736+00:00 utah-21391-trusty-i386 ubiquity: : No such file or directory
2014-03-23T11:36:27.239750+00:00 utah-21391-trusty-i386 ubiquity:
2014-03-23T11:36:27.239937+00:00 utah-21391-trusty-i386 ubiquity: /usr/share/ubiquity/user-setup-encrypted-swap: 84: /usr/share/ubiquity/user-setup-encrypted-swap: arithmetic expression: expecting primary: "/1048576"
2014-03-23T11:36:27.244542+00:00 utah-21391-trusty-i386 ubiquity[2502]: debconffilter_done: ubi-usersetup (current: ubi-usersetup)
2014-03-23T11:36:27.244800+00:00 utah-21391-trusty-i386 ubiquity[2502]: dbfilter_handle_status: ('ubi-usersetup', 2)

description: updated
Changed in ubiquity (Ubuntu):
importance: Undecided → Critical
assignee: nobody → Ubuntu Installer Team (ubuntu-installer)
summary: - Trusty Desktop installer crashed - French - Encrypted Home
+ Trusty Desktop installer crashed - Encrypted Home
summary: - Trusty Desktop installer crashed - Encrypted Home
+ Trusty Desktop installer crashed with "Encrypted Home" set
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubiquity (Ubuntu):
status: New → Confirmed
tags: added: qa-daily-testing rls-t-tracking
Changed in ubiquity (Ubuntu Trusty):
milestone: none → ubuntu-14.04-beta-2
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1296697

tags: added: iso-testing
Jean-Baptiste Lallement (jibel) wrote :

Content of /etc/crypttab when this crash occurs.

description: updated
Jean-Baptiste Lallement (jibel) wrote :

This bug has been introduced by :

ecryptfs-utils (104-0ubuntu1)

  [ Dustin Kirkland ]
  * src/utils/ecryptfs-setup-swap: LP: #1172014
    - write crypttab entry using UUID

Jean-Baptiste Lallement (jibel) wrote :

I tried http://paste.ubuntu.com/7151118/ but then there is no swap after installation even if /etc/crypttab looks correct.

Colin Watson (cjwatson) on 2014-03-26
Changed in ubiquity (Ubuntu Trusty):
assignee: Ubuntu Installer Team (ubuntu-installer) → Colin Watson (cjwatson)
Colin Watson (cjwatson) on 2014-03-26
Changed in ubiquity (Ubuntu Trusty):
status: Confirmed → In Progress
Colin Watson (cjwatson) wrote :

OK, so I have a fix for the ubiquity side of things, but the swap setup post-reboot still doesn't work. However, I think that's something that needs to be fixed elsewhere. I started a conversation with Dustin about it on IRC and we'll see where that goes:

14:53 <cjwatson> kirkland: so, bug 1172014
14:54 <cjwatson> kirkland: this change caused a regression in ubiquity; not really your fault, ubiquity needed to resolve the UUID= in crypttab because it explicitly zeroes the device
14:54 <cjwatson> kirkland: but more importantly, I can't actually make the swap setup work properly even after fixing that ubiquity bug
14
:56 <cjwatson> kirkland: I think https://bugs.launchpad.net/ubuntu/+source/ecryptfs-utils/+bug/1172014/comments/9 has the right of it; the swap space is set up with a random key, there's no container, so how can it have a stable UUID?
14:58 <cjwatson> kirkland: indeed when I reboot after installation, re-point crypttab to /dev/sda5 so that I can cryptdisks_start, copy the new UUID into /etc/crypttab, and reboot, it still doesn't work

Changed in ubiquity (Ubuntu Trusty):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 2.17.10

---------------
ubiquity (2.17.10) trusty; urgency=low

  [ Luke Yelavich ]
  * Set up atk label association for grub boot loader location combo box in
    advanced partition editor.
  * Add Super + Alt + S as an activation keystroke for the screen reader
    profile. This mirrors the same keystroke that can be used to activate the
    screen reader when in a Unity or GNOME desktop. The Control + S keystroke
    is still present for transitional purposes, so new users don't need to
    hunt for new information when they attempt to install trusty. It will be
    removed in trusty+1.

  [ Jason Gerard DeRose ]
  * ubiquity-dm: 'indicator-application-service' =>
    'indicator-application/indicator-application-service' (LP: #1297312).

  [ Colin Watson ]
  * Resolve LABEL= and UUID= entries in /etc/crypttab into real devices
    before trying to run swapoff and test -b on them (LP: #1296697).
  * Automatic update of included source packages: flash-kernel
    3.0~rc.4ubuntu48, grub-installer 1.78ubuntu18, partconf 1.45,
    partman-jfs 43, partman-lvm 90, partman-newworld 32.
 -- Colin Watson <email address hidden> Wed, 26 Mar 2014 15:11:43 +0000

Changed in ubiquity (Ubuntu Trusty):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers