Mythbuntu Installer Crashes: File "/usr/lib/python3/dist-packages/mythbuntu_common/vnc.py", line 58, in create_password ValueError: Password should be passed as bytes

Bug #1290460 reported by Andreas Weller on 2014-03-10
688
This bug affects 76 people
Affects Status Importance Assigned to Milestone
mythbuntu-common (Ubuntu)
High
Mario Limonciello
Trusty
High
Thomas Mashos
mythbuntu-live-autostart (Ubuntu)
High
Mario Limonciello
Trusty
High
Thomas Mashos
ubiquity (Ubuntu)
High
Mario Limonciello
Trusty
High
Mario Limonciello

Bug Description

[Impact]
 * Mythbuntu installer crashes if VNC is enabled
 * Mythbuntu control center crashes if VNC is enabled

 * Mythbuntu does LTS only releases, so we should make sure this is fixed for LTS.
[Test Case]

 * Run an install with a password >=6 characters. Check the VNC checkbox.
 * See if install completes

[Regression Potential]

 * As this is the only function affected by this patch and it fixes both places it's used (installer and control center) I don't see any other regression potential.
[Other Info]

Exception during installation:
Mar 10 17:17:39 mythbuntu /plugininstall.py: Traceback (most recent call last):
Mar 10 17:17:39 mythbuntu /plugininstall.py: File "/usr/share/ubiquity/plugininstall.py", line 1780, in <module>
Mar 10 17:17:39 mythbuntu /plugininstall.py: install.run()
Mar 10 17:17:39 mythbuntu /plugininstall.py: File "/usr/share/ubiquity/plugininstall.py", line 78, in wrapper
Mar 10 17:17:39 mythbuntu /plugininstall.py: func(self)
Mar 10 17:17:39 mythbuntu /plugininstall.py: File "/usr/share/ubiquity/plugininstall.py", line 204, in run
Mar 10 17:17:39 mythbuntu /plugininstall.py: self.configure_plugins()
Mar 10 17:17:39 mythbuntu /plugininstall.py: File "/usr/share/ubiquity/plugininstall.py", line 580, in configure_plugins
Mar 10 17:17:39 mythbuntu /plugininstall.py: self.run_plugin(plugin)
Mar 10 17:17:39 mythbuntu /plugininstall.py: File "/usr/share/ubiquity/plugininstall.py", line 554, in run_plugin
Mar 10 17:17:39 mythbuntu /plugininstall.py: ret = inst.install(self.target, PluginProgress(self.db))
Mar 10 17:17:39 mythbuntu /plugininstall.py: File "/usr/lib/ubiquity/plugins/myth-install-type.py", line 198, in install
Mar 10 17:17:39 mythbuntu /plugininstall.py: self.setup_roles()
Mar 10 17:17:39 mythbuntu /plugininstall.py: File "/usr/lib/ubiquity/plugins/myth-install-type.py", line 178, in setup_roles
Mar 10 17:17:39 mythbuntu /plugininstall.py: vnc.create_password(passwd)
Mar 10 17:17:39 mythbuntu /plugininstall.py: File "/usr/lib/python3/dist-packages/mythbuntu_common/vnc.py", line 58, in create_password
Mar 10 17:17:39 mythbuntu /plugininstall.py: raise ValueError('Password should be passed as bytes')
Mar 10 17:17:39 mythbuntu /plugininstall.py: ValueError: Password should be passed as bytes
Mar 10 17:17:39 mythbuntu /plugininstall.py:

tags: added: installer-crash
Changed in ubiquity (Ubuntu):
importance: Undecided → High
Changed in ubiquity (Ubuntu):
assignee: nobody → Mario Limonciello (superm1)

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubiquity (Ubuntu):
status: New → Confirmed
Changed in ubiquity (Ubuntu Trusty):
status: Confirmed → Triaged
Regen (regen2) wrote :

Caused by the VNC plugin installer and acknowledged by Thomas Mashos (Mythbuntu team).
http://www.mythtv.org/pipermail/mythtv-users/2014-April/362863.html

The workaround is to install without the VNC plugin ticked and then later install VNC and set the password manually:
sudo apt-get install x11vnc
mkdir $HOME/.vnc
x11vnc -storepasswd $HOME/.vnc/passwd

Attempting to install via Mythbuntu Control Centre after the installation has finished causes the same error.

Regen (regen2) wrote :

... and reboot to get it working. The script that uses the password and launches the VNC server (/usr/share/mythbuntu/session.sh) only runs at login.

summary: - Mythbuntu Installer Crashes
+ Mythbuntu Installer Crashes: File "/usr/lib/python3/dist-
+ packages/mythbuntu_common/vnc.py", line 58, in create_password
+ ValueError: Password should be passed as bytes
Changed in mythbuntu-common (Ubuntu):
assignee: nobody → Mario Limonciello (superm1)
Changed in mythbuntu-common (Ubuntu Trusty):
assignee: nobody → Mario Limonciello (superm1)
Changed in mythbuntu-common (Ubuntu):
status: New → Triaged
Changed in mythbuntu-common (Ubuntu Trusty):
status: New → Triaged
Changed in mythbuntu-common (Ubuntu):
importance: Undecided → High
Changed in mythbuntu-common (Ubuntu Trusty):
importance: Undecided → High
Changed in ubiquity (Ubuntu):
status: Triaged → Invalid
Changed in ubiquity (Ubuntu Trusty):
status: Triaged → Invalid
Thomas Mashos (tgm4883) wrote :

I've pushed a fix for this to the live-autostart branch

Changed in mythbuntu-common (Ubuntu):
status: Triaged → Fix Released
status: Fix Released → Fix Committed
Changed in mythbuntu-live-autostart (Ubuntu):
status: New → Fix Committed
Changed in mythbuntu-live-autostart (Ubuntu Trusty):
status: New → In Progress
Changed in mythbuntu-common (Ubuntu Trusty):
status: Triaged → In Progress
assignee: Mario Limonciello (superm1) → Thomas Mashos (tgm4883)
Changed in mythbuntu-live-autostart (Ubuntu):
assignee: nobody → Mario Limonciello (superm1)
Changed in mythbuntu-live-autostart (Ubuntu Trusty):
assignee: nobody → Thomas Mashos (tgm4883)
description: updated
Changed in mythbuntu-live-autostart (Ubuntu Trusty):
milestone: none → ubuntu-14.04.1
Changed in mythbuntu-common (Ubuntu Trusty):
milestone: none → ubuntu-14.04.1
Brian Murray (brian-murray) wrote :

This is the same bug as bug 1309553 and since that one is referenced by a changelog, I'll mark this as a duplicate of that.

Scott Kitterman (kitterman) wrote :

This one is referenced in the 1290460 SRU, so I swapped it around.

Changed in mythbuntu-live-autostart (Ubuntu):
status: Fix Committed → In Progress
Changed in mythbuntu-common (Ubuntu):
status: Fix Committed → In Progress
Changed in mythbuntu-live-autostart (Ubuntu Trusty):
status: In Progress → Fix Committed
tags: added: verification-needed

Hello Andreas, or anyone else affected,

Accepted mythbuntu-live-autostart into trusty-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/mythbuntu-live-autostart/0.70 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

H Buus (faginbagin) wrote :

I'm confused. I don't see how enabling a proposed repo on a precise install would allow one to test a problem seen using a mythbuntu trusty iso. Wouldn't I need an updated iso with this package? However, I can see it would be relatively easy to test the fix on a computer that already has trusty installed if there were a proposed package for mythbuntu-common. Then I could install that package and test by using MCC to change the x11vnc password, right?

You can install the fixed packages in the live environment then run
though the install.
Thanks,

Thomas Mashos

On Thu, May 15, 2014 at 11:34 AM, H Buus <email address hidden> wrote:
> I'm confused. I don't see how enabling a proposed repo on a precise
> install would allow one to test a problem seen using a mythbuntu trusty
> iso. Wouldn't I need an updated iso with this package? However, I can
> see it would be relatively easy to test the fix on a computer that
> already has trusty installed if there were a proposed package for
> mythbuntu-common. Then I could install that package and test by using
> MCC to change the x11vnc password, right?
>
> --
> You received this bug notification because you are a member of Mythbuntu
> Team, which is subscribed to the bug report.
> https://bugs.launchpad.net/bugs/1290460
>
> Title:
> Mythbuntu Installer Crashes: File "/usr/lib/python3/dist-
> packages/mythbuntu_common/vnc.py", line 58, in create_password
> ValueError: Password should be passed as bytes
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu/+source/mythbuntu-common/+bug/1290460/+subscriptions

Regen (regen2) wrote :

I can confirm that at least one scenario works.

When booting from hard disk with Mythbuntu 14.04 amd64 installed:
- enable trusty-proposed
- update mythbuntu-common from 0.73 to 0.74
- use Mythbuntu Control Centre to install VNC, including setting the password
VNC is installed successfully and the password works after a reboot.

When booting from ISO into live environment:
- enable trusty-proposed
- update mythbuntu-common from 0.73 to 0.74
- disable trusty-proposed
- Use desktop icon to install Mythbuntu
the installation crashes with a different error:
Gtk-Message: Failed to load module "overlay-scrollbar"
Submitted this as bug 1320439, as an easy way to provide details.
https://bugs.launchpad.net/ubuntu/+source/ubiquity/+bug/1320439

This crash does not happen if VNC is not ticked in the installation options.

Is anyone else able to confirm that updating mythbuntu-common from 0.73 to 0.74 in the live environment before installing to hard disk works? I can't figure out how to avoid this crash. If anyone is able to advise how to avoid this crash I'm happy to try testing again.

Regen (regen2) wrote :

Looking at the logs in bug 1320439 (testing results), it is the same error but on line 59 instead of line 58. This indicates that it is using the new vnc.py, but still failing, so I will mark this as verification-failed.

tags: added: verification-failed
removed: verification-needed
dallas8101 (dallas-webfathom) wrote :

I tried the approach suggested to un-check the VNC during install. I was able to do an erase and re-install of Mythbuntu 14.04 then. I did updates including the proposed repository. I then went into MCC to enable VNC. During the install it failed, but also failed to submit the report. After some other work on installing the Ceton drivers and attempting to pair it with Comcast, so far unsuccessful, I disabled (uninstalled?) the VNC and then enabled again. This time it gave no error, but I still do not have a functioning VNC. I cannot connect from Mac OS X Screen Sharing, but I can ssh in.

Thomas Mashos (tgm4883) wrote :

Regen,

You updated the wrong package. Please upgrade mythbuntu-live-autostart and test again.

tags: added: verification-done
removed: verification-failed
tags: added: verification-needed
removed: verification-done
Regen (regen2) wrote :

Testing booting from ISO into live environment:
- enable trusty-proposed
- update ONLY mythbuntu-live-autostart from 0.69 to 0.70
- disable trusty-proposed
- Use desktop icon to install Mythbuntu
This installation fails.

Testing again, booting from ISO into live environment:
- enable trusty-proposed
- update 2 packages:
  - mythbuntu-common from 0.73 to 0.74
  - mythbuntu-live-autostart from 0.69 to 0.70
- disable trusty-proposed
- Use desktop icon to install Mythbuntu, including ticking VNC
This installation succeeds, and VNC works on first boot.

Tagging this bug as verification-done.

tags: added: verification-done
removed: verification-needed
Regen (regen2) wrote :

Hi Dallas,
Updates available in -proposed are not fully tested and verified as working. If you have installed all updates available from -proposed you may have installed something that is not working properly. You may find it simpler to erase your hard disk and start again.

I can personally vouch for using the following method as I have used this and I have my Mythbuntu box running in Prod, including a high WAF ;) http://en.wikipedia.org/wiki/Wife_acceptance_factor

Install Mythbuntu with the VNC option unticked.
After the installation is finished and you have booted from the hard disk, install VNC and set the password manually:
  Open a terminal (Applications > System > Xfce Terminal) and type the following commands:
  sudo apt-get install x11vnc
  mkdir $HOME/.vnc
  x11vnc -storepasswd $HOME/.vnc/passwd
Install all other updates are you would normally. Do NOT include updates from -proposed.
Reboot.

If you look in MCC it will now show VNC as already installed (Enabled), but don't touch it. It is already working.

H Buus (faginbagin) wrote :

I can confirm when booting from hard disk with Mythbuntu 14.04 *i386* installed:
- enable trusty-proposed
- update mythbuntu-common from 0.73 to 0.74
- use Mythbuntu Control Centre to install VNC, including setting the password
VNC is installed successfully and the password works after a reboot.

H Buus (faginbagin) wrote :

Booted from USB stick with Mythbuntu 14.04 *i386* into live environment:
- enable trusty-proposed
- update 2 packages:
  - mythbuntu-common from 0.73 to 0.74
  - mythbuntu-live-autostart from 0.69 to 0.70
- disable trusty-proposed
- Use desktop icon to install Mythbuntu, including ticking VNC
This installation succeeds, and VNC works on first boot.

I did not try updating ONLY mythbuntu-live-autostart based on Regen's experience.

Changed in mythbuntu-live-autostart (Ubuntu Trusty):
importance: Undecided → High
Changed in mythbuntu-live-autostart (Ubuntu):
importance: Undecided → High
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mythbuntu-live-autostart - 0.70

---------------
mythbuntu-live-autostart (0.70) trusty-proposed; urgency=low

  * Fix VNC crashing ubiquity during install (LP: #1290460)
 -- Thomas Mashos <email address hidden> Thu, 08 May 2014 11:47:26 -0700

Changed in mythbuntu-live-autostart (Ubuntu Trusty):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for mythbuntu-live-autostart has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Changed in mythbuntu-common (Ubuntu Trusty):
status: In Progress → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mythbuntu-live-autostart - 0.70build1

---------------
mythbuntu-live-autostart (0.70build1) utopic; urgency=medium

  * No change rebuild for utopic. (LP: #1290460)
 -- Mario Limonciello <email address hidden> Thu, 22 May 2014 22:32:23 -0500

Changed in mythbuntu-live-autostart (Ubuntu):
status: In Progress → Fix Released
Changed in mythbuntu-common (Ubuntu):
status: In Progress → Fix Released
sheff (doughed2003) wrote :

Hi , i reported my bug and it bumped me to this one, exactly what is it I'm supposed to do?
I was trying to install to and old sony desktop with a wintv card i had laying around.
Is there an ISO with the fix added that i can download? or is it more complicated than that?

On Mon, Jul 14, 2014 at 04:59:47PM -0000, sheff wrote:
> Hi , i reported my bug and it bumped me to this one, exactly what is it I'm supposed to do?
> I was trying to install to and old sony desktop with a wintv card i had laying around.
> Is there an ISO with the fix added that i can download? or is it more complicated than that?
>
...

I just re-ran the install without selecting VNC service - I don't use it anyway. I think it might be just a 1-click install later in the Mythbuntu Control Centre.
Cheers!
--
Greg

Same here. I think the VNC installer will work fine as long as you set the
initial user's password strong enough but I did not verify.
On Jul 14, 2014 6:31 PM, "Greg Cunningham" <email address hidden>
wrote:

> On Mon, Jul 14, 2014 at 04:59:47PM -0000, sheff wrote:
> > Hi , i reported my bug and it bumped me to this one, exactly what is it
> I'm supposed to do?
> > I was trying to install to and old sony desktop with a wintv card i had
> laying around.
> > Is there an ISO with the fix added that i can download? or is it more
> complicated than that?
> >
> ...
>
> I just re-ran the install without selecting VNC service - I don't use it
> anyway. I think it might be just a 1-click install later in the Mythbuntu
> Control Centre.
> Cheers!
> --
> Greg
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (1338152).
> https://bugs.launchpad.net/bugs/1290460
>
> Title:
> Mythbuntu Installer Crashes: File "/usr/lib/python3/dist-
> packages/mythbuntu_common/vnc.py", line 58, in create_password
> ValueError: Password should be passed as bytes
>
> Status in “mythbuntu-common” package in Ubuntu:
> Fix Released
> Status in “mythbuntu-live-autostart” package in Ubuntu:
> Fix Released
> Status in “ubiquity” package in Ubuntu:
> Invalid
> Status in “mythbuntu-common” source package in Trusty:
> Fix Released
> Status in “mythbuntu-live-autostart” source package in Trusty:
> Fix Released
> Status in “ubiquity” source package in Trusty:
> Invalid
>
> Bug description:
> [Impact]
> * Mythbuntu installer crashes if VNC is enabled
> * Mythbuntu control center crashes if VNC is enabled
>
> * Mythbuntu does LTS only releases, so we should make sure this is
> fixed for LTS.
> [Test Case]
>
> * Run an install with a password >=6 characters. Check the VNC
> checkbox.
> * See if install completes
>
> [Regression Potential]
>
> * As this is the only function affected by this patch and it fixes both
> places it's used (installer and control center) I don't see any other
> regression potential.
> [Other Info]
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu/+source/mythbuntu-common/+bug/1290460/+subscriptions
>

Brian Murray (brian-murray) wrote :

If you install from Ubuntu 14.04.1 media you should not encounter this bug, this was not fixed in time to be included on the 14.04 medai.

Andy Wood (ahwood-9) wrote :

Confirmed that not enabling VNC during the installation works around the installer crash issue.
(Still a problem with 14.04.4 install media AMD64).
http://cdimage.ubuntu.com/mythbuntu/releases/14.04.4/release/

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers