[apport] ubiquity crashed with UnicodeEncodeError in partman_edit_dialog()

Bug #128554 reported by Yannick on 2007-07-26
6
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
Medium
Colin Watson
Hardy
Medium
Colin Watson

Bug Description

Binary package hint: ubiquity

I tried to set "données" as a partition name, but then, it crashed.

I'm still able to install it, with the same session, and I didn't launch the installer a second time...it didn't really crashed. If apport hadn't told me, I wouldn't have notice it :)

Thanks !

ProblemType: Crash
Architecture: i386
Date: Thu Jul 26 16:04:03 2007
DistroRelease: Ubuntu 7.04
ExecutablePath: /usr/lib/ubiquity/bin/ubiquity
InterpreterPath: /usr/bin/python2.5
Package: ubiquity 1.4.11
PackageArchitecture: i386
ProcCmdline: /usr/bin/python /usr/lib/ubiquity/bin/ubiquity kde-ui
ProcCwd: /home/ubuntu
ProcEnviron:
 PATH=/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=fr_FR.UTF-8
 SHELL=/bin/bash
PythonArgs: ['/usr/lib/ubiquity/bin/ubiquity', 'kde-ui']
SourcePackage: ubiquity
Uname: Linux ubuntu 2.6.20-15-generic #2 SMP Sun Apr 15 07:36:31 UTC 2007 i686 GNU/Linux

Yannick (splitsch) wrote :
Changed in ubiquity:
importance: Undecided → Medium
status: New → Confirmed
Colin Watson (cjwatson) wrote :

Thanks, and sorry for the delay. This will be fixed for the next upload.

Changed in ubiquity:
assignee: nobody → kamion
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 1.9.5

---------------
ubiquity (1.9.5) intrepid; urgency=low

  [ Colin Watson ]
  * Update README to document --automatic option.
  * Direct questions to the ubuntu-installer list rather than to me
    personally.
  * Depend on kdesudo | kdesudo-kde4 (the latter is transitional now).
  * KDE frontend:
    - Fix crash on selecting non-ASCII options in the "Use as:" menu while
      creating a partition (LP: #247993).
    - Fix crash when entering a non-ASCII mount point (LP: #128554).
  * Preseed netcfg/dhcp_ntp_servers from install component rather than
    clock-setup, since the latter doesn't have debconf database access at
    the right time (LP: #251089).

  [ Jonathan Riddell ]
  * language.py: Change string to unicode, fixes crash when using KDE
    frontend, closes LP: #251097
  * KDE frontend
   - comment out dcop code
   - add set_hostname method
   - temporarily force sudo until we work out why kdesudo stops it passing
     partitioning stage, bug 251203

  [ Evan Dandrea ]
  * Automatic update of included source packages: user-setup
    1.20ubuntu3.

 -- Evan Dandrea <email address hidden> Wed, 23 Jul 2008 12:48:57 -0400

Changed in ubiquity:
status: Fix Committed → Fix Released
Colin Watson (cjwatson) wrote :

Installation failure with a straightforward fix; I think we should clean this up for 8.04.3.

Changed in ubiquity (Ubuntu Hardy):
assignee: nobody → Colin Watson (cjwatson)
importance: Undecided → Medium
milestone: none → ubuntu-8.04.3
status: New → Triaged
status: Triaged → In Progress
Martin Pitt (pitti) wrote :

Accepted ubiquity into hardy-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in ubiquity (Ubuntu Hardy):
status: In Progress → Fix Committed
tags: added: verification-needed
Steve Beattie (sbeattie) wrote :

I was able to reproduce this issues with the version of ubiquity in kubuntu 8.04.2. I attempted to reproduce the issue with the version of ubiquity in hardy-proposed, 1.8.14, while running within the 8.04.2 livecd environment and can confirm that it fixes the crash; however, a partition with a unicode mount point is not displayed correctly in the manual partitioner, but the installation continues to completion.

I also verified that this issue and bug 247993 are not present in the ubiquity GTK frontend in the 8.04.3 daily livecd snapshot (as well as not being present in the 8.04.2 ubuntu images before I realized this issue was specific to the KDE frontend).

Attached is a screenshot of how the attempted mount point /ũûúù-çǺª was displayed by the partitioner, though the mount point did get created correctly.

Given that kubuntu isos won't be respun for 8.04.3, that this issue is not addressed perfectly but does improve the situation (for hypothetical users who updated ubiquity before installing or for kubuntu respins) and doesn't appear to introduce any regressions, I don't believe the display issue is worth blocking the update. Marking verification-done.

tags: added: verification-done
removed: verification-needed
Steve Beattie (sbeattie) wrote :

(Minor correction to my previous message, the mount point that was created correctly but displayed incorrectly was '/ũûúùçÇ', not '/ũûúù-çǺª'. Sorry for the noise.)

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 1.8.14

---------------
ubiquity (1.8.14) hardy-proposed; urgency=low

  * KDE frontend:
    - Fix crash on selecting non-ASCII options in the "Use as:" menu while
      creating a partition (LP: #247993).
    - Fix crash when entering a non-ASCII mount point (LP: #128554).
  * Automatic update of included source packages: partman-basicfilesystems
    56ubuntu5.

 -- Colin Watson <email address hidden> Tue, 09 Jun 2009 22:41:48 +0100

Changed in ubiquity (Ubuntu Hardy):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers