ubiquity crashed with AttributeError in item_str(): 'list' object has no attribute 'find'

Bug #1282640 reported by jbvoolstra on 2014-02-20
48
This bug affects 9 people
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
Critical
Dimitri John Ledkov
Trusty
Critical
Dimitri John Ledkov

Bug Description

Just booting on CD in attempt to install Ubuntu 14.04 i396 daily build, downloaded 20 feb 2014

ProblemType: Crash
DistroRelease: Ubuntu 14.04
Package: ubiquity 2.17.7
ProcVersionSignature: Ubuntu 3.13.0-10.30-generic 3.13.3
Uname: Linux 3.13.0-10-generic i686
ApportVersion: 2.13.2-0ubuntu5
Architecture: i386
CasperVersion: 1.337
Date: Thu Feb 20 15:33:02 2014
ExecutablePath: /usr/lib/ubiquity/bin/ubiquity
InstallCmdLine: file=/cdrom/preseed/ubuntu.seed boot=casper initrd=/casper/initrd.lz quiet splash -- maybe-ubiquity
InterpreterPath: /usr/bin/python3.4
LiveMediaBuild: Ubuntu 14.04 LTS "Trusty Tahr" - Alpha i386 (20140220.1)
ProcCmdline: /usr/bin/python3 /usr/lib/ubiquity/bin/ubiquity --greeter --only
ProcEnviron: Error: [Errno 13] Permission denied: '/proc/2371/environ'
PythonArgs: ['/usr/lib/ubiquity/bin/ubiquity', '--greeter', '--only']
SourcePackage: ubiquity
Title: ubiquity crashed with AttributeError in item_str(): 'list' object has no attribute 'find'
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups:

Related branches

jbvoolstra (jbvoolstra-gmail) wrote :
tags: removed: need-duplicate-check
Changed in ubiquity (Ubuntu):
importance: Undecided → Medium
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubiquity (Ubuntu):
status: New → Confirmed
information type: Private → Public
Changed in ubiquity (Ubuntu):
importance: Medium → Critical
assignee: nobody → Dimitri John Ledkov (xnox)
jiaowen520li (jiaowen520li) wrote :

This problem also exists in Ubuntu Kylin 14.04 amd64 & i386 daily build, downloaded 20 feb 2014.

Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1282640

tags: added: iso-testing
CBrider (zaknafien13) wrote :

I downloaded the AMD64 daily build of 14.04 today (Feb 21.) While attempting to install he program I recieved this error. The installer has not yet asked if I would like to install or try ubuntu. The computer is an older AMD Turion Laptop with Raedon graphics. I am attempting to instal from a USB that I built using the Ubuntu Startup Disk Creator. Enough of the desktop did load so that I can use firefox to write this report, and I see the sound and system-power (shutdown, restart) icons. Let me know if you would like any other information.

Dimitri John Ledkov (xnox) wrote :

Fix committed but cannot be released due to bug #1283152

Changed in ubiquity (Ubuntu Trusty):
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 2.17.8

---------------
ubiquity (2.17.8) trusty; urgency=medium

  * Fix deprecated warnings in nmwidgets.
  * Run test-suite under auto-allocated xvfb-run server.
  * g-i changed return values, thus convert list of integers into
    bytestring to preserve old logic in item_str. (LP: #1282640)
  * Launch unity-settings-daemon if available.
  * Automatic update of included source packages: apt-setup
    1:0.80ubuntu6, base-installer 1.143ubuntu1, choose-mirror
    2.55ubuntu1, debian-installer-utils 1.105ubuntu1, hw-detect
    1.95ubuntu2.
 -- Dimitri John Ledkov <email address hidden> Fri, 21 Feb 2014 20:00:50 +0000

Changed in ubiquity (Ubuntu Trusty):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers