Activity log for bug #1265192

Date Who What changed Old value New value Message
2013-12-31 14:08:18 Steve Devine bug added bug
2014-01-06 10:49:13 Launchpad Janitor ubiquity (Ubuntu): status New Confirmed
2014-01-06 11:00:28 Tomasz Kuczak bug added subscriber Dan Sufho
2014-01-09 15:42:34 Phillip Susi ubiquity (Ubuntu): importance Undecided Critical
2014-01-09 15:42:34 Phillip Susi ubiquity (Ubuntu): status Confirmed Triaged
2014-02-03 09:01:35 JackT bug added subscriber JackT
2014-02-03 12:20:27 Dario Ruellan marked as duplicate 1256874
2014-02-03 15:01:31 Phillip Susi removed duplicate marker 1256874
2014-02-03 15:02:37 Phillip Susi summary Reinstallation wipes out all partitions Reinstallation wipes out all/other partitions
2014-02-12 15:40:41 George Kantianis bug task added ubiquity
2014-02-13 07:57:08 Martin Dindoffer bug added subscriber Martin Dindoffer
2014-04-01 23:19:50 Brian Murray bug added subscriber Brian Murray
2014-04-01 23:23:21 Dimitri John Ledkov ubiquity (Ubuntu): assignee Dimitri John Ledkov (xnox)
2014-04-01 23:23:25 Dimitri John Ledkov bug task deleted ubiquity
2014-04-04 12:55:25 sachit bug added subscriber staticd
2014-04-04 13:46:58 Phillip Susi ubiquity (Ubuntu): status Triaged Incomplete
2014-04-05 07:33:10 sachit attachment added logs.tar.gz https://bugs.launchpad.net/ubuntu/+source/ubiquity/+bug/1265192/+attachment/4067000/+files/logs.tar.gz
2014-04-05 16:35:56 Phillip Susi ubiquity (Ubuntu): status Incomplete Triaged
2014-04-05 16:36:23 Phillip Susi ubiquity (Ubuntu): milestone ubuntu-14.04
2014-04-05 17:10:58 Jean-Baptiste Lallement nominated for series Ubuntu Trusty
2014-04-05 17:10:58 Jean-Baptiste Lallement bug task added ubiquity (Ubuntu Trusty)
2014-04-05 18:09:24 Phillip Susi ubiquity (Ubuntu Trusty): status Triaged Incomplete
2014-04-05 23:17:47 Phillip Susi ubiquity (Ubuntu Trusty): status Incomplete Triaged
2014-04-22 10:18:32 Tomasz Kuczak attachment added installer.tar.gz https://bugs.launchpad.net/ubuntu/trusty/+source/ubiquity/+bug/1265192/+attachment/4092396/+files/installer.tar.gz
2014-05-04 13:37:53 bapoumba bug added subscriber bapoumba
2014-05-19 20:06:57 Nikita Kozubenko attachment added installer.tar.gz https://bugs.launchpad.net/ubuntu/+source/ubiquity/+bug/1265192/+attachment/4115658/+files/installer.tar.gz
2014-05-20 02:44:39 Erick Brunzell bug added subscriber Erick Brunzell
2014-05-20 03:16:47 Erick Brunzell attachment added Trusty_Lubuntu_install_options.png https://bugs.launchpad.net/ubuntu/+source/ubiquity/+bug/1265192/+attachment/4115836/+files/Trusty_Lubuntu_install_options.png
2014-05-26 11:25:55 Ubuntu QA Website tags iso-testing
2014-06-10 00:50:31 Chris Bainbridge bug added subscriber Chris Bainbridge
2014-06-27 10:17:52 Chris Bainbridge summary Reinstallation wipes out all/other partitions Install/reinstall wipes out all/other partitions
2014-07-14 15:43:28 Erick Brunzell bug added subscriber Ubuntu Release Team
2014-07-22 10:53:58 Tim Booth bug added subscriber Tim Booth
2014-07-23 07:50:14 machrider bug added subscriber machrider
2014-07-25 05:50:44 sudodus bug added subscriber sudodus
2014-07-30 13:17:43 Fane attachment added VM screenshots for installation at [Installation type] stage https://bugs.launchpad.net/ubuntu/+source/ubiquity/+bug/1265192/+attachment/4165778/+files/Wipeout.png
2014-08-13 05:21:44 Eliah Kagan bug added subscriber Eliah Kagan
2014-08-26 12:36:11 sachit bug task added ubuntu-livecd-image (Ubuntu)
2014-08-28 13:37:30 Launchpad Janitor ubuntu-livecd-image (Ubuntu): status New Confirmed
2014-08-28 13:37:30 Launchpad Janitor ubuntu-livecd-image (Ubuntu Trusty): status New Confirmed
2014-08-28 14:23:42 aboaboit bug added subscriber aboaboit
2014-08-28 14:24:54 Darkwarfighter bug added subscriber Darkwarfighter
2014-08-28 15:14:38 Arnaud Thevenet bug added subscriber Arnaud Thevenet
2014-08-28 16:02:41 Jan Groenewald bug added subscriber AIMS
2014-08-28 18:00:14 Takyoji bug added subscriber Caleb Langeslag
2014-08-28 18:26:05 Adam Niedling bug added subscriber Adam Niedling
2014-08-28 20:49:15 Marcos Alano bug added subscriber Marcos Alano
2014-08-29 07:45:35 Christian Niemeyer bug added subscriber Christian Niemeyer
2014-08-29 09:24:07 Sergey "Shnatsel" Davidoff bug task added ubiquity
2014-08-29 09:24:21 Sergey "Shnatsel" Davidoff bug task added elementaryos
2014-08-29 09:24:43 Sergey "Shnatsel" Davidoff bug task deleted ubiquity
2014-08-29 09:25:55 Sergey "Shnatsel" Davidoff elementaryos: milestone freya-beta2
2014-08-29 12:26:38 Olivier Febwin bug added subscriber Olivier Febwin
2014-08-29 16:06:22 Chris Bainbridge attachment added ubiquity-better-desc.patch https://bugs.launchpad.net/ubuntu/+source/ubiquity/+bug/1265192/+attachment/4190239/+files/ubiquity-better-desc.patch
2014-08-30 03:24:02 Anthony Wong bug added subscriber Anthony Wong
2014-09-01 19:38:24 Chris Bainbridge attachment added ubiquity-os-prober-windows-efi.patch https://bugs.launchpad.net/ubuntu/+source/ubiquity/+bug/1265192/+attachment/4192672/+files/ubiquity-os-prober-windows-efi.patch
2014-09-01 19:44:26 Chris Bainbridge tags iso-testing iso-testing patch
2014-09-12 17:31:12 Mantas Kriaučiūnas bug added subscriber Mantas Kriaučiūnas
2014-09-12 17:31:21 Mantas Kriaučiūnas bug added subscriber Baltix GNU/Linux system developers
2014-09-12 17:31:40 Mantas Kriaučiūnas bug added subscriber Baltix GNU/Linux activists
2014-09-12 17:32:07 Mantas Kriaučiūnas bug added subscriber Gintautas
2014-09-12 17:32:41 Mantas Kriaučiūnas bug added subscriber Paulius Brazaitis
2014-09-12 19:34:40 Launchpad Janitor ubiquity (Ubuntu): status Triaged Fix Released
2014-09-13 00:06:21 Ikuya Awashiro bug added subscriber Ikuya Awashiro
2014-09-13 21:52:57 Adolfo Jayme ubuntu-livecd-image (Ubuntu Trusty): importance Undecided Critical
2014-09-13 21:53:02 Adolfo Jayme ubuntu-livecd-image (Ubuntu): importance Undecided Critical
2014-09-15 09:05:49 Dimitri John Ledkov ubiquity (Ubuntu): assignee Dimitri John Ledkov (xnox)
2014-09-17 21:13:12 Daniel Fore elementaryos: status New Triaged
2014-09-17 21:13:19 Daniel Fore elementaryos: milestone freya-beta2 freya+1-beta1
2014-09-18 09:36:13 Bougron bug added subscriber Bougron
2014-09-20 16:52:10 sachit ubiquity (Ubuntu): assignee staticd (staticd-growthecommons)
2014-09-20 16:52:16 sachit ubiquity (Ubuntu): assignee staticd (staticd-growthecommons)
2014-09-26 12:12:31 sachit bug added subscriber Mark Shuttleworth
2014-09-30 20:59:56 Chris J Arges ubiquity (Ubuntu): status Fix Released Confirmed
2014-10-01 01:08:37 Steve Langasek ubiquity (Ubuntu): assignee Stéphane Graber (stgraber)
2014-10-01 02:02:20 Steve Langasek ubiquity (Ubuntu): assignee Stéphane Graber (stgraber) Colin Watson (cjwatson)
2014-10-12 12:03:35 Madhan bug added subscriber Madhan
2014-10-13 02:07:58 Erick Brunzell attachment added comp_delete.png https://bugs.launchpad.net/ubuntu/+source/ubiquity/+bug/1265192/+attachment/4233561/+files/comp_delete.png
2014-10-14 13:54:35 Colin Watson bug task deleted ubuntu-livecd-image (Ubuntu)
2014-10-14 13:54:41 Colin Watson bug task deleted ubuntu-livecd-image (Ubuntu Trusty)
2014-10-14 13:54:47 Colin Watson ubiquity (Ubuntu): status Confirmed In Progress
2014-10-14 13:54:53 Colin Watson ubiquity (Ubuntu): milestone ubuntu-14.04 ubuntu-14.10
2014-10-16 00:04:16 Launchpad Janitor branch linked lp:ubiquity
2014-10-16 13:49:34 Launchpad Janitor ubiquity (Ubuntu): status In Progress Fix Released
2014-10-29 12:28:46 Launchpad Janitor branch linked lp:~ubuntu-installer/ubiquity/trusty-proposed
2014-10-29 12:41:55 Colin Watson ubiquity (Ubuntu Trusty): milestone ubuntu-14.04 ubuntu-14.04.2
2014-10-29 12:41:58 Colin Watson ubiquity (Ubuntu Trusty): assignee Dimitri John Ledkov (xnox) Colin Watson (cjwatson)
2014-10-29 12:42:01 Colin Watson ubiquity (Ubuntu Trusty): status Triaged In Progress
2014-10-29 12:51:34 Colin Watson description Brand new Samsung laptop with UEFI. I had installed 13.04 Ubuntu but on reboot I never saw the 'grub' style menu. It just kept going into Windows 8.1. So I got the 13.10 version (64 bit) and choose "Reinstall Ubuntu" (That may not be the exact text) It removed all the partiions including the recovery partitions. I do have a backup for the windows install, but I was very surprised that this happened. On a positive note I now have Ububtu up and running on my machine. This is not my first time with Ubuntu. I have installed Ubuntu alongside WinXp, Vista and Windows 7. I've used Ubuntu desktop for over 6 years. If you would like me to try something to replicate this. .. I could shrink my existing partion make another one - reinstall and see if it whacks that one. I can do this now .. I'm still moving into this laptop so starting over is not so bad. Steve Devine [Impact] Serious data loss due to misleading UI in a variety of cases where the installer fails to accurately assess or describe the current partitioning layout. This set of proposed changes fix the problem both narrowly (by fixing a specific detection failure) and broadly (by being more consistent and conservative about how automatic partitioning methods are described, and by always displaying a confirmation dialog; "are you sure?" dialogs are generally dubious, but in this case it supplies more specific information which is a justifiable last resort for an operation as potentially destructive as partitioning). I have taken care to ensure that it has no impact on translations. [Test Case] Validating this ideally requires exploratory testing, but simple tests include setting up partitioning layouts that include deliberately-unrecognisable partitions and making sure that the installation process only removes those in response to options that explicitly state that they will erase the disk rather than merely erasing a single OS, and that a confirmation dialog is always displayed. [Regression Potential] This involves partitioning logic, so be careful. I've tried to keep the changes as isolated as possible to the automatic partitioning page, although the confirmation dialog change also affects the manual partitioner. It's worth checking that back/forward paths still work correctly, as this took me several goes to get right. Original report follows: Brand new Samsung laptop with UEFI. I had installed 13.04 Ubuntu but on reboot I never saw the 'grub' style menu. It just kept going into Windows 8.1. So I got the 13.10 version (64 bit) and choose "Reinstall Ubuntu" (That may not be the exact text) It removed all the partiions including the recovery partitions. I do have a backup for the windows install, but I was very surprised that this happened. On a positive note I now have Ububtu up and running on my machine. This is not my first time with Ubuntu. I have installed Ubuntu alongside WinXp, Vista and Windows 7. I've used Ubuntu desktop for over 6 years. If you would like me to try something to replicate this. .. I could shrink my existing partion make another one - reinstall and see if it whacks that one. I can do this now .. I'm still moving into this laptop so starting over is not so bad. Steve Devine
2014-10-30 19:28:01 Laurence Alban Frostenson elementaryos: status Triaged Fix Released
2014-10-30 20:30:02 Brian Murray ubiquity (Ubuntu Trusty): status In Progress Fix Committed
2014-10-30 20:30:07 Brian Murray bug added subscriber Ubuntu Stable Release Updates Team
2014-10-30 20:30:13 Brian Murray bug added subscriber SRU Verification
2014-10-30 20:30:37 Brian Murray tags iso-testing patch iso-testing patch verification-needed
2014-11-28 18:44:29 Mathew Hodson description [Impact] Serious data loss due to misleading UI in a variety of cases where the installer fails to accurately assess or describe the current partitioning layout. This set of proposed changes fix the problem both narrowly (by fixing a specific detection failure) and broadly (by being more consistent and conservative about how automatic partitioning methods are described, and by always displaying a confirmation dialog; "are you sure?" dialogs are generally dubious, but in this case it supplies more specific information which is a justifiable last resort for an operation as potentially destructive as partitioning). I have taken care to ensure that it has no impact on translations. [Test Case] Validating this ideally requires exploratory testing, but simple tests include setting up partitioning layouts that include deliberately-unrecognisable partitions and making sure that the installation process only removes those in response to options that explicitly state that they will erase the disk rather than merely erasing a single OS, and that a confirmation dialog is always displayed. [Regression Potential] This involves partitioning logic, so be careful. I've tried to keep the changes as isolated as possible to the automatic partitioning page, although the confirmation dialog change also affects the manual partitioner. It's worth checking that back/forward paths still work correctly, as this took me several goes to get right. Original report follows: Brand new Samsung laptop with UEFI. I had installed 13.04 Ubuntu but on reboot I never saw the 'grub' style menu. It just kept going into Windows 8.1. So I got the 13.10 version (64 bit) and choose "Reinstall Ubuntu" (That may not be the exact text) It removed all the partiions including the recovery partitions. I do have a backup for the windows install, but I was very surprised that this happened. On a positive note I now have Ububtu up and running on my machine. This is not my first time with Ubuntu. I have installed Ubuntu alongside WinXp, Vista and Windows 7. I've used Ubuntu desktop for over 6 years. If you would like me to try something to replicate this. .. I could shrink my existing partion make another one - reinstall and see if it whacks that one. I can do this now .. I'm still moving into this laptop so starting over is not so bad. Steve Devine [Impact] Serious data loss due to misleading UI in a variety of cases where the installer fails to accurately assess or describe the current partitioning layout. This set of proposed changes fix the problem both narrowly (by fixing a specific detection failure) and broadly (by being more consistent and conservative about how automatic partitioning methods are described, and by always displaying a confirmation dialog; "are you sure?" dialogs are generally dubious, but in this case it supplies more specific information which is a justifiable last resort for an operation as potentially destructive as partitioning). I have taken care to ensure that it has no impact on translations. [Test Case] Validating this ideally requires exploratory testing, but simple tests include setting up partitioning layouts that include deliberately-unrecognisable partitions and making sure that the installation process only removes those in response to options that explicitly state that they will erase the disk rather than merely erasing a single OS, and that a confirmation dialog is always displayed. [Regression Potential] This involves partitioning logic, so be careful. I've tried to keep the changes as isolated as possible to the automatic partitioning page, although the confirmation dialog change also affects the manual partitioner. It's worth checking that back/forward paths still work correctly, as this took me several goes to get right. Original report follows: Brand new Samsung laptop with UEFI. I had installed 13.04 Ubuntu but on reboot I never saw the 'grub' style menu. It just kept going into Windows 8.1. So I got the 13.10 version (64 bit) and choose "Reinstall Ubuntu" (That may not be the exact text) It removed all the partiions including the recovery partitions. I do have a backup for the windows install, but I was very surprised that this happened. On a positive note I now have Ububtu up and running on my machine. This is not my first time with Ubuntu. I have installed Ubuntu alongside WinXp, Vista and Windows 7. I've used Ubuntu desktop for over 6 years. If you would like me to try something to replicate this. .. I could shrink my existing partion make another one - reinstall and see if it whacks that one. I can do this now .. I'm still moving into this laptop so starting over is not so bad. Steve Devine
2014-12-05 10:51:29 Tuomas Kantonen bug added subscriber Tuomas Kantonen
2015-01-01 20:50:17 Bruno Nova tags iso-testing patch verification-needed iso-testing patch verification-done
2015-01-08 18:12:43 Launchpad Janitor ubiquity (Ubuntu Trusty): status Fix Committed Fix Released
2015-01-08 18:12:53 Brian Murray removed subscriber Ubuntu Stable Release Updates Team
2015-09-15 01:27:51 Cody Garver bug task deleted elementaryos
2015-12-15 17:44:05 SamWanPaul affects ubiquity (Ubuntu Trusty) clean-ubiquity (Ubuntu Trusty)
2015-12-15 18:03:33 Marcos Alano removed subscriber Marcos Alano
2015-12-15 20:48:55 Brian Murray affects clean-ubiquity (Ubuntu) ubiquity (Ubuntu)
2015-12-15 20:48:55 Brian Murray ubiquity (Ubuntu): milestone ubuntu-14.10
2016-01-23 11:26:17 Paul affects ubiquity (Ubuntu Trusty) clean-ubiquity-ubuntu (Ubuntu Trusty)
2016-01-23 12:12:18 Colin Watson affects clean-ubiquity-ubuntu (Ubuntu) ubiquity (Ubuntu)
2016-03-06 22:55:08 Roger bug task added ubiquity
2016-03-27 21:11:57 valentino ubiquity (Ubuntu): assignee Colin Watson (cjwatson) valentino (ciobanuvalentino6)
2016-03-27 22:22:23 Colin Watson ubiquity (Ubuntu): assignee valentino (ciobanuvalentino6) Colin Watson (cjwatson)
2016-03-29 09:36:28 Martin Pitt removed subscriber Ubuntu Release Team
2016-04-28 23:43:50 Mathew Hodson affects ubiquity ubuntu-translations
2016-04-28 23:44:04 Mathew Hodson bug task deleted ubuntu-translations