xkeyboard-config, console-setup, and ubiquity should use Super+Space for switching keyboard layouts

Bug #1242572 reported by Norbert on 2013-10-21
46
This bug affects 8 people
Affects Status Importance Assigned to Milestone
xkeyboard-config
Fix Released
Wishlist
console-setup (Ubuntu)
Wishlist
Mathieu Trudel-Lapierre
Trusty
Wishlist
Unassigned
ubiquity (Ubuntu)
Wishlist
Mathieu Trudel-Lapierre
Trusty
Wishlist
Unassigned
xkeyboard-config (Ubuntu)
Medium
Maarten Lankhorst
Trusty
Low
Maarten Lankhorst

Bug Description

Super+Space is default combination for switching keyboard layouts in gnome3, unity, Mac OS X, Windows. Thus for consistently, Xorg; console-setup; and ubiquity should also use Super+Space combination for switching keyboard layouts.

reading xkeyboard-config sources and documentations i don't see that xkeyboard-config can support grp:lwin_space and i guess that needs to be the first step to properly support super+space.

Original bug report below:

Recently I installed Ubuntu 13.10 and Ubuntu GNOME 13.10.
I use two keyboard layouts - English and Russian.
So I select them on the corresponding screen of ubiquity setup wizard.

It quietly set the keyboard switching shortcut to Alt+Shift and wrote this setting to /etc/default/keyboard:
# ...
XKBMODEL="pc105"
XKBLAYOUT="us,ru"
XKBVARIANT=","
XKBOPTIONS="grp:alt_shift_toggle,grp_led:scroll"
# ...

On first boot of installed system the small notification pop-up showed that Ibus will use Super+Space for layout switching.

Please fix this configuration inconsistency.

----------
For other layout switching problems introduced in Ubuntu 13.10 you can see bug 1218322.
----------

ProblemType: Bug
DistroRelease: Ubuntu 13.10
Package: ubiquity (not installed)
ProcVersionSignature: Ubuntu 3.11.0-12.19-generic 3.11.3
Uname: Linux 3.11.0-12-generic i686
ApportVersion: 2.12.5-0ubuntu2
Architecture: i386
Date: Mon Oct 21 12:16:58 2013
InstallCmdLine: file=/cdrom/preseed/ubuntu-gnome.seed boot=casper only-ubiquity initrd=/casper/initrd.lz quiet splash --
InstallationDate: Installed on 2013-10-21 (0 days ago)
InstallationMedia: Ubuntu-GNOME 13.10 "Saucy Salamander" - Release i386 (20131017)
MarkForUpload: True
SourcePackage: ubiquity
UpgradeStatus: No upgrade log present (probably fresh install)

Norbert (nrbrtx) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubiquity (Ubuntu):
status: New → Confirmed
Norbert (nrbrtx) on 2013-10-29
description: updated
Sebastien Bacher (seb128) wrote :

Confirmed, the default changed to super-space in gnome-settings-daemon 3.8 ... we might want to go back to use alt-shift by default though

Changed in ubiquity (Ubuntu):
importance: Undecided → High
Norbert (nrbrtx) on 2013-10-31
tags: added: keyboard-layout-switching-hotkeys
Norbert (nrbrtx) wrote :

Bug exists in Ubuntu 14.04.

tags: added: ubuntu-desktop-trusty
removed: ubiquity-2.15.26
Norbert (nrbrtx) wrote :

Bug exists in installation from trusty daily image (2014-03-16).

Norbert (nrbrtx) wrote :

Installed Ubuntu 14.04 final beta (4cf9e5ef2c1c362317c90312c76cfda0 *ubuntu-14.04-beta2-desktop-i386.iso) - bug is still here.
And ubiquity uses Alt+Shift quietly - there is no notes about which key is used to change layout.

Norbert (nrbrtx) wrote :

Made a clean install of Ubuntu 14.04 from final (!!) iso image.

unity-control-center keyboard indicates that Super+Space and Shift+Super+Space are used for layout switching,
/etc/default/keyboard contains:

XKBMODEL="pc105"
XKBLAYOUT="us,ru"
XKBVARIANT=","
XKBOPTIONS="grp:alt_shift_toggle,grp_led:scroll"

and Alt+Shift switches layouts in terminals (for example Ctrl+Alt+F1) but does not work in Xorg (for example in Unity session).

So the bug is still here. Please fix it on next install media. It may confuse Ubuntu newbies.

Changed in ubiquity (Ubuntu):
assignee: nobody → Dimitri John Ledkov (xnox)
Changed in ubiquity (Ubuntu Trusty):
assignee: nobody → Dimitri John Ledkov (xnox)
Dimitri John Ledkov (xnox) wrote :

Indeed we preseed alt_shift_toggel as the modifier to console-setup. It would be great to make console-setup default to super+space, or in console-setup terms "Logo Key + Space". But i don't see console-setup supporting "Logo Key + Space" combination at the moment (only logo key is supported, which just by itself would conflict with default unity shortcut).

I'll open a bug report against console-setup in debian.

Changed in console-setup (Ubuntu):
status: New → Confirmed
Changed in console-setup (Ubuntu Trusty):
status: New → Confirmed
Changed in console-setup (Ubuntu):
importance: Undecided → Wishlist
Changed in ubiquity (Ubuntu):
importance: High → Wishlist
Changed in console-setup (Ubuntu Trusty):
importance: Undecided → Wishlist
Changed in ubiquity (Ubuntu Trusty):
importance: High → Wishlist
Changed in xkeyboard-config (Ubuntu):
status: New → Confirmed
Changed in xkeyboard-config (Ubuntu Trusty):
status: New → Confirmed
Changed in xkeyboard-config (Ubuntu):
importance: Undecided → Wishlist
Changed in xkeyboard-config (Ubuntu Trusty):
importance: Undecided → Wishlist
summary: - Ubiquity sets Alt+Shift shortcut for layout switching, while installed
- system uses Super+Space
+ xkeyboard-config, console-setup, and ubiquity should use Super+Space for
+ switching keyboard layouts
description: updated
Changed in ubiquity (Ubuntu):
assignee: Dimitri John Ledkov (xnox) → nobody
Changed in ubiquity (Ubuntu Trusty):
assignee: Dimitri John Ledkov (xnox) → nobody
status: Confirmed → Incomplete
Changed in console-setup (Ubuntu Trusty):
status: Confirmed → Incomplete
Changed in xkeyboard-config (Ubuntu):
assignee: nobody → Maarten Lankhorst (mlankhorst)

Gnome3, Unity, Mac OS X and Windows default to using "Super+Space" (aka win+space,logo+space, etc) combination to switch keyboard layouts.

I've tried to get "Super+Space" key to work with xkeyboard-config and it doesn't appear to work. (Such that the key-combination to change layouts is consistent everywhere)

xkeyboard-config manpage only offers:
grp:alt_space_toggle Alt+Space
grp:lwin_toggle Left Win
grp:rwin_toggle Right Win

But ideally it is desired to also offer following options:
grp:lwin_space_toggle Left Win + Space
grp:rwin_space_toggle Right Win + Space

Bruteforcing / setting above by chance did not work =)

Can those two options be added?

Changed in xkeyboard-config (Ubuntu Trusty):
status: Confirmed → Incomplete
Changed in xkeyboard-config (Ubuntu):
assignee: Maarten Lankhorst (mlankhorst) → nobody
Dimitri John Ledkov (xnox) wrote :

Once upstream supports it, and xkeyboard-config supports it, we can modify console-setup and ubiquity to support Super+Space key combos.

Changed in xkeyboard-config:
importance: Unknown → Wishlist
status: Unknown → Confirmed
Dimitri John Ledkov (xnox) wrote :

Maarten Lankhorst, proposed the following sample patch. Can you please forward it upstream and/or upload into ubuntu? it appears to do what we need/want for at least some languages.

Changed in xkeyboard-config (Ubuntu):
assignee: nobody → Maarten Lankhorst (mlankhorst)
tags: added: patch

Created attachment 98299
add grp:win_space_toggle to allow meta keys to switch keyboard layout

I've attached my patch. But I have no clue about xkb-data, so I don't know if it's correct or not. Could this be reviewed?

Changed in xkeyboard-config (Ubuntu Trusty):
assignee: nobody → Dimitri John Ledkov (xnox)
milestone: none → ubuntu-14.04.2
Changed in ubiquity (Ubuntu Trusty):
milestone: none → ubuntu-14.04.2
Changed in xkeyboard-config (Ubuntu):
milestone: none → ubuntu-14.10
Changed in ubiquity (Ubuntu Trusty):
assignee: nobody → Dimitri John Ledkov (xnox)
Changed in console-setup (Ubuntu):
assignee: nobody → Dimitri John Ledkov (xnox)
no longer affects: ubiquity
Changed in ubiquity (Ubuntu):
assignee: nobody → Dimitri John Ledkov (xnox)

Dimitri, would you be able to confirm this patch is ok for you?

(In reply to comment #2)
> Dimitri, would you be able to confirm this patch is ok for you?

Yes, the proposed patch works great for my use cases.

fine, thanks, committed to git.

Dimitri John Ledkov (xnox) wrote :

Maarten, can you cherrypick

http://cgit.freedesktop.org/xkeyboard-config/patch/?id=40bc9e68840dd525047186ebb9277bedf9b892da

Into both trusty & unicorn? And i'll handle ubiquity/console-config cases.

Changed in xkeyboard-config (Ubuntu Trusty):
status: Incomplete → Confirmed
assignee: Dimitri John Ledkov (xnox) → Maarten Kumpen (maarten)
Changed in console-setup (Ubuntu Trusty):
assignee: nobody → Dimitri John Ledkov (xnox)
status: Incomplete → Confirmed
Changed in ubiquity (Ubuntu Trusty):
status: Incomplete → Confirmed
Changed in xkeyboard-config (Ubuntu):
importance: Wishlist → Medium
Changed in xkeyboard-config (Ubuntu Trusty):
importance: Wishlist → Low
Changed in ubiquity (Ubuntu):
milestone: none → ubuntu-14.04.2
milestone: ubuntu-14.04.2 → ubuntu-14.10
Changed in console-setup (Ubuntu Trusty):
milestone: none → ubuntu-14.04.2
Changed in console-setup (Ubuntu):
milestone: none → ubuntu-14.10
Changed in xkeyboard-config:
status: Confirmed → Fix Released

Created attachment 98456
Missing PC_SUPER_LEVEL2 definition.

It looks like the PC_SUPER_LEVEL2 definition is missing from the commit, I've attached it as diff.

right, thank you!

Norbert (nrbrtx) wrote :

Bug exists in Ubuntu 14.10 (installed from Ubuntu 14.10 _Utopic Unicorn_ - Alpha i386 (20140902)).

unity-control-center keyboard indicates that Super+Space and Shift+Super+Space are used for layout switching,
/etc/default/keyboard contains:

XKBMODEL="pc105"
XKBLAYOUT="us,ru"
XKBVARIANT=","
XKBOPTIONS="grp:alt_shift_toggle,grp_led:scroll"

and Alt+Shift switches layouts in terminals (for example Ctrl+Alt+F1) but does not work in Xorg (for example in Unity session).

So the bug is still here. Please fix it on next install media. It may confuse Ubuntu newbies. Please fix it before 14.10 final release.

tags: added: utopic
Norbert (nrbrtx) wrote :

It's great that Ubuntu 14.10 MATE beta is not affected by this bug.

Changed in xkeyboard-config (Ubuntu Trusty):
assignee: Maarten Kumpen (maarten) → Maarten Lankhorst (mlankhorst)
Maarten Lankhorst (mlankhorst) wrote :

xkb-data 2.12 is in utopic, so marking it as fix released

Changed in xkeyboard-config (Ubuntu):
status: Confirmed → Fix Released
Maarten Lankhorst (mlankhorst) wrote :

xkeyboard-config patch for trusty

Without the console-setup changes I cannot verify this works correctly, which is why I haven't uploaded it yet..

Changed in xkeyboard-config (Ubuntu Trusty):
status: Confirmed → In Progress
Norbert (nrbrtx) wrote :

Reinstalled Utopic from official beta2 , the bug is still here.
The /etc/default/keyboard looks the same as comment 19 (Unity uses Win+Space, console uses Alt+Shift).

Maarten Lankhorst (mlankhorst) wrote :

Console-setup still needs fixing for this to work.

Norbert (nrbrtx) wrote :

Bug exists in Ubuntu Utopic 14.10 final.

Mathew Hodson (mhodson) on 2015-01-14
tags: added: ubiquity-2.15.26
Mathew Hodson (mhodson) on 2015-01-14
tags: added: trusty
removed: ubuntu-desktop-trusty
Norbert (nrbrtx) wrote :

Bug exists in Ubuntu 15.04 alpha2.
The /etc/default/keyboard looks the same as comment 19 (Unity uses Win+Space, console uses Alt+Shift).
Please fix it.

tags: added: vivid
Norbert (nrbrtx) wrote :

Bug exists in Ubuntu 15.04 beta2.
The /etc/default/keyboard looks the same as comment 19 (Unity uses Win+Space, console uses Alt+Shift).
Please fix it.

Dimitri John Ledkov (xnox) wrote :

Please do not comment and continue to reproduce this bug. It has status open, therefore it is known that it is not fixed yet. A developer should upload a patch to fix & close this bug report in the remaining components that it is open against.

Norbert (nrbrtx) wrote :

Bug exists in Ubuntu 15.04 final.
The /etc/default/keyboard looks the same as comment 19 (Unity uses Win+Space, console uses Alt+Shift).
Please fix it.

Dimitri John Ledkov (xnox) wrote :

@Norbert nrbrtx -> please stop reproducing and commenting on this bug report. This is bug is not fixed, and has status confirmed, thus everyone knows that this was not fixed yet.

Mathew Hodson (mhodson) on 2015-08-21
Changed in console-setup (Ubuntu):
milestone: ubuntu-14.10 → none
Changed in ubiquity (Ubuntu):
milestone: ubuntu-14.10 → none
Changed in xkeyboard-config (Ubuntu):
milestone: ubuntu-14.10 → none
Changed in console-setup (Ubuntu Trusty):
milestone: ubuntu-14.04.2 → trusty-updates
Changed in ubiquity (Ubuntu Trusty):
milestone: ubuntu-14.04.2 → trusty-updates
Changed in xkeyboard-config (Ubuntu Trusty):
milestone: ubuntu-14.04.2 → trusty-updates
Norbert (nrbrtx) wrote :

I'm sorry, John, but bug exists in Ubuntu 15.10 final.

Norbert (nrbrtx) on 2015-10-24
tags: added: wily
Changed in console-setup (Ubuntu):
assignee: Dimitri John Ledkov (xnox) → Mathieu Trudel-Lapierre (mathieu-tl)
Changed in console-setup (Ubuntu Trusty):
assignee: Dimitri John Ledkov (xnox) → nobody
Changed in ubiquity (Ubuntu):
assignee: Dimitri John Ledkov (xnox) → Mathieu Trudel-Lapierre (mathieu-tl)
Changed in ubiquity (Ubuntu Trusty):
assignee: Dimitri John Ledkov (xnox) → nobody
Norbert (nrbrtx) on 2016-02-19
tags: added: xenial
Norbert (nrbrtx) on 2016-07-11
tags: added: yakkety
Norbert (nrbrtx) on 2017-10-07
tags: added: artful zesty
Norbert (nrbrtx) wrote :

Got this bug on installation of fresh Ubuntu 17.10. I selected Russian keyboard layout on installation. After installation I got both <Super+Space> and convenient <Alt+Shift> keyboard layout switchers.

Here is my /etc/default/keyboard :
# KEYBOARD CONFIGURATION FILE

# Consult the keyboard(5) manual page.

XKBMODEL="pc105"
XKBLAYOUT="us,ru"
XKBVARIANT=","
XKBOPTIONS="grp:alt_shift_toggle,grp_led:scroll"

BACKSPACE="guess"

I like <Alt+Shift> keyboard layout switcher, it is great.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.