Lubuntu 13.10 installation with full disk encryption fails

Bug #1241833 reported by Howard An
42
This bug affects 7 people
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
Expired
Undecided
Unassigned

Bug Description

Lubuntu 13.10 release version (not beta), 32bit iso
Dell Xps Gen2 with 2GB ram
Hard disk partition: GPT with biosgrub partition
Partition #1: 200MB, /boot
Partition #2: 7GB as phisical volume for luks encryption for root (/).
No swap partition, will use swap file after installation.

When selecting Partition #2 as phisical volume for encryption, a window popup saying unsecure swap partition is dected.
Then there is nothing happens. Can not go any further at this point.

Lubuntu 13.04 and 13.10 alpha version installs without problem.

William Grant (wgrant)
affects: launchpad → ubuntu
Revision history for this message
riprop (riprop) wrote :

I confirm this bug, installation in virutal box fails, and there is no way installing encrypted lubuntu , manually or automatically, always getting: "unsecure swap partition is dected."

Revision history for this message
John Kim (kotux) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. The issue that you reported is one that should be reproducible with the live environment of the Desktop ISO of the development release - Trusty Tahr. It would help us greatly if you could test with it so we can work on getting it fixed in the next release of Ubuntu. You can find out more about the development release at http://www.ubuntu.com/testing/ . Thanks again and we appreciate your help.

tags: added: derivatives
tags: added: saucy
Changed in ubuntu:
status: New → Confirmed
Revision history for this message
John Kim (kotux) wrote :
Revision history for this message
Nuno Sucena Almeida (slug-debian) wrote :

This still happens with lubuntu 14.04 beta 2

Revision history for this message
John Eure (johneure) wrote :

This still happens with the official 14.04 desktop image:
lubuntu-14.04-desktop-amd64.iso

It does not happen with the following images:
lubuntu-14.04-alternate-amd64.iso
ubuntu-14.04-desktop-amd64.iso
ubuntu-14.04-server-amd64.iso
xubuntu-14.04-desktop-amd64.iso

My workaround for my laptop was to just use the lubuntu alternate installer; it seems like the problem only exists in the lubuntu desktop installer, and not in any of the others that I tried.

And as riprop said above, this can also be perfectly reproduced in a new VM (I used VirtualBox on Windows 7). I created a new VM with the default options, booted from the image, selected "Install lubuntu", and chose the default for everything until I got to the full disk encryption option. I checked that box (and it automatically checked another), clicked "Continue", input a passphrase twice, and clicked "Install Now". The installation failed for lubuntu-14.04-desktop-amd64.iso, but the same basic steps worked for all the others.

The error message is: "An unsafe swap space has been detected." I've attached a screenshot from a VM repro.

Revision history for this message
John Eure (johneure) wrote :
Revision history for this message
John Eure (johneure) wrote :
Revision history for this message
John Eure (johneure) wrote :
Revision history for this message
Anton Gyllenberg (antong) wrote :

Also happens with lubuntu-14.04.1-desktop-amd64.iso

Revision history for this message
turtlepurple (turtle-purple) wrote :

This does STILL happen in lubuntu 14.04.2-desktop i386

Just read a workaorund here: http://askubuntu.com/questions/393418/unsafe-swap-space-detected/590479#590479
"Set up all your actual partitions, including your encrypted containers. I believe it necessary to include an encrypted partition for swap, so make sure to make one of suitable size for it.

Once you have them all set up, THEN, and only then pin them to actual mount points. I started with swap and then moved on to /home and so on."

Another workaround is using the alternate-cd (14.04.1 i386 in my case) but there you need to make sure to select the "Install" (in unetbootin-menu, are these available without unetbootin?) method - not the "expert install" and not "install lubuntu". It should have a kind of pink not a blue background (that is "install lubuntu" and will lead to another problem https://bugs.launchpad.net/ubuntu/+source/debian-installer/+bug/1417918 )
And when grub asks you to install to MBR say "No" because that is another bug(https://bugs.launchpad.net/ubuntu/+source/debian-installer/+bug/1426219) in alternate-CD and you will then be given the option to specify the correct device to install grub to.

Revision history for this message
Markus Waidele (markus-waidele) wrote :

Had the same problem installing in a VM. A "swapon -s" shows that there are two swap spaces created by zram (part of the RAM gets compressed and and used like swap space but with higher priority than "real" swap space).

For the installer it really seems that there is swap space enabled in the system so it does what it should in this case: Warn about that and cancel the installation. So no bug in my eyes.

With that information it's really easy to perform the installation anyway: Open a terminal and type "sudo /etc/init.d/zram-config stop". After that there are no swap spaces provided by zram anymore and the installer does it's job without complaining/aborting.

Mathew Hodson (mhodson)
affects: ubuntu → ubiquity (Ubuntu)
tags: added: lubuntu trusty
removed: derivatives disk encryption full installation
Revision history for this message
Marcus Tomlinson (marcustomlinson) wrote :

This release of Ubuntu is no longer receiving maintenance updates. If this is still an issue on a maintained version of Ubuntu please let us know.

Changed in ubiquity (Ubuntu):
status: Confirmed → Incomplete
Revision history for this message
Launchpad Janitor (janitor) wrote :

[Expired for ubiquity (Ubuntu) because there has been no activity for 60 days.]

Changed in ubiquity (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Duplicates of this bug

Other bug subscribers