Ubuntu one login during install hangs

Bug #1240683 reported by Paul Larson on 2013-10-16
104
This bug affects 23 people
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
High
Dimitri John Ledkov

Bug Description

During the install, I selected to login to my ubuntu one account and provided my userid/password.
I have seen this succeed many times, but this time it just hung at a screen with the spinner, and the buttons for back/continue/login later were no longer usable after hitting continue. They were gray at first, then when I switched windows and came back they were clickable but didn't do anything.
When I switched to a terminal and ran top, I noticed that ubiquity was using 90% cpu.

I reran with -d enabled to get better logs.

The image I'm using right now is saucy desktop amd64 20131016.1

ProblemType: Bug
DistroRelease: Ubuntu 13.10
Package: ubiquity 2.15.26
ProcVersionSignature: Ubuntu 3.11.0-12.19-generic 3.11.3
Uname: Linux 3.11.0-12-generic x86_64
ApportVersion: 2.12.5-0ubuntu2
Architecture: amd64
CasperVersion: 1.336ubuntu1
Date: Wed Oct 16 15:01:45 2013
InstallCmdLine: file=/cdrom/preseed/ubuntu.seed boot=casper initrd=/casper/initrd.lz quiet splash -- maybe-ubiquity
LiveMediaBuild: Ubuntu 13.10 "Saucy Salamander" - Release amd64 (20131016.1)
MarkForUpload: True
SourcePackage: ubiquity
UpgradeStatus: No upgrade log present (probably fresh install)

Paul Larson (pwlars) wrote :
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1240683

tags: added: iso-testing
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubiquity (Ubuntu):
status: New → Confirmed
Brian Murray (brian-murray) wrote :

I wonder if this is the error:

Oct 16 20:00:20 ubuntu /ubuntuone-keyring-helper: failed to create keyring 'login': <enum GNOME_KEYRING_RESULT_KEYRING_ALREADY_EXISTS of type PyGnomeKeyringResult>
Oct 16 20:00:20 ubuntu ubiquity[16866]: Error creating keyring, u1 token not saved.

Paul Larson (pwlars) wrote :

that could be a side effect of me running through it more than once on the same boot because it's not always reproducible and I wanted to get it with -d enabled on ubiquity

Brian Murray (brian-murray) wrote :

I was able to recreate this and found the following in my log:

ubuntu /ubuntuone-keyring-helper: Success, create item 'Ubuntu One @ ubuntu-virtual-machine' in kerying 'login'
ubuntu ubiquity[5352]: debconffilter_done: ubi-ubuntuone (current: ubi-ubuntuone)
...

Dimitri John Ledkov (xnox) wrote :

GNOME_KEYRING_RESULT_KEYRING_ALREADY_EXISTS suggests that the /target system to install, has /target/$user already has a login keyring. If the installer got stuck that means the error state is not handled correctly.

Changed in ubiquity (Ubuntu):
assignee: nobody → Dmitrijs Ledkovs (xnox)
importance: Undecided → High
tags: added: u1
Marcus (marcusad79) wrote :

I just tried to install 13.10 & I ran into the same problem.
After I put in my email/pw and hit 'Continue' the install just hanged. When I hit continue again, the large dots stopped moving but the cursor kept spinning. If I clicked 'Back' nothing happened. If I clicked 'Log in Later' the cursor turned back into an arrow, but nothing else changed. Clicking 'Back' or 'Continue' changed the cursor back to a spin.

Peter Würtz (pwuertz) wrote :

Just ran into this error when trying to install 13.10. Is the installer frozen now? Do I have to kill and restart it?

Is it possible to install Ubuntu at all under these circumstances? Does the "Log in later" button work before one attempts to log in?

Peter Würtz (pwuertz) wrote :

I don't know if this is related, but I also had to deactivate the update-during-installation option because the installer did freeze on that as well. Internet connection works flawlessly however.

Mike Butash (michael-butash) wrote :

Has anyone noticed that simply put, for all intents and purposes broken with this bug? I've wasted a good part of a day just trying to figure out a workaround for this issue, only to find there seems to be no workaround for it. This is absurd, and exactly why I've always avoided the desktop installations, aside from the fact they don't have mdadm, lvm, or cryptsetup prior. Still doesn't have mdraid, and now this broken install just tells me why I need to find a new distribution.

Does no one do actual Q/A on your releases? I'd expect this in an alpha release, not an actual release.

Fr-coord (fr-coor) wrote :

Mike Butash, for now the workaround is simple, install without loging in to Ubuntu One, just select to do it later.

BTW this issue is also present in Trusty.

Jelte (tjebbe) wrote :

Except that it also hangs when you click "log in later"

edly (edzycamote) wrote :

first time ubuntu user here, can't pass this error during installation so haven't tried ubuntu yet until this installation flaw is resolved :-(

Diogenes (thomas-arbs) wrote :

#metoo On cleanly installing Ubuntu 13.10 from a DVD beside Windows XP, it repeatably hangs on the Ubuntu One Login screen, regardless which option I pick. Strange thing is I have installed it a couple times on other computers already from an USB stick without issues, only this computer won't boot from USB. So it really is a showstopper for this particular computer; I see no way past it.

Albert (albert337) wrote :

Found the fix..... I was also getting these hangups at install even though I used the same USB on another laptop and it worked fine. I wastes many hours trying to work around it until I read another post regarding partitions and the possibility of Ubuntu freezing. So I decided to not connect to Internet, log in later, do not install updates during, do not install 3rd party software, and use the partition software it mentions during install.... Bam installed Ubuntu within minutes, no freezing and no issues.

Confirmed that this happens when you have no internet connection (installing on a VirtualBox VM on a host stuck behind a proxy).

* Get to "Ubuntu One" stage
* Lack of connection detected correctly
* Continue greyed out
* Click "Login Later" - nothing happens
* No disk or network activity (for some reason the USB activity lamp on the VM flashes a lot at this point even though there are no USB devices connected)

Also confirmed that workaround described in #16 seems to work - if you use the manual partitioning wizard, create and format an ext4 partition for /, clicking "Login later" works - the continue button is ungreyed but you don't have to click it because the installer then continues.

Brandon Giesing (dotmaniac39) wrote :

On Trusty, you can workaround this by using the install option on the live CD instead of try Ubuntu.

Changed in ubiquity (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers