oem config user remains the default user after full oem installation

Bug #1231166 reported by Para Siva on 2013-09-25
34
This bug affects 6 people
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
High
Dimitri John Ledkov
Saucy
High
Dimitri John Ledkov

Bug Description

The temporary oem config user remains the defalt user even after the full installation of saucy desktop images. Not sure if keeping the temp user settings is a bug but I think making it the default user is not right.

Steps: (test case: http://iso.qa.ubuntu.com/qatracker/testcases/1305/info)
1. Perform an oem installation
2. Carry out the user setup step as part of the oem installation
3. Reboot
4. The default user is still the temp oem user

ProblemType: Bug
DistroRelease: Ubuntu 13.10
Package: ubiquity (not installed)
ProcVersionSignature: Ubuntu 3.11.0-8.15-generic 3.11.1
Uname: Linux 3.11.0-8-generic i686
ApportVersion: 2.12.4-0ubuntu1
Architecture: i386
Date: Wed Sep 25 23:06:10 2013
InstallCmdLine: file=/cdrom/preseed/ubuntu.seed boot=casper only-ubiquity initrd=/casper/initrd.lz quiet splash -- apt-setup/restricted=false apt-setup/multiverse=false oem-config/enable=true
InstallationDate: Installed on 2013-09-25 (0 days ago)
InstallationMedia: Ubuntu 13.10 "Saucy Salamander" - Beta i386 (20130925.1)
MarkForUpload: True
SourcePackage: ubiquity
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

lp:~xnox/ubiquity/fix-oem-user
Colin Watson: Approve on 2013-10-14
Para Siva (psivaa) wrote :
Para Siva (psivaa) on 2013-09-25
summary: - oem config user remains default user after full oem installation
+ oem config user remains the default user after full oem installation
description: updated
Paul Larson (pwlars) on 2013-09-25
Changed in ubiquity (Ubuntu):
status: New → Confirmed
Brian Murray (brian-murray) wrote :

I recreated this bug using an image from 20131001. The OEM user still exists and you are automatically logged in as that user.

Changed in ubiquity (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → High
tags: removed: rls-s-incoming
Jason Gerard DeRose (jderose) wrote :

Not sure if anyone is working on this, but I'm doing my best to track this down as this bug means System76 can't start shipping Saucy the day we want to... the day it's released =D

I have zero experience with the Ubiquity code base, but from what I've dug through so far, my hunch is this regression was introduced in commit 6003, although I don't yet understand why it broke.

Jason Gerard DeRose (jderose) wrote :

Attached a tarball of /var/log after running the user config (after clicking "Prepare for shipping to user", rebooting).

Jason Gerard DeRose (jderose) wrote :

Another tarball of /var/log. This time I modified oem-config-wrapper so it will fail if `userdel --force --remove oem` fails, and I booted with debug-oem-config.

Changed in ubiquity (Ubuntu Saucy):
status: Triaged → Fix Committed
assignee: nobody → Dmitrijs Ledkovs (xnox)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 2.15.23

---------------
ubiquity (2.15.23) saucy; urgency=low

  * Attempt to remove oem user again in the oem-config/post-start, after
    oem-config-first-boot setup has been completed. (LP: #1231166)
  * Load U1 Terms & Conditions page lazily when asked, instead of at U1
    plugin import time. Thus the page will only be loaded once there is a
    working internet connection and the user is signing up for U1. This
    also resolves ubiquity failing to load when booting direct live user
    session. (LP: #1226912)
  * Instead of skipping u1 plugin when offline, display "No internet
    connectivity" page and show the login later button. Thus avoiding
    hanging when installing fully offline, and explaining why U1 login was
    not available. (LP: #1237694)
  * Run debconf-updatepo to actually update templates.pot and make all the
    U1 page strings translatable. (LP: #1235192)
 -- Dmitrijs Ledkovs <email address hidden> Fri, 11 Oct 2013 15:37:31 +0100

Changed in ubiquity (Ubuntu Saucy):
status: Fix Committed → Fix Released
Jason Gerard DeRose (jderose) wrote :

Problem I just found with the oem-config fix... because that upstart job always runs, the "oem" user gets deleted the first time you install 2.15.23, first time you boot after doing an OEM mode install.

This fix shows the approach that's needed, but it currently creates other deal-breaking problems. I'll keep digging.

Changed in ubiquity (Ubuntu Saucy):
status: Fix Released → Confirmed
Richard Foulkes (rbsfou) wrote :

Any details of the fix guys? Is the bug number kept in a comment (to a commit) to a repo?

I too am having the same problem, where the 'oem' user is deleted on the first boot!

I guess it's not been built yet, as http://packages.ubuntu.com/saucy/admin/oem-config still shows 2.15.23

This is a really scary one to have open so close to release date - without understanding the build schedules or anything is it likely to be in tomorrow's daily build (15/10/13) ?

Only two and a bit days remaining, no pressure ;)

Richard Foulkes (rbsfou) wrote :

Confusion over the repos - http://bazaar.launchpad.net/~ubuntu-core-dev/oem-config/trunk/files is not the repo for oem-config anymore!

xnox - Did you commit your fix to here? I can see your changes to become version 2.15.23 - yet that was on the 11th, not 14th (if it was 5 hours ago when you last commented) - and as jderose confirms the oem user is still deleted on the first boot.

http://bazaar.launchpad.net/~ubuntu-installer/ubiquity/trunk/changes

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 2.15.24

---------------
ubiquity (2.15.24) saucy; urgency=low

  [ Colin Watson ]
  * Move oem user removal from upstart & wrapper into
    oem-config-firstboot, after ubiquity-dm finished executing. (LP:
    #1231166) (LP: #1239471)

  [ Dmitrijs Ledkovs ]
  * Kill any remaining oem user process before removing oem user (session
    dbus leaves zombies). (LP: #1231166)
 -- Dmitrijs Ledkovs <email address hidden> Mon, 14 Oct 2013 18:19:27 +0100

Changed in ubiquity (Ubuntu Saucy):
status: Confirmed → Fix Released
Richard Foulkes (rbsfou) wrote :

Thanks folks - with any luck once i manually add the oem user back in, it won't get deleted. Inside a chroot 2.15.24 has just been apt-get'd :)

I apologise if i made any basic errors or assumptions about the way ubuntu is built - and also what localtime releases.ubuntu.com (daily build) ;)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers