Ubiquity not finding existing Linux installation(s)

Bug #1220187 reported by Lars Noodén on 2013-09-03
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
Undecided
Unassigned

Bug Description

Ubiquity cannot find a recent, fresh installation of Lubuntu using the PowerPC Desktop / Live CD image.

The exact message is "This computer currently has no detected operating systems" The install dialog shows the option to erase the disk or to do 'something else' but does not find the system I had just installed. What should happen is that Ubiquity should find the installed system and offer to resize or install along side the existing system.

ProblemType: Bug
DistroRelease: Ubuntu 13.10
Package: ubiquity 2.15.16 [modified: lib/partman/automatically_partition/question]
ProcVersionSignature: Ubuntu 3.11.0-1.2-powerpc-smp 3.11.0-rc7
Uname: Linux 3.11.0-1-powerpc-smp ppc
ApportVersion: 2.12.1-0ubuntu3
Architecture: powerpc
CasperVersion: 1.336
Date: Tue Sep 3 11:01:42 2013
InstallCmdLine: ro ramdisk_size=1048576 file=/cdrom/preseed/lubuntu.seed boot=casper quiet splash -- video=radeonfb:1280x854-32@60
LiveMediaBuild: Lubuntu 13.10 "Saucy Salamander" - Alpha powerpc (20130902.1)
MarkForUpload: True
SourcePackage: ubiquity
UpgradeStatus: No upgrade log present (probably fresh install)

Revision history for this message
Lars Noodén (larsnooden) wrote :
Revision history for this message
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1220187

tags: added: iso-testing
description: updated
description: updated
Revision history for this message
Brian Murray (brian-murray) wrote :

This is suspicious:

Sep 3 10:50:42 lubuntu kernel: [ 384.303158] XFS (sda1): bad magic number
Sep 3 10:50:42 lubuntu kernel: [ 384.303174] de413000: 50 4d 00 00 00 00 00 05 00 00 00 01 00 00 00 3f PM.............?
Sep 3 10:50:42 lubuntu kernel: [ 384.303182] de413010: 41 70 70 6c 65 00 00 00 00 00 00 00 00 00 00 00 Apple...........
Sep 3 10:50:42 lubuntu kernel: [ 384.303188] de413020: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 ................
Sep 3 10:50:42 lubuntu kernel: [ 384.303195] de413030: 41 70 70 6c 65 5f 70 61 72 74 69 74 69 6f 6e 5f Apple_partition_
Sep 3 10:50:42 lubuntu kernel: [ 384.303204] XFS (sda1): Internal error xfs_sb_read_verify at line 780 of file /build/buildd/linux-ppc-3.11.0/fs/xfs/xfs_mount.c. Caller 0xf3ed9cdc
Sep 3 10:50:42 lubuntu kernel: [ 384.303204]
Sep 3 10:50:42 lubuntu kernel: [ 384.303217] CPU: 0 PID: 5 Comm: kworker/0:0H Tainted: GF C 3.11.0-1-powerpc-smp #2-Ubuntu
Sep 3 10:50:42 lubuntu kernel: [ 384.303404] Workqueue: xfslogd xfs_buf_iodone_work [xfs]
Sep 3 10:50:42 lubuntu kernel: [ 384.303412] Call Trace:
Sep 3 10:50:42 lubuntu kernel: [ 384.303430] [ef87fdc0] [c00098f8] show_stack+0xf8/0x1b0 (unreliable)
Sep 3 10:50:42 lubuntu kernel: [ 384.303444] [ef87fe10] [c06dfa0c] dump_stack+0x78/0xa0
Sep 3 10:50:42 lubuntu kernel: [ 384.303506] [ef87fe20] [f3edc970] xfs_corruption_error+0x78/0x98 [xfs]
Sep 3 10:50:42 lubuntu kernel: [ 384.303593] [ef87fe50] [f3f3c378] xfs_sb_read_verify+0x10c/0x12c [xfs]
Sep 3 10:50:42 lubuntu kernel: [ 384.303649] [ef87fe80] [f3ed9cdc] xfs_buf_iodone_work+0xb4/0xd8 [xfs]
Sep 3 10:50:42 lubuntu kernel: [ 384.303665] [ef87fe90] [c005c2e0] process_one_work+0x158/0x3c8
Sep 3 10:50:42 lubuntu kernel: [ 384.303674] [ef87fec0] [c005cc5c] worker_thread+0x134/0x3fc
Sep 3 10:50:42 lubuntu kernel: [ 384.303686] [ef87fef0] [c0064160] kthread+0xb4/0xb8
Sep 3 10:50:42 lubuntu kernel: [ 384.303696] [ef87ff40] [c0017140] ret_from_kernel_thread+0x5c/0x64
Sep 3 10:50:42 lubuntu kernel: [ 384.303702] XFS (sda1): Corruption detected. Unmount and run xfs_repair
Sep 3 10:50:42 lubuntu kernel: [ 384.303729] XFS (sda1): SB validate failed with error 22.
Sep 3 10:50:42 lubuntu ubiquity: mount: you must specify the filesystem type
Sep 3 10:50:42 lubuntu ubiquity:
Sep 3 10:50:42 lubuntu ubiquity: mount: wrong fs type, bad option, bad superblock on /dev/sda3,
Sep 3 10:50:42 lubuntu ubiquity: missing codepage or helper program, or other error
Sep 3 10:50:42 lubuntu ubiquity:
Sep 3 10:50:42 lubuntu ubiquity: In some cases useful info is found in syslog - try
Sep 3 10:50:42 lubuntu ubiquity: dmesg | tail or so
Sep 3 10:50:42 lubuntu ubiquity:

Do you have a log file from the install of the other operating system? Were there any errors?

Changed in ubiquity (Ubuntu):
status: New → Incomplete
Revision history for this message
Lars Noodén (larsnooden) wrote :

I didn't keep any logs from the installation of the other system because it went without a hitch. It was the same system, Lubuntu 13.10b, and from the same CD, just with the use-entire-disk option. The installer was not finding Lubuntu.

Revision history for this message
Phill Whiteside (phillw) wrote :

I'm just wondering if this another manifestation of bug 1220165 I saw that one on my alternate 64-bit, but as I was on 3rd re-slicing of a 10 GB partition I thought nothing of it and just re-installed the VM from scratch.

Revision history for this message
Launchpad Janitor (janitor) wrote :

[Expired for ubiquity (Ubuntu) because there has been no activity for 60 days.]

Changed in ubiquity (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers