Comment 13 for bug 1205397

Joe (joec4204) wrote :

Yes, I ran into this problem again when attempting a install of 14.10 using my (encrypted) 14.04 partitions. Very frustrating since it takes 5+ minutes per iteration after you quit and try something different. The problem seems worse -- I tried at least 5 or 6 different variations before finally being able to complete the install. Even though I would run "sudo swapoff --all" (from the terminal, from a virtual console), I'd still get the error. I tried deleting my existing partitions and creating new partitions.

The problem seems worse (or perhaps it's an additional problem) -- there were several times that I was trying the approach from comment #11 and not setting mount points until the end, but then the problem was that after I created one physical volume for encryption, the installer would hang when I created the second. (One partition for swap, one for /, in addition to the unencrypted /boot partition).

In the end, the solution I came up with was to create a partition for swap but not to use it at all. (I.e., an install with no swap). Now that the install completed, I'll go back and set up that partition to be swap after the fact. This will probably be better anyway -- I'll be able to set it up so that it uses a random key for swap encryption so I only need to type one passphrase to boot. (Which is fine since I never do a hibernate anyway.)