ubiquity needs to be updated for the new indicators

Bug #1204290 reported by Tim on 2013-07-23
84
This bug affects 13 people
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
High
Lars Karlitski

Bug Description

This occured while testing ubuntu GNOME alpha2 candidate image

Occured just after logging into Live Session

ProblemType: Crash
DistroRelease: Ubuntu 13.10
Package: ubiquity-frontend-gtk 2.15.11 [modified: usr/share/applications/ubiquity-gtkui.desktop]
ProcVersionSignature: Ubuntu 3.10.0-4.13-generic 3.10.1
Uname: Linux 3.10.0-4-generic x86_64
ApportVersion: 2.11-0ubuntu1
Architecture: amd64
CasperVersion: 1.335
Date: Tue Jul 23 23:09:50 2013
ExecutablePath: /usr/lib/ubiquity/panel
InstallCmdLine: file=/cdrom/preseed/ubuntu-gnome.seed boot=casper initrd=/casper/initrd.lz quiet splash -- maybe-ubiquity
LiveMediaBuild: Ubuntu-GNOME 13.10 "Saucy Salamander" - Alpha amd64 (20130723.1)
MarkForUpload: True
ProcCmdline: /usr/lib/ubiquity/panel
ProcEnviron:
 TERM=linux
 PATH=(custom, no user)
 LANG=en_US.UTF-8
SegvAnalysis:
 Segfault happened at: 0x7f9cf655ce49 <indicator_object_get_entries+41>: mov 0x18(%rax),%rax
 PC (0x7f9cf655ce49) ok
 source "0x18(%rax)" (0x00000018) not located in a known VMA region (needed readable region)!
 destination "%rax" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: ubiquity
StacktraceTop:
 indicator_object_get_entries () from /usr/lib/x86_64-linux-gnu/libindicator3.so.7
 ?? ()
 __libc_start_main () from /lib/x86_64-linux-gnu/libc.so.6
 ?? ()
Title: panel crashed with SIGSEGV in indicator_object_get_entries()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo

Related branches

lp:~larsu/ubiquity/fix-indicators
Ubuntu Installer Team: Pending requested 2013-07-29
Tim (darkxst) wrote :

Thank you for taking the time to report this crash and helping to make this software better. This particular crash has already been reported and is a duplicate of bug #1161058, so is being marked as such. Please look at the other bug report to see if there is any missing information that you can provide, or to see if there is a workaround for the bug. Additionally, any further discussion regarding the bug should occur in the other report. Please continue to report any other bugs you may find.

information type: Private → Public
tags: removed: need-amd64-retrace

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1204290

tags: added: iso-testing
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubiquity (Ubuntu):
status: New → Confirmed
Tim (darkxst) wrote :

my guess is this is crashing trying to load the session indicator which we don't ship on the image.

(panel:2434): libindicator-WARNING **: File '/usr/lib/indicators3/7/libsession.so' does not exist.

(panel:2434): GLib-GObject-WARNING **: invalid (NULL) pointer instance

(panel:2434): GLib-GObject-CRITICAL **: g_signal_connect_data: assertion 'G_TYPE_CHECK_INSTANCE (instance)' failed

(panel:2434): GLib-GObject-WARNING **: invalid (NULL) pointer instance

(panel:2434): GLib-GObject-CRITICAL **: g_signal_connect_data: assertion 'G_TYPE_CHECK_INSTANCE (instance)' failed

(panel:2434): libindicator-CRITICAL **: get_all_entries: assertion 'INDICATOR_IS_OBJECT(io)' failed

Sebastien Bacher (seb128) wrote :

The issue is that the ubiquity code tries to load .so files that don't exist in saucy anymore, the code needs to be ported to support indicator-ng, Lars said he's going to do that (basically adding an installer profile to the indicators and make ubiquity load those)

summary: - panel crashed with SIGSEGV in indicator_object_get_entries()
+ ubiquity needs to be updated for the new indicators
Changed in ubiquity (Ubuntu):
assignee: nobody → Lars Uebernickel (larsu)
importance: Undecided → High
Lars Karlitski (larsu) on 2013-07-30
Changed in ubiquity (Ubuntu):
status: Confirmed → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 2.15.12

---------------
ubiquity (2.15.12) saucy; urgency=low

  [ Rohan Garg ]
  * [KDE] Fix language drop down list closes on first click (LP:
    #1187762)

  [ Aurélien Gâteau ]
  * [KDE] Fix max width to 1000px on content and refactor widget stack to simplify

  [ Lars Uebernickel ]
  * Port ubiquity panel to new indicators (LP: #1204290)

  [ Dmitrijs Ledkovs ]
  * Automatic update of included source packages: debian-installer-utils
    1.98ubuntu1, partman-base 167ubuntu1.
 -- Dmitrijs Ledkovs <email address hidden> Tue, 30 Jul 2013 12:00:21 +0100

Changed in ubiquity (Ubuntu):
status: In Progress → Fix Released

sorry to inform you that yesterday when triedn to install ubuntu 13.10 it displayed as fatal error for boot. I regret to inform you that WinXP crashed completely - resulting I have to reinstall from scratch - howeve unable to connect with internet also As such I am using live CD for the purpose of internet. anyway I am trying to install ubuntu 13.10(daily build) and to see what will happen next - whether winxp will again crashed or not.

Tim (darkxst) wrote :

sriranga, please file another bug for your issue, it sounds like a completely different issue than these broken indicators!

I dont know how to file another issue as desired by you. I am not
programmer nor developer Moreover WinXP had crashed and restored but
unable to connect with the internet,

On Wed, Jul 31, 2013 at 2:27 PM, Tim <email address hidden> wrote:

> sriranga, please file another bug for your issue, it sounds like a
> completely different issue than these broken indicators!
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (1204174).
> https://bugs.launchpad.net/bugs/1204290
>
> Title:
> ubiquity needs to be updated for the new indicators
>
> Status in “ubiquity” package in Ubuntu:
> Fix Released
>
> Bug description:
> This occured while testing ubuntu GNOME alpha2 candidate image
>
> Occured just after logging into Live Session
>
> ProblemType: Crash
> DistroRelease: Ubuntu 13.10
> Package: ubiquity-frontend-gtk 2.15.11 [modified:
> usr/share/applications/ubiquity-gtkui.desktop]
> ProcVersionSignature: Ubuntu 3.10.0-4.13-generic 3.10.1
> Uname: Linux 3.10.0-4-generic x86_64
> ApportVersion: 2.11-0ubuntu1
> Architecture: amd64
> CasperVersion: 1.335
> Date: Tue Jul 23 23:09:50 2013
> ExecutablePath: /usr/lib/ubiquity/panel
> InstallCmdLine: file=/cdrom/preseed/ubuntu-gnome.seed boot=casper
> initrd=/casper/initrd.lz quiet splash -- maybe-ubiquity
> LiveMediaBuild: Ubuntu-GNOME 13.10 "Saucy Salamander" - Alpha amd64
> (20130723.1)
> MarkForUpload: True
> ProcCmdline: /usr/lib/ubiquity/panel
> ProcEnviron:
> TERM=linux
> PATH=(custom, no user)
> LANG=en_US.UTF-8
> SegvAnalysis:
> Segfault happened at: 0x7f9cf655ce49 <indicator_object_get_entries+41>:
> mov 0x18(%rax),%rax
> PC (0x7f9cf655ce49) ok
> source "0x18(%rax)" (0x00000018) not located in a known VMA region
> (needed readable region)!
> destination "%rax" ok
> SegvReason: reading NULL VMA
> Signal: 11
> SourcePackage: ubiquity
> StacktraceTop:
> indicator_object_get_entries () from
> /usr/lib/x86_64-linux-gnu/libindicator3.so.7
> ?? ()
> __libc_start_main () from /lib/x86_64-linux-gnu/libc.so.6
> ?? ()
> Title: panel crashed with SIGSEGV in indicator_object_get_entries()
> UpgradeStatus: No upgrade log present (probably fresh install)
> UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu/+source/ubiquity/+bug/1204290/+subscriptions
>

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers