[Tribe1] Manual partitioning gives inconsistent units

Bug #120123 reported by Bryce Harrington on 2007-06-13
4
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
Undecided
Unassigned

Bug Description

Tribe 1 Desktop CD install.

I used the manual install option and kept the existing partitions, but reformatted them.

In one part of the GUI it uses "megabytes", and in another "MB" for the same partition, but with different numbers.
While this is probably just a units difference, it would be clearer to users if the same units could be used consistently throughout.

Colin Watson (cjwatson) wrote :

We can certainly make it say MB throughout. Where exactly were the places displaying different numbers, and what were the numbers?

Changed in ubiquity:
assignee: nobody → kamion
status: Unconfirmed → Needs Info
Bryce Harrington (bryce) wrote :

Here's some photos to show it. Hopefully the quality is good enough.

I noticed on this first screen the measure is in GB's, so include it for completeness. I don't think this screen should be changed; GB's make sense here.

Bryce Harrington (bryce) wrote :

This shows where partition size is shown in "megabytes" rather than "MB".

Bryce Harrington (bryce) wrote :

Here's where the bug shows up.

I've selected the second partition, which is 6218MB with 0MB used (a swap partition), and clicked Edit.

Notice that in the new partition size, it's offered to make it 244776, which is the size of the other partition. There is no other space on the drive, so this value is invalid. It should say 6218 MB.

Bryce Harrington (bryce) wrote :

Anyway, so the issue I was seeing was not a units difference, but rather an incorrect value in a widget when editing the partitions. It often displays correctly. I was not able to get it to occur for the first partition on the drive, nor with newly created partitions.

Bryce Harrington (bryce) on 2009-01-06
Changed in ubiquity:
status: Incomplete → New
mathew (meta23) wrote :

It's not just a MB vs megabytes issue.

I set up Kubuntu 9.04 at the weekend. I was setting up a 15GB root partition, some swap, and the rest of my disk for /home.

At the top of the window, it showed the /home partition size as 139.7GB.
Below that in the list of partitions, it showed it as 149987MB.

When I went to create a partition, it asked me for the size in MB, and said 1MB = 1000000 bytes.

So there are several problems here:

1. I'm guessing that the top of the window shows partition sizes in GiB, but labels them as GB, because of the fact that its number is smaller than the one in the actual partition list.

2. The figure shown in the partition list is incompatible with the figure shown at the top. 149987MB isn't 139.7GiB. Nor is 149987MiB. I can't find any way to reconcile the two values.

3. The dialog for creating a partition asks for a third unit, different from both the other two places.

Since hard disks are measured in GB--that is, base 10, not base 2--that's the obvious useful unit for the end user. I know that my hard disk is 160GB. I have no idea how big it is in base-2 units, and the average person is going to have a hard time calculating it.

So, the ideal fix should be pretty simple: the main window ought to be changed to show GB/MB everywhere, like it claims it's already doing, and then all the UI stuff can be left the same.

Dave Martin (dave-martin-arm) wrote :

There's another perspective here: occasionally I want to specify exact partition sizes. In this case, the user may want an exact number of MiB or sectors, but usually not any exact number of MB.

I don't expect ubiquity necessarily to provide this flexibility, but it would make sense if the user could choose the units to be used, and the chosen unit system applied consistently across the whole GUI.

For myself though, I'm happy to use a traditional partitioner on those occasions where I care about the exact results.

Roy Jamison (xteejx) wrote :

Most regular users wouldn't want or need to select such an exact amount. I totally agree though that there should be an option for this, perhaps an "Advanced Partitioning" button so the regular users aren't confused with the GB/GiB/sectors selections.

Regarding the bug, could it simply be that one window is showing one set of units and another window using another set of units, i.e. MB vs MiB?

Is this occurring in Karmic? I have a stable production system so I wouldn't like to mess with partitions.

Thank you :)

Changed in ubiquity (Ubuntu):
status: New → Incomplete
Charlie Kravetz (charlie-tca) wrote :

According to the recently issued policy on units, this should no longer be an issue. https://wiki.ubuntu.com/UnitsPolicy describes what units are used when/where.

Changed in ubiquity (Ubuntu):
assignee: Colin Watson (cjwatson) → nobody
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers