Clicking "Install Xubuntu 13.10" in live session doesn't work.

Bug #1193526 reported by Scott Moore
42
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Xfce4 Panel
Unknown
Unknown
ubiquity (Ubuntu)
Undecided
Dimitri John Ledkov

Bug Description

In the live session, clicking the desktop launcher "Install Xubuntu 13.10" doesn't do anything. I also tried right-clicking and selecting "execute" but still, nothing happened. I rebooted and tried again. The problem still exists.

The hardware profile for this machine can be viewed at wiki.ubuntu.com/scottbomb/IBM_T60. The live session is n on a USB thumbdrive via Unetbootin.

ProblemType: Bug
DistroRelease: Ubuntu 13.10
Package: ubiquity 2.15.7
ProcVersionSignature: Ubuntu 3.9.0-6.14-generic 3.9.6
Uname: Linux 3.9.0-6-generic i686
ApportVersion: 2.10.2-0ubuntu2
Architecture: i386
CasperVersion: 1.333
Date: Fri Jun 21 20:27:48 2013
InstallCmdLine: initrd=/casper/initrd.lz file=/cdrom/preseed/xubuntu.seed boot=casper quiet splash -- BOOT_IMAGE=/casper/vmlinuz
LiveMediaBuild: Xubuntu 13.10 "Saucy Salamander" - Alpha i386 (20130621)
MarkForUpload: True
SourcePackage: ubiquity
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Revision history for this message
Scott Moore (scottbomb) wrote :
Revision history for this message
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1193526

tags: added: iso-testing
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubiquity (Ubuntu):
status: New → Confirmed
Revision history for this message
Elfy (elfy) wrote :

Tried this on two machines.

Same issue.

Using the install xubuntu rather than try xubuntu option - boots to first install screen - no further progression.

Revision history for this message
Jackson Doak (noskcaj) wrote :

This only affects me using the launcher icon on the desktop. both the standalone and running from the command line work fine.

This is in Vbox via testdrive

Revision history for this message
Jackson Doak (noskcaj) wrote :

same results on lubuntu

Revision history for this message
Elfy (elfy) wrote :

@Jackson

the command works for me as well - however the bug is about running the install from the desktop launcher.

Does that work for you?

Revision history for this message
sudodus (nio-wiklund) wrote :

This is the Exec command now (in the desktop file) and it does not work
Exec=ubiquity gtk_ui

It worked a few days ago when it was
Exec=ubiquity --desktop %k gtk_ui

Are there other changes too?

Revision history for this message
sudodus (nio-wiklund) wrote :

I tested Lubuntu i386 (in a real computer)

I think the desktop file is 'dead' because

ubiquity gtk_ui

works from a terminal window (... so yes, there are other changes too)

Revision history for this message
Dimitri John Ledkov (xnox) wrote :

I have switched to policykit priviledge escalation, thus:
pkexec ubiquity gtk_ui

should work. Will test recent lubuntu/xubuntu images.

Changed in ubiquity (Ubuntu):
assignee: nobody → Dmitrijs Ledkovs (xnox)
Revision history for this message
ibere fernandes (ibere-fernandes) wrote :
Revision history for this message
Elfy (elfy) wrote :

Still failing as of latest image

Revision history for this message
Jackson Doak (noskcaj) wrote :

@elfy
It doesn't work running from the launcher.

Has this been confirmed in K, U, G or Kylin?

Revision history for this message
Dimitri John Ledkov (xnox) wrote :

This is related to bugs around pkexec checking parent, which under some DE can be gone already.
See:
https://bugzilla.redhat.com/show_bug.cgi?id=879922
https://bugzilla.xfce.org/show_bug.cgi?id=9626#c2

One workaround is to add:
StartupNotify=true

which makes Xubuntu work, but can fail other Desktop Environments.

Another workaround is to wrap, ubiquity-wrapper, in a shell script. As e.g. synaptic did.

Changed in ubiquity (Ubuntu):
status: Confirmed → In Progress
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 2.15.8

---------------
ubiquity (2.15.8) saucy; urgency=low

  [ Colin Watson ]
  * Fix "parition" typo in template names.

  [ Dmitrijs Ledkovs ]
  * Wrap ubiquity call in sh, due to broken desktop-file/pkexec
    interaction on XFCE and LXDE (LP: #1193526)
 -- Dmitrijs Ledkovs <email address hidden> Tue, 25 Jun 2013 13:11:30 +0100

Changed in ubiquity (Ubuntu):
status: In Progress → Fix Released
Revision history for this message
Elfy (elfy) wrote :

reappeared in today's utopic daily

anthony (tunkki420)
information type: Public → Private
information type: Private → Public
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.