Ubiquity Locale Problem

Bug #1184729 reported by Volkan Gezer
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
Confirmed
Undecided
Unassigned

Bug Description

Today I installed Kubuntu 13.04 on a friend's computer and used
Turkish locale. During installation process, I noticed that the
default Keyboard Layout remains in English whatever the language
selection is. Also after installation completed, I noticed that the
calendar, currency etc. settings are also wrong (they were in German
style since I picked German timezone during installation).

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubiquity (Ubuntu):
status: New → Confirmed
Revision history for this message
Ovidiu-Florin BOGDAN (ovidiu-florin) wrote :

The same is for Romanian. IMO if a language is selected for the installer, all settings should default to the specific country for that language, if it's available.

Revision history for this message
Harald Sitter (apachelogger) wrote :

Currency and friends do not map to languages but countries. Mapping to the time zone is the closest match available. So that is in fact by design.

Revision history for this message
Ovidiu-Florin BOGDAN (ovidiu-florin) wrote :

What do you mean by "So that is in fact by design." ?

If you mean that the locale and default keyboard layout are selected accordingly to the Time Zone, then that is not true. It does not happen.

Revision history for this message
Volkan Gezer (volkangezer) wrote :

+1 for Ovidiu. I picked Turkey from the list, but the Keyboard setting was EN_GB and timezone with calendar settings were German.

Revision history for this message
Alexander Vinbæk Strand (alexstrand7-o) wrote :

Same here, when I enter my name, I can't use the Norwegian letters Æ,Ø,Å, because keyboard is still on English.. and the bug is still there in Ubuntu 19.10, and I see this bug is reported for 13.04, and this happens only for me if I choose install Ubuntu instead of try Ubuntu before install and then launch installer from live desktop, when I try Ubuntu and then install everything works.

Revision history for this message
Alexander Vinbæk Strand (alexstrand7-o) wrote :

After install everything works for me, so it is only when installing Ubuntu that keyboard is not the language I selected (Norwegian Bokmål)

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers