Comment 0 for bug 1180880

Tobin Davis (gruemaster) wrote :

After installing Ubuntu Server 12.04 (and 12.04.2) AMD64 edition, then running oem-config-prepare after post-install updates and rebooting, the system hangs during reboot. Adding debug-oem-config doesn't produce any new information. Recovery only possible by booting in rescue mode from the installation cd (or bootable USB) then removing /var/lib/oem-config/run and rebooting.

apport-retrace reports the following from the crash report:

root@atp-spare1:/home/lab/bogl-0.1.18# apport-retrace -g /var/crash/_usr_bin_bterm.0.crash
GNU gdb (Ubuntu/Linaro 7.4-2012.04-0ubuntu2.1) 7.4-2012.04
Copyright (C) 2012 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law. Type "show copying"
and "show warranty" for details.
This GDB was configured as "x86_64-linux-gnu".
For bug reporting instructions, please see:
<http://bugs.launchpad.net/gdb-linaro/>.
Reading symbols from /usr/bin/bterm...Reading symbols from /usr/lib/debug/usr/bin/bterm...done.
done.
[New LWP 1489]
warning: Can't read pathname for load map: Input/output error.
Core was generated by `bterm -f /usr/share/ubiquity/unifont.bgf -- /usr/sbin/oem-config --only'.
Program terminated with signal 7, Bus error.
#0 0x0000000000404349 in bogl_font_glyph (font=0x1e10f20, wc=32 L' ', bitmap=0x0) at bogl.c:351
351 for (i = font->offset[wc & mask]; font->index[i]; i += 2)
(gdb) bt
#0 0x0000000000404349 in bogl_font_glyph (font=0x1e10f20, wc=32 L' ', bitmap=0x0) at bogl.c:351
#1 0x0000000000402891 in bogl_term_new (font=0x1e10f20) at bogl-term.c:41
#2 0x0000000000401c9c in main (argc=6, argv=0x7fff536402e8) at bterm.c:312

The attached crash does NOT have private data, so no need to keep this bug private.