Crash when starting oem-config on Ubuntu Server 12.04 amd64.

Bug #1180880 reported by Tobin Davis on 2013-05-16
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
High
Colin Watson
Precise
High
Colin Watson
Saucy
High
Colin Watson

Bug Description

[Impact] Breaks OEM-mode server installations on at least some non-i386 architectures.
[Test Case] Install an amd64 server image in OEM mode (F4 at the boot menu). After installation, make sure that ubiquity* and oem-config* are up to date from -proposed, run oem-config-prepare, and reboot. oem-config should appear on the console after reboot.
[Regression Potential] Given the size of the change, I think the only plausible source of regression is the sort that should affect any rebuild of ubiquity. Nothing much other than this uses the debconf frontend.

Original report follows:

After installing Ubuntu Server 12.04 (and 12.04.2) AMD64 edition, then running oem-config-prepare after post-install updates and rebooting, the system hangs during reboot. Adding debug-oem-config doesn't produce any new information. Recovery only possible by booting in rescue mode from the installation cd (or bootable USB) then removing /var/lib/oem-config/run and rebooting.

apport-retrace reports the following from the crash report:

root@atp-spare1:/home/lab/bogl-0.1.18# apport-retrace -g /var/crash/_usr_bin_bterm.0.crash
GNU gdb (Ubuntu/Linaro 7.4-2012.04-0ubuntu2.1) 7.4-2012.04
Copyright (C) 2012 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law. Type "show copying"
and "show warranty" for details.
This GDB was configured as "x86_64-linux-gnu".
For bug reporting instructions, please see:
<http://bugs.launchpad.net/gdb-linaro/>.
Reading symbols from /usr/bin/bterm...Reading symbols from /usr/lib/debug/usr/bin/bterm...done.
done.
[New LWP 1489]
warning: Can't read pathname for load map: Input/output error.
Core was generated by `bterm -f /usr/share/ubiquity/unifont.bgf -- /usr/sbin/oem-config --only'.
Program terminated with signal 7, Bus error.
#0 0x0000000000404349 in bogl_font_glyph (font=0x1e10f20, wc=32 L' ', bitmap=0x0) at bogl.c:351
351 for (i = font->offset[wc & mask]; font->index[i]; i += 2)
(gdb) bt
#0 0x0000000000404349 in bogl_font_glyph (font=0x1e10f20, wc=32 L' ', bitmap=0x0) at bogl.c:351
#1 0x0000000000402891 in bogl_term_new (font=0x1e10f20) at bogl-term.c:41
#2 0x0000000000401c9c in main (argc=6, argv=0x7fff536402e8) at bterm.c:312

The attached crash does NOT have private data, so no need to keep this bug private.

Tobin Davis (gruemaster) wrote :
Tobin Davis (gruemaster) wrote :

Installed system that generated this crash is behind a corporate firewall, making it impossible to use ubuntu-bug to file. But it is fully reproducible on a vm or physical hardware.

Colin Watson (cjwatson) wrote :

I was indeed able to reproduce this in a precise VM. I haven't yet tried a more recent release, although the relevant part of bogl hasn't changed.

Changed in bogl (Ubuntu):
status: New → Triaged
importance: Undecided → High
assignee: nobody → Colin Watson (cjwatson)
Colin Watson (cjwatson) wrote :

This turns out to be a ubiquity bug after all. The .bgf font format used by bterm is architecture-dependent - for example, it depends on the architecture's pointer size - but we were putting unifont.bgf in an architecture-independent package so it was always the i386 version. The fix is just a matter of making ubiquity-frontend-debconf be Architecture: any rather than all. I'm test-building that now, and it should be a straightforward SRU candidate.

affects: bogl (Ubuntu) → ubiquity (Ubuntu)
Changed in ubiquity (Ubuntu):
status: Triaged → In Progress
Colin Watson (cjwatson) on 2013-05-17
Changed in ubiquity (Ubuntu Precise):
status: New → In Progress
importance: Undecided → High
assignee: nobody → Colin Watson (cjwatson)
milestone: none → ubuntu-12.04.3
Colin Watson (cjwatson) on 2013-05-17
description: updated
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 2.15.4

---------------
ubiquity (2.15.4) saucy; urgency=low

  * Make ubiquity-frontend-debconf Architecture: any rather than all; the
    .bgf font format is architecture-dependent (LP: #1180880).
  * Automatic update of included source packages: flash-kernel
    3.0~rc.4ubuntu34.
 -- Colin Watson <email address hidden> Fri, 17 May 2013 14:52:57 +0100

Changed in ubiquity (Ubuntu Saucy):
status: In Progress → Fix Released
Tobin Davis (gruemaster) wrote :

I can confirm that this fixes Precise. I have tested it on both an amd64 VM (kvm) and raw hardware.

Thanks Colin.

Hello Tobin, or anyone else affected,

Accepted ubiquity into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/ubiquity/2.10.25 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in ubiquity (Ubuntu Precise):
status: In Progress → Fix Committed
tags: added: verification-needed
Tobin Davis (gruemaster) wrote :

Tested on 12.04.2 amd64. Works correctly now. Don't have any other archs available to test at the moment.

tags: added: verification-done
removed: verification-needed

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 2.10.25

---------------
ubiquity (2.10.25) precise; urgency=low

  [ Colin Watson ]
  * KDE frontend:
    - Set default QString encoding to UTF-8 (LP: #1057485).
  * Make ubiquity-frontend-debconf Architecture: any rather than all; the
    .bgf font format is architecture-dependent (LP: #1180880).
  * Automatic update of included source packages: partman-basicfilesystems
    71ubuntu3.1, partman-efi 25ubuntu1.1.

  [ Ma Jun (Kylin Team) ]
  * Fix referencing variable before assignment (LP: #945027)

  [ Stéphane Graber ]
  * Fix crash in ubi-console-setup when quickly moving back and forth between
    pages. (LP: #944614)
 -- Colin Watson <email address hidden> Fri, 17 May 2013 15:08:59 +0100

Changed in ubiquity (Ubuntu Precise):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers