Ubiquity input progress indicator is wrong for Edubuntu installation

Bug #1172626 reported by Jonathan Carter on 2013-04-25
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
Undecided
Unassigned

Bug Description

Edubuntu ads some additional steps to the Ubiquity installer.

The correct number of steps are displayed, but the indication of total progress as shown at the bottom of the installer doesn't always match the actuall installation step progress.

Dimitri John Ledkov (xnox) wrote :

For example, the wifi connection is an optional page and if there is already network connectivity it will be "skipped" and the the dot will be filled.
E.g. in ubuntu image switching from prepare -> partitioning colors two dots. One for the skipped wifi and the other for the now current "partitioning" page.

Good way to test is to do a few rounds of going back and forwards. And the same amount of dots should change colors per transitioning going back and forward.

It's a dot per plugin, such that partitioning (ask, resize, crypto input, manual) all get collectively one dot, although it can be up-to 3 screens (in the case of encrypted install with choosing hard drive).

Does edubuntu experience match the above descriptions? Or is there still inconsistency between above and what actually happens to the edubuntu installer.

Changed in ubiquity (Ubuntu):
status: New → Incomplete
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers