Install doesn't mount encrypted swap for reinstall

Bug #1172002 reported by Paul Larson on 2013-04-23
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Release Notes for Ubuntu
Undecided
Pete Graner
ubiquity (Ubuntu)
High
Unassigned
Raring
Undecided
Unassigned
Saucy
High
Unassigned

Bug Description

Image: Raring release candidate 20130423.1
Summary: I installed once, and selected the option to encrypt my home directory.
Next, I rebooted and selected the option to reinstall, preserving my home directory.

The installer popped up a box telling me that I had not selected any swap partition. It looks like installing with ecryptfs now uses encrypted swap, but I was never given an option to mount that encrypted swapspace on reinstall.

Release Note:
When using installer to upgrade or reinstall an existing installation with encrypted swap, the installer may fail to reuse it. A warning will be shown, but installation can be completed. The installed system will not have swap activated and users are advised to recreate swap on their systems. Please see advice about adding and activating swap at: https://help.ubuntu.com/community/SwapFaq

Paul Larson (pwlars) wrote :
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1172002

tags: added: iso-testing
Nicholas Skaggs (nskaggs) wrote :

I believe this suffers from the same issue as doing an encrypted installation and then attempting to re-install. That is ubiquity doesn't know what the encrypted partition is and simply lists it as unknown. Therefore it doesn't use it or prompt about it

Changed in ubiquity (Ubuntu):
status: New → Confirmed
Changed in ubiquity (Ubuntu):
importance: Undecided → High
Dimitri John Ledkov (xnox) wrote :

By default, we reuse existing swap partitions. Since home directory was encrypted originally, the swap was as well. Thus at reinstall we should use encrypted swap. One option is to detect that previous install is encrypted and force encrypted swap. Partman logs do not indicate any swap detected nor mounted, which is concerning. This potentially ties in with the other dm-crypt bug 1066480, where any dm-crypt partitions are activated.

description: updated
description: updated
Andy Whitcroft (apw) on 2013-04-25
Changed in ubuntu-release-notes:
status: New → Fix Released
assignee: nobody → Pete Graner (pgraner)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubiquity (Ubuntu Raring):
status: New → Confirmed
tags: removed: ubuntu
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers