[FFe] Ubuntu One sign in or up or skip plugin

Bug #1153731 reported by Dimitri John Ledkov on 2013-03-11
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
High
Unassigned
Raring
High
Unassigned
Saucy
Undecided
Unassigned

Bug Description

I'm requesting FFe to add Ubuntu One sing in, up or skip, plugin to ubiquity.
It does not add any additional dependencies, instead it allows to sign in or up for Ubuntu One directly from the installer.
On the technical side of things it, it authenticates and retrieves a token which is stored in the newly created user account's keyring.

It adds extra pages, visual assets and translatable strings to the installer.

The code is almost complete in lp:~xnox/ubiquity/main_u1 but is pending an U1 deployment and a few fix ups before merging.
Overall, I am confident in landing this right after beta1 block is lifted.

Further testing will be required once it lands on the images.

Related branches

Changed in ubiquity (Ubuntu Raring):
status: New → Triaged
status: Triaged → New
importance: Undecided → High

The delays were caused by combination of:
- scheduling U1 SSO downtime for server API upgrades (it was postponed twice, due to uptime requirements for events)
- finalising & deploying legal notices, that need to be available if somebody is registering a new account
- delayed final visual design and assets
- vUDS preperation and delivery, interrupting the work of people involved in all of the above

I'd like to merge it, with a feature flag, disabled by default. Get the images with it, extensively test against one.ubuntu.com, and then propose to switch the default on. Thus to minimise any potential disruptions in any of the configurations.

But I would like an FFe pre-approval first, before getting the images.

Once it's possible to test with real images, the FFe can be finally decided w.r.t. enabling this feature by default in ubiquity-gtk.
As it is hard to asses the full impact of this feature without daily images readily available for testing and evaluation.

At the moment there is only code for ubiquity-gtk, normal installation (no oem config).

Scott Kitterman (kitterman) wrote :

Complex to test things like this really should be in before Feature Freeze. I thought we were pretty clear about being limited in the exceptions we would grant this time.

Stefano Rivera (stefanor) wrote :

Presumably a lot of that technical work could have happened before FF. The only blocker there was the server side.

The testing plan sounds fairly reasonable. But I'm still not particularly keen on accepting this.
Does Ubuntu One always have to change installation / sign-up after FF?

summary: - [FFe] Ubuntu One sing in or up or skip plugin
+ [FFe] Ubuntu One sign in or up or skip plugin
Iain Lane (laney) wrote :

Let's leave it. Given that you admit that this needs more testing and therefore probably further iterations, I think it would be better to land this early in S-cycle. Or right now, in a PPA, enabled by default, with testing instructions (admittedly given that this is ubiquity that's slightly awkward but still possible). We'll then be able to have a really solid feature for the first images of whatever kind we end up producing.

Changed in ubiquity (Ubuntu Raring):
status: New → Won't Fix
Changed in ubiquity (Ubuntu Saucy):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers