No help or documentation available for Ubuntu installer

Bug #114521 reported by Robb Topolski on 2007-05-13
26
This bug affects 2 people
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
Wishlist
Unassigned
ubuntu-docs (Ubuntu)
Wishlist
Unassigned

Bug Description

Binary package hint: ubiquity

In a conversation found at "http://www.dslreports.com/forum/remark,18327525" -- a critic of Ubuntu points out that there is no documentation or help that explains the Installer. Install simply appears on the desktop, along with another icon called Examples (which does not seem to provide any). Searching the online help system also found no help or information on what to expect when installing Ubuntu.

Tags: doc Edit Tag help
Colin Watson (cjwatson) on 2007-06-15
Changed in ubiquity:
importance: Undecided → Wishlist
status: Unconfirmed → Confirmed
Dylan McCall (dylanmccall) wrote :

There should also be a Help button on the bottom left in Ubiquity, for quick access to the documentation. This would really help to reduce the number of users who are confused during the partitioning step, for example.

Similar older brainstorm idea -- http://brainstorm.ubuntu.com/idea/9352/

Matthew East (mdke) wrote :

I think this would be a good task for the documentation team during the 9.10 development cycle

Changed in ubuntu-docs (Ubuntu):
importance: Undecided → Wishlist
status: New → Confirmed
tags: added: documentors
Phil Bull (philbull) wrote :
Vikram Dhillon (dhillon-v10) wrote :

Agreed, we will have to pull information from various sources that describes the installer and its workings, I am actually working on a little guide that I was going to talk about on the mailing list and post on my blog about Ubiquity but now it seems to be going somewhere more useful :) So I'll follow the SPEC that Phil wrote and write a guide that covers all those aspects and anything else that seems really important

I do have a question though: some of the common questions that Phil covered can be linked out to other guides that already exist , so do you guys want to link out those questions to other documents or rewrite those in this guide.

Thanks for giving me a chance to help :)

Changed in ubuntu-docs (Ubuntu):
assignee: nobody → Vikram (dhillon-v10)
Changed in ubuntu-docs (Ubuntu):
status: Confirmed → In Progress
Vikram Dhillon (dhillon-v10) wrote :

A friendly ping on this one, AFAIK from the last meeting, I believe I am not the only one working on these docs. so can anyone give me an update of how much work is done, and what's left

Changed in ubuntu-docs (Ubuntu):
assignee: Vikram Dhillon (dhillon-v10) → nobody
David Vasta (david-vasta) wrote :

I would like to help if there is room on this bug. I am new and think I could clean up any documentation you have out there now. Can someone help me get started?

On Thu, Apr 01, 2010 at 02:50:36AM -0000, David Vasta wrote:
> I would like to help if there is room on this bug. I am new and think I
> could clean up any documentation you have out there now. Can someone
> help me get started?
>
> Status in “ubiquity” package in Ubuntu: Confirmed
> Status in “ubuntu-docs” package in Ubuntu: In Progress
>
> Bug description:
> Binary package hint: ubiquity
>
> In a conversation found at "http://www.dslreports.com/forum/remark,18327525" -- a critic of Ubuntu points out that there is no documentation or help that explains the Installer. Install simply appears on the desktop, along with another icon called Examples (which does not seem to provide any). Searching the online help system also found no help or information on what to expect when installing Ubuntu.
>
>

@David: You should send an email to the mailing list [1] (under the contact section), that's the best place to get you started :)

[1] https://wiki.ubuntu.com/DocumentationTeam

--
Regards,
Vikram Dhillon

There is poetry and there is beauty in real sympathy; but there is more — there is action. The noblest and most powerful form of sympathy is not merely the responsive tear, the echoed sigh, the answering look; it is the embodiment of the sentiment in actual help.

Sanket Totewar (sunk8) wrote :

The Ubuntu Manual gives an overview...
It's available for download here:
https://wiki.ubuntu.com/ubuntu-manual

David W (dcw) on 2010-09-07
Changed in ubiquity (Ubuntu):
status: Confirmed → Fix Committed
Connor Imes (ckimes) on 2010-09-12
Changed in ubuntu-docs (Ubuntu):
status: In Progress → New
Geoffrey Kuhn (kuhn-geoff) wrote :

Agreed, while the installation guide is easy to access on the support tab on the homepage, a non-computer savvy person may have trouble reading the actual guide itself even if it appears simple to most. The Ubuntu Manual Project will provide a simple -one-stop source for ALL information for a typical user.

Vikram Dhillon (dhillon-v10) wrote :

Given that Ubuntu Manual Project produced a great manual for the issues mentioned in this bug, I will go ahead and close it.

Changed in ubuntu-docs (Ubuntu):
status: New → Invalid
Jeremy Bicha (jbicha) wrote :

In that case, there should at least be a link from the System Help to either the Installation Guide (which is more for sysadmins doing the alternate install) or the Ubuntu manual. I'm reopening this bug since although the installer is quite good about explaining itself as it goes, there still should be some way for users to get more help and explanation for the install choices.

Changed in ubuntu-docs (Ubuntu):
status: Invalid → New
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu-docs (Ubuntu):
status: New → Confirmed
Changed in ubiquity (Ubuntu):
status: Fix Committed → Triaged
bab188d (bkhosi) wrote :

2012/7/9, Brian Murray <email address hidden>:
> ** Changed in: ubiquity (Ubuntu)
> Status: Fix Committed => Triaged
>
> --
> You received this bug notification because you are subscribed to ubuntu-
> docs in Ubuntu.
> https://bugs.launchpad.net/bugs/114521
>
> Title:
> No help or documentation available for Ubuntu installer
>
> Status in “ubiquity” package in Ubuntu:
> Triaged
> Status in “ubuntu-docs” package in Ubuntu:
> Confirmed
>
> Bug description:
> Binary package hint: ubiquity
>
> In a conversation found at
> "http://www.dslreports.com/forum/remark,18327525" -- a critic of
> Ubuntu points out that there is no documentation or help that explains
> the Installer. Install simply appears on the desktop, along with
> another icon called Examples (which does not seem to provide any).
> Searching the online help system also found no help or information on
> what to expect when installing Ubuntu.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu/+source/ubiquity/+bug/114521/+subscriptions
>

John Kim (kotux) on 2013-06-09
tags: added: doc
removed: documentors
Chris Perry (clissold345) wrote :

@Gunnar. Can I do this bug? I was planning a short description of the main different ways of installing desktop Ubuntu - I think there are many different ways (eg the alternative downloads) so I wasn't planning to try to mention all of them - with links to detailed documentation (where such documentation exists). As an example link the recommended system requirements for the latest desktop LTS are here:

https://www.ubuntu.com/download/desktop

I think the links will have to be to Canonical-maintained pages or up-to-date wiki pages.

I wasn't planning to cover the details of installation at all (choose keyboard layout, enter username, etc, etc). I'll leave that stuff to the linked documents or the installer itself, which is now pretty good.

Does the above sound OK? If not I suggest we discuss alternatives via email and then when we've decided what to do I can update this bug.

Gunnar Hjalmarsson (gunnarhj) wrote :

@Chris: It's fine to use the bug report for discussion.

This topic is a can of worms and, to be honest, my personal view is that a short description wouldn't add much value. I often point people to the page you mentioned, which covers the basics.

Areas which could be better documented (somewhere), and where people often encounter difficulties, is problems due to UEFI/secure boot when installing alongside Windows and problems with graphics drivers for certain hardware. There are many, many questions on those things at e.g. Ask Ubuntu. But a useful and up to date documentation of it would require expert input, and I feel that such documentation should be written and maintained by Canonical rather than those who maintain the desktop guide. It should be noted that installation matters isn't an Ubuntu desktop specific topic. It's basically the same for the server and the flavors.

And, of course, there is a comprehensive (but rather technical) installation guide already:

https://help.ubuntu.com/lts/installation-guide/

This bug report is 10 years old, and I have a feeling that the available guidance is far better today compared to when the bug was filed. I tend to think that the status of the ubuntu-docs task ought to be "Won't Fix". Awaiting your response before changing it, though.

Chris Perry (clissold345) wrote :

Hi Gunnar, below I give my (revised) idea of a "short description". It's basically links to www.ubuntu.com but www.ubuntu.com doesnt organise the info in this way (why not?).

[ Start of page ]

The process is typically this:

Check the recommended system requirements:

https://www.ubuntu.com/download/desktop

Download the ISO.

Burn a DVD:

https://www.ubuntu.com/download/desktop/burn-a-dvd-on-ubuntu

or create a bootable USB stick:

https://www.ubuntu.com/download/desktop/create-a-usb-stick-on-ubuntu

Check your computer is compatible with Ubuntu:

https://www.ubuntu.com/download/desktop/try-ubuntu-before-you-install

Back up your data.

Install Ubuntu:

https://www.ubuntu.com/download/desktop/install-ubuntu-desktop

[ End of page ]

Strictly speaking info on installing Ubuntu doesn't belong in the desktop help but in my opinion it's an obvious place to look for it. As far as I can see there's no exact equivalent to the above text at www.ubuntu.com (why not?). If there was we could just link to it.

Would something like this be of use to (some) users?

Gunnar Hjalmarsson (gunnarhj) wrote :

On 2017-01-26 22:56, Chris Perry wrote:
> Strictly speaking info on installing Ubuntu doesn't belong in the
> desktop help but in my opinion it's an obvious place to look for it.

I disagree on the obviousness.

> As far as I can see there's no exact equivalent to the above text at
> www.ubuntu.com (why not?). If there was we could just link to it.

If you see room for improvements as regards how those pages are structured, wouldn't it be smarter to file an issue?

https://github.com/ubuntudesign/www.ubuntu.com/issues/

Chris Perry (clissold345) wrote :

OK. So can we change the status of this bug to "Won't Fix" (as you suggest) on the grounds that the desktop help doesn't cover installation at all (which includes any overview of installation and documentation of any installation-related problems, such as the ones you mentioned above)? If you agree, can you change the bug status?

Thanks for the github link. I'll have a look and I may well file an issue.

Gunnar Hjalmarsson (gunnarhj) wrote :

Yeah, let's close the ubuntu-docs task. Possibly the ubiquity task should be closed as well, but I leave it open for now.

Changed in ubuntu-docs (Ubuntu):
status: Confirmed → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related blueprints