running restricted-manager before installation can break system

Bug #114296 reported by Ori Avtalion on 2007-05-12
28
This bug affects 1 person
Affects Status Importance Assigned to Milestone
restricted-manager (Ubuntu)
High
Martin Pitt
ubiquity (Ubuntu)
Medium
Colin Watson

Bug Description

Binary package hint: ubiquity

After booting Ubuntu from the live cd I clicked on the restricted manager icon.
Then I enabled the ATI driver (aka fglrx). It prompted me to reboot but I didn't.

I clicked on the install icon to install Ubuntu.
When the intalled system laucnhed, X could not start.
The xorg.conf file had the fglrx driver configured, but it was not installed.

Two solutions I can think of:
* Disable the restricted-manager when running under ubuquity.
* Carry over the packages installed by restricted-manager into the new installation. (The settings are already migrated, but they're nothing without the packages)

Colin Watson (cjwatson) wrote :

Interesting point. I need some way to extract the list of required packages from restricted-manager in order to fix this.

Changed in ubiquity:
importance: Undecided → Medium
status: Unconfirmed → Confirmed
Martin Pitt (pitti) wrote :

If r-m maintained a list of /var/cache/restricted-manager/installed-packages, that should do it, right? A simple text file with one package per line. Lines would get removed again if the user disables a module.

Changed in restricted-manager:
assignee: nobody → pitti
importance: Undecided → High
status: Unconfirmed → In Progress
Martin Pitt (pitti) wrote :

Let's fix this in a hook in r-m itself.

<cjwatson> pitti: restricted-manager could ship a hook script in /usr/lib/ubiquity/target-config/ that just does whatever's necessary
<cjwatson> pitti: it can call 'apt-install <package>' (note: *not* a typo for 'apt-get install') to ensure that <package> remains installed
<cjwatson> pitti: arbitrary executables; you can query the debconf database, but please don't use INPUT or GO; it doesn't check exit code at the moment, but please exit 0 on success obviously
<cjwatson> oh and since it's connected to debconf please don't output stuff to stdout
<cjwatson> stderr is fine and will end up in syslog

Changed in ubiquity:
status: Confirmed → Rejected
Martin Pitt (pitti) wrote :

Fixed in bzr head.

Changed in restricted-manager:
status: In Progress → Fix Committed
Martin Pitt (pitti) wrote :

 restricted-manager (0.22) gutsy; urgency=low
 .
   [ Matteo Zandi ]
   * restricted-manager: moved back the linux-restricted-modules-$(uname -r)
     check to its original place (called only if no params are given), since
     it caused r-m to popup a message dialog on startup.
 .
   [ Martin Pitt ]
   * RestrictedManager/core.py: Introduce function get_os_name() which reads
     the OS name from lsb_release -is; this falls back to 'the operating
     system'.
   * RestrictedManager/core.py, RestrictedManager/ipw3945.py,
     restricted-manager: Avoid the word 'Ubuntu' where possible and replace it
     with a call to get_os_name() in the remaining cases, to avoid branding
     issues for derivatives.
   * po/de.po: Update again to test i18n.
   * Add RestrictedManager/restricted24.png to avoid
     blurry icon in the panel menu, and RestrictedManager/restricted.svg to get
     a non-blurry icon in the application window. Thanks to Jef! (LP: #103513)
     Remove the 32x32 pixel variant, since it's the same as the scalable one.
   * Move icons from RestrictedManager/ into icons/, since there are quite a
     few of them now.
   * *.desktop.in: Fix capitalization of Comment:. (LP: #105230)
   * restricted-manager: Raise notification timeout from five to ten seconds.
     (LP: #106278)
   * RestrictedManager/xorg_driver.py, enable()/disable(): Do not crash if
     Section "Modules" does not exist. Create it if necessary. (LP: #119562)
   * RestrictedManager/bcm43xx.py: Call parent methods properly.
   * RestrictedManager/core.py, FWHandler.enable(): unbind and re-bind all
     devices from the module to trigger reloading of the firmware. This avoids
     the necessity of a reboot. Do trigger the reboot notification for
     disable() though, since we do not have a chance of hot-removing the
     firmware from devices.
   * RestrictedManager/core.py, install_package(), uninstall_package(): Keep
     track of installed and removed packages in
     /var/cache/restricted-manager/installed_packages.
   * Add debian/restricted-manager.ubiquity: ubiquity hook to install all
     packages into the target system that have been installed with r-m. Since
     we copy xorg.conf, we need to copy video driver packages, too, to avoid
     wrecking the X in the target system. Install the script as
     /usr/lib/ubiquity/target-config/31restricted_manager_pkgs. (LP: #114296)

Changed in restricted-manager:
status: Fix Committed → Fix Released
Martin Pitt (pitti) wrote :

I tested this on the actual live system yesterday, and it's not yet fixed. The list is written, but nvidia-glx does not actually get installed into the target system.

Changed in restricted-manager:
status: Fix Released → In Progress
Martin Pitt (pitti) wrote :

<pitti> cjwatson: I just reopened bug 114296, btw; is apt-install restricted to packages which are already on the live system?
<pitti> cjwatson: when I uploaded r-m, I only ran the script to see that the executed apt-install commands are correct; however, yesterday I wasn't able to check whether the script was not ran in the first place, or apt-install didn't do anything
<cjwatson> pitti: it's not supposed to be, but ubiquity may be buggy there *shrug*
<cjwatson> pitti: I'd suggest closing the restricted-manager task and reopening the ubiquity task

Changed in ubiquity:
status: Invalid → New
Changed in restricted-manager:
status: In Progress → Fix Released
Colin Watson (cjwatson) on 2007-07-06
Changed in ubiquity:
assignee: nobody → kamion
status: New → In Progress
Colin Watson (cjwatson) on 2007-07-06
Changed in ubiquity:
status: In Progress → Fix Committed
Evan (ev) wrote :

ubiquity (1.5.5) gutsy; urgency=low

  [ Colin Watson ]
  * KDE frontend: Disable the KDE media notifier for the entire duration of
    installation (LP: #122500).
  * Rename gtk-ui to gtk_ui and kde-ui to kde_ui, to make it easier to
    subclass them.
  * If oem-config/enable is true, then:
    - Adjust title bar to indicate that Ubiquity is running in OEM mode.
    - Hardcode the user's full name to "OEM Configuration (temporary user)",
      the username to "oem", and the UID to 29999.
    - Install the appropriate oem-config-FRONTEND package on the target
      system.
    - Install a desktop file for oem-config-prepare on the oem user's
      desktop.
    - Ask for a unique identifier for this batch of installations, and save
      that in /var/log/installer/oem-id on the installed system.
  * Add a warning in d-i/source/README about modifying files in this
    directory.
  * GTK frontend:
    - Fix full-name error reason widget, and make the error reasons
      selectable.
    - Suppress some spurious uncaught exceptions on startup.
    - Don't reconfigure the username entry box as a combo box if
      migration-assistant didn't find any users.
  * Replicate the apt configuration done by base-installer (trust CD-ROMs,
    allow unauthenticated packages if debian-installer/allow_unauthenticated
    is true, bind-mount /cdrom into /target, and configure apt-cdrom/apt not
    to mount CD-ROMs).
  * Install packages passed to apt-install even if they aren't on the live
    filesystem, as long as they're available from the apt archive on the CD
    (LP: #114296).

  [ Evan Dandrea ]
  * Initial commit of ubiquity-automation work:
    - Added a new frontend, noninteractive.
    - debconffilter now respects the "seen" flag when running in automatic
      mode.

  [ Mario Limonciello ]
  * Merge in mythbuntu alpha 2 changes.
  * Set all mythbuntu labels to word wrap.
  * Add mythbuntu to translatable files.

  [ Evan Dandrea ]
  * Automatic update of included source packages: base-installer
    1.80ubuntu2, hw-detect 1.53ubuntu1, silo-installer 1.10ubuntu4.

 -- Evan Dandrea <email address hidden> Wed, 11 Jul 2007 10:34:53 +0100

Changed in ubiquity:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers