dapper ubqiuty crashed over PPC partitioning

Bug #112119 reported by KarlGoetz on 2007-05-03
4
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
Undecided
Andreas Moog

Bug Description

Binary package hint: ubiquity

Leading up to this bug was roughtly this:

i installed ubuntu using default ('use entire drive'), onto hda
reran the installer and chose custom partitioning (first run was to create the boot partitions)
the label editor apeared and i put in 5 lines
/dev/hda3 /
/dev/hda4 /home
/dev/hda5 /mnt/ubuntumirror
/dev/hda6 swap

i hit next, noticed i hadnt put one in, then added it (assuming the next hadnt worked).
/dev/hdd3 /mnt/oldsystem
or
/dev/hdd3 /mnt/oldhome
(i cant remember which if either of these is correct, but they look ok)

the last page loaded, and it didnt have the last system i added. i tried goin back to labeling and forward again and it wouldnt appear.

i pressed 'isntall' figuring i can add it afterwards.
ubiquity popped up a message saying 'you need an hfs partition <this long>, with contine and go back options,
i pressed 'go back' and it crashed.

Ubuntquity gave this output:

Traceback (most recent call last):
  File "/usr/lib/python2.4/site-packages/ubiquity/frontend/gtkui.py", line 1169, in watch_debconf_fd_helper
    return callback(source, debconf_condition)
  File "/usr/lib/python2.4/site-packages/ubiquity/filteredcommand.py", line 154, in process_input
    self.exit_ui_loops()
  File "/usr/lib/python2.4/site-packages/ubiquity/filteredcommand.py", line 269, in exit_ui_loops
    self.frontend.quit_main_loop()
  File "/usr/lib/python2.4/site-packages/ubiquity/frontend/gtkui.py", line 1600, in quit_main_loop
    gtk.main_quit()
RuntimeError: called outside of a mainloop

I'll attach the logs requested.

Wasnt sure if this was a dupe, so filed it anyway

KarlGoetz (kgoetz) wrote :
KarlGoetz (kgoetz) wrote :

the last post is /var/log/installer/syslog.

my /var/log/syslog is empty.

/var/log/partman is attached here.

I just noticed the time is wrong now too - perhaps its related (looks like it/i got GMT wrong)

sorry if this post dupes

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Thank you for taking the time to report this bug and helping to make
Ubuntu better. You reported this bug a while ago and there hasn't been
any activity in it recently. We were wondering is this still an issue
for you? Can you try with latest Ubuntu release? Thanks in advance.

 status incomplete
 assignee <email address hidden>
 subscribe

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.9 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

iEYEARECAAYFAkit4xQACgkQ06FgkPZwicQO1QCfRroSdEHQC3ePlcxjUfFs7KkD
LikAnjdGKjyfsFAsmZem2GMLMjR4JKGp
=1KxK
-----END PGP SIGNATURE-----

Changed in ubiquity:
assignee: nobody → andreas-moog
status: New → Incomplete

On Thu, 2008-08-21 at 21:50 +0000, Andreas Moog wrote:
> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA1
>
> Thank you for taking the time to report this bug and helping to make
> Ubuntu better. You reported this bug a while ago and there hasn't been
> any activity in it recently. We were wondering is this still an issue
> for you? Can you try with latest Ubuntu release? Thanks in advance.

Trying with the latest release would be moot wouldnt it, as PPC is no
longer supported?
Or do you mean an 'ubuntu 6.06.2' cd?
kk

>
--
Karl Goetz <email address hidden>

Andreas Moog (ampelbein) wrote :

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Have you already tried with the 6.06.2-install cd?

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.9 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

iEYEARECAAYFAkiufEEACgkQ06FgkPZwicQoIgCg7qaTMXxe8OvZ7FEZqKkIAVNO
v50AnjUlRaXO6hH/CVpxPaBHU8y9tE/p
=ck7c
-----END PGP SIGNATURE-----

KarlGoetz (kgoetz) wrote :

On Fri, 2008-08-22 at 08:43 +0000, Andreas Moog wrote:
> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA1
>
> Have you already tried with the 6.06.2-install cd?

No, i've not tried to use the system in question recently.

Colin Watson (cjwatson) wrote :

This crash was fixed a long time ago, as bug 54163. Sorry I didn't notice this bug before now.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments