6.10 install erased my LVM volumes

Bug #110682 reported by rockyl on 2007-04-28
4
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
Undecided
Unassigned

Bug Description

First a little history. I've been a Linux user since 1995. I've heard such good things about Ubuntu I thought I would switch from Fedora Core 6. I've been running FC6 on an LVM partition for months. I noticed here that you need to download and boot from an alternative CD, so I downloaded Feisty-alt. (BTW, the 30 minute wait for it to find the LVM volumes really sucks.) No luck. I didn't install Grub since it was already installed, and just modified the existing grub.conf. After rebooting it uncompressed vmlinuz but soon after it hung. I rebooted FC6 and it was OK.

I figured I had enough normal partition space to try the standard desktop CD, so I downloaded 6.10 live. I did an apt-get on lvm2 just in case the install program might find my LVM volumes. No luck again, but I proceeded with the install. I chose to install Grub on one of the partitions since there didn't appear to be an option not to install it, and I didn't want to overwrite the existing one. BTW this partition was on hda and my LVM was on hdb. The installation proceeded and finished. I had to reboot to FC6 to play with grub.conf, so I tried that.

FC6 tried to boot but reported that it couldn't locate any LVM volumes. I booted my FC7 live CD and it can find the physical volume, but there are no logical volumes. My entire FC6 is wiped out. Luckily I made a backup of my /home directories, but it will be a pain to rebuild everything.

Disk partition info:

hda
  1 - NTFS Windows installation
  2 - ext3 FC6 boot
  3 - unused Linux partition
  4 - extended partition
    5 - unused Linux
    6 - unused Linux - told Ubuntu to install grub here

hdb
  1 FAT32 Windows
  2 Linux 10 Gig - used to install 6.10
  3 Swap
  4 LVM partition
     00 - FC6 /home
     01 - unused
     02 - unused
     04 - FC6 /usr
     05 - FC6 /
     06 - unused

Andreas Moog (ampelbein) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. You reported this bug a while ago and there hasn't been any activity in it recently. We were wondering is this still an issue for you? Can you try with latest Ubuntu release? Thanks in advance.

Changed in ubiquity:
assignee: nobody → andreas-moog
status: New → Incomplete
Andreas Moog (ampelbein) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New". Thanks again!

Changed in ubiquity:
assignee: andreas-moog → nobody
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers