Xubuntu 7.04 installation does not detect existing partitions

Bug #108804 reported by debianmigrant on 2007-04-22
10
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
Undecided
Unassigned

Bug Description

I am facing couple of issues with Xubuntu 7.04 installation. Here is my setup...

1) I have an old machine - 400 MHz Pentium II with 256 MB RAM and 20 GB hard drive.

2) First, I partitioned my 20 GB hard drive using fdisk as follows...
Primary partition C: - 8 GB
Extended partition
    Logical drive 1: 6 GB (will use this for "/")
    Logical drive 2: 1 GB (will use this for "swap")
    Logical drive 3: 6 GB (will use this for "shared")

3) I installed Windows 98 on primary partition. Everything works fine.

4) I burnt the Xubuntu 7.04 Desktop CD using the .iso from this location - http://cdimage.ubuntu.com/xubuntu/releases/7.04/release/xubuntu-7.04-desktop-i386.iso

5) I booted using the Xubuntu Desktop CD. Xubuntu menu shows up and I verified that the CD is okay. I then clicked on the first link to launch Xubuntu from the Desktop CD.

Here are the issues...
1) I am assuming the Xubuntu Desktop CD is a "Live CD". I see the following icons on the desktop - "Windows" (which is my C: Win98 installation", "Floppy drive", "Trash", "Home", "File System", "Examples", "Install".
I don't see any menus at all. Shouldn't I see a menu bar at the top and bottom with "Applications" at the top? I used to see it with the Xubuntu 6.10 Desktop CD. Is there a bug in the Xubuntu 7.04 Desktop CD?

2) I clicked on "Install" to start the installation. On the "Prepare disk space" screen, I selected the "Manual" option. When I get to the "Prepare partitions" screen, it does not detect my Windows partition and the 3 volumes on the extended partition. It wants to partition the entire disk.
The Xubuntu 6.10 Desktop CD detected this scenario without a problem and I was able to format the "/" and "swap" partitions as "ext3".
Is there a bug in the Xubuntu 7.04 Desktop CD?

I am stuck. How do I proceed? I am hoping the answer is not "use the command line installer". The GUI partition tool in Xubuntu 6.10 seemed much better.

I have the problem in Ubuntu 7.04 installation on my desktop (with the desktop CD):
Intel D875PBZ Motherboard using an IDE WB 160GB Caviar drive.

It looks as if the live cd in general is not finding/mounting your hard drive. Ive even tried gparted and even mounting the drive but it cant find it. I wonder if this has something to do with the -15 kernel. I have feisty on this machine now but I upgraded a long time ago and just have been doing my daily updates for fesity and something I noticed is I had problems with the -13 kernel through -15. They fixed the -13 kernel but they released two others that do not work with my hardware. I get dropped to:
Busybox
"/bin/sh: Can't access tty; Job control turned off"

Might this be related? If anybody knows please help us in need here ;)

Thanks

Stu (wien33) wrote :

Compuer:
AMD Athelon 2200+
512M DDR Ram
PC Chips 825G MB
HD Seagate 100G IDE

I tried installing both Xubuntu and Kubuntu 7.04 and ran into similar issues. When choosing either to resize the partitions or installing to the entire disk, the installer started then opened the "media" file browser along with a message box that said there was a problem reading the hda1 ext3 partition which needed to be corrected. Clicking "Continue" aborted the install, and clicking "Go Back" dropped me back to the keyboard setup. Continuing from there simply repeated the problem. I got the installation to proceed successfully (I'm using Xubuntu now) after choosing "Manual" partitioning, deleting all existing partitions, re-partitioning and formatting to 1Gb for "swap", 5Gb ext3 for "/", and the rest to ext3 "/home", but I don't know how that will work with multiple boot systems. This same computer installed Ubuntu 6.10 without any problems.
I hope this info proves helpful.

Charlie Kravetz (charlie-tca) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. However, I am closing it because the bug has been fixed in the latest development version of Ubuntu - the Intrepid Ibex.

Feel free to continue to report any other bugs you may find.

Changed in ubiquity:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers