Partitioning options do not come up in ubiquity & d-i

Bug #1085991 reported by Rohan Garg on 2012-12-03
34
This bug affects 7 people
Affects Status Importance Assigned to Milestone
partman-auto (Ubuntu)
High
Dimitri John Ledkov
ubiquity (Ubuntu)
High
Unassigned

Bug Description

For some reason the installer get's stuck at "Preparing to install Kubuntu" due to which a user cannot install Kubuntu

ProblemType: Bug
DistroRelease: Ubuntu 13.04
Package: ubiquity 2.13.6 [modified: lib/partman/automatically_partition/question]
ProcVersionSignature: Ubuntu 3.7.0-4.12-generic 3.7.0-rc7
Uname: Linux 3.7.0-4-generic x86_64
ApportVersion: 2.6.3-0ubuntu2
Architecture: amd64
CasperVersion: 1.329
Date: Mon Dec 3 14:37:28 2012
InstallCmdLine: BOOT_IMAGE=(loop)/casper/vmlinuz boot=casper iso-scan/filename=/iso/raring-desktop-amd64+mac.iso noprompt noeject radeon.modeset=0
LiveMediaBuild: Kubuntu 13.04 "Raring Ringtail" - Alpha amd64+mac (20121203)
MarkForUpload: True
SourcePackage: ubiquity
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Rohan Garg (rohangarg) wrote :
Dimitri John Ledkov (xnox) wrote :

Ubiquity 2.13.6
Error: "/var/tmp/kdecache-kubuntu" is owned by uid 999 instead of uid 0.
mkdir failed: : Permission denied
TEXT <small>If more than one person will use this computer, you can set up multiple accounts after installation.</small>
TEXT <small>Enter the same password twice, so that it can be checked for typing errors.</small>
TEXT <small>The name it uses when it talks to other computers.</small>
TEXT <small>If more than one person will use this computer, you can set up multiple accounts after installation.</small>
TEXT <small>Enter the same password twice, so that it can be checked for typing errors.</small>
TEXT <small>The name it uses when it talks to other computers.</small>
QSocketNotifier: Invalid socket 15 and type 'Read', disabling...
QSocketNotifier: Invalid socket 15 and type 'Exception', disabling...
QSocketNotifier: Invalid socket 15 and type 'Write', disabling...
QSocketNotifier: Invalid socket 15 and type 'Read', disabling...
QSocketNotifier: Invalid socket 15 and type 'Exception', disabling...
QSocketNotifier: Invalid socket 15 and type 'Write', disabling...

Rohan Garg (rohangarg) wrote :

After messing around with the partitions a bit ( by which I mean deleting all of them ), I got the installer to work.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubiquity (Ubuntu):
status: New → Confirmed
Dimitri John Ledkov (xnox) wrote :

Resize/reuse are getting stuck at ntfs (see below) and or possibly fat partitions (myself):

<xnox> $ sudo chmod -x /lib/partman/automatically_partition/*5*/choices
<xnox> when ubiquity comes up, but before clicking next on the prepare step.
<xnox> and please tell me if that fixes for you.
<shadeslayer> afiestas: ^ since you probably are the one who can test this the quickest
<xnox> I have managed to kind of reproduce it with a fat partition, but ntfs might be also a trigger for this bug.
<afiestas> xnox: if I kill ubiquity and startit again, will it work?
<afiestas> or should I do a clean start?
<xnox> afiestas: if you already had a hang, killing ubiquity will not help.
<xnox> afiestas: just reboot.
<afiestas> ookz
<afiestas> restarting then
<afiestas> xnox: worked
<xnox> afiestas: now, tell me a lot of how you booted and how many disks you had attached to your system.
<xnox> afiestas: did you boot from USB or CD?
<afiestas> oks
<afiestas> I booted from USB
<afiestas> dd if of the image
<xnox> afiestas: how many hard-drives do you have?
<afiestas> I had windows 8 installed, using the whole harddisk (it is a laptop, only have 1)
<xnox> afiestas: that's it?
<afiestas> the machien is a dell XPS1330 the ones that shipped with Ubuntu years ago
<xnox> afiestas: ok. thanks a lot.
<afiestas> yes

Dimitri John Ledkov (xnox) wrote :

Both reuse & replace recipes use blkid, in my local experimentation I did managed to get blkid to hang on fat32 partition approximately similar to bug 987718 and bug 1044111.

But that got me thinking - both recipes are trying to detect existing ubuntu installations which should not be on a fat32/ntfs/hfs/swap partitions, so I want to skip mounting those & skip using blkid.

Changed in partman-auto (Ubuntu):
status: New → Confirmed
assignee: nobody → Dmitrijs Ledkovs (xnox)
importance: Undecided → High
Changed in ubiquity (Ubuntu):
importance: Undecided → High
summary: - Ubiquity stuck at "Preparing to install Kubuntu"
+ Partitioning options do not come up in ubiquity & d-i
Oded Arbel (oded-geek) wrote :

I'm having the same problem.Doing what Dmitrijs Ledkovs sait in comment#5 fixed it for me.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package partman-auto - 105ubuntu2

---------------
partman-auto (105ubuntu2) raring; urgency=low

  * Reuse & Replace recipes:
    - Avoid using blkid, as it may sometimes hang indefinitely without
      timing out. See blkid bugs http://pad.lv/987718 and
      http://pad.lv/1044111. This change should address (LP: #1085991)
    - Skip mounting filesystems that ought to not be Ubuntu root
      filesystems (empty, swap, fat, ntfs, hfs). This also should speed up
      automatic partitioning page.
    - Silence warnings from umount in the clean-up (typically should
      already be unmounted)
 -- Dmitrijs Ledkovs <email address hidden> Wed, 02 Jan 2013 14:00:50 +0000

Changed in partman-auto (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers